aboutsummaryrefslogtreecommitdiff
path: root/audio/libmad/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-10-11 22:20:46 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-10-11 22:20:46 +0000
commitd52971d56c7520e7b8af206bc70e05cceed295a5 (patch)
tree0a1c21400c310a4002ada8e2e90f32816e5e79c8 /audio/libmad/Makefile
parent9ee8737b33d36e343157b8ee0da8055e3d7eb5a7 (diff)
downloadports-d52971d56c7520e7b8af206bc70e05cceed295a5.tar.gz
ports-d52971d56c7520e7b8af206bc70e05cceed295a5.zip
Notes
Diffstat (limited to 'audio/libmad/Makefile')
-rw-r--r--audio/libmad/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/audio/libmad/Makefile b/audio/libmad/Makefile
index f2b8c0d265cf..4c8079aad95b 100644
--- a/audio/libmad/Makefile
+++ b/audio/libmad/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libmad
PORTVERSION= 0.15.1b
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
ftp://ftp.mars.org/pub/mpeg/
@@ -16,9 +17,17 @@ MAINTAINER= asa@gascom.ru
COMMENT= Libmad library (part of MAD project)
USE_INC_LIBTOOL_VER= 13
+USE_GNOME= pkgconfig
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --disable-debugging \
--enable-sso \
--enable-accuracy
+post-patch:
+ @${SED} -e 's|%PREFIX%|${PREFIX}|g ; s|%VERSION%|${PORTVERSION}|g' \
+ ${FILESDIR}/mad.pc.in > ${WRKDIR}/mad.pc
+
+post-install:
+ ${INSTALL_DATA} ${WRKDIR}/mad.pc ${PREFIX}/libdata/pkgconfig
+
.include <bsd.port.mk>