aboutsummaryrefslogtreecommitdiff
path: root/audio/libmatemixer
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2015-07-27 20:19:33 +0000
committerKoop Mast <kwm@FreeBSD.org>2015-07-27 20:19:33 +0000
commitb18513c396f0da554f784695a222d8383acd7127 (patch)
tree0d276f72ec80621ae31f35239a1c27ae16c21bba /audio/libmatemixer
parentd6c984cb28fe817c6db7ba577f9eb98928bacd1e (diff)
downloadports-b18513c396f0da554f784695a222d8383acd7127.tar.gz
ports-b18513c396f0da554f784695a222d8383acd7127.zip
Update MATE DE to 1.10.0.
This MATE is still build agains GTK+2. Sort USES here and there. Replace mate-dialogs with zenity and mate-calc with galculator. This update fixes the following PR's: PR: 193942, 191885 Submitted by: Gustau Perez <gustau.perez@gmail.com> via Gnome devel repo Obtained from: gnome devel repo.
Notes
Notes: svn path=/head/; revision=393031
Diffstat (limited to 'audio/libmatemixer')
-rw-r--r--audio/libmatemixer/Makefile32
-rw-r--r--audio/libmatemixer/distinfo2
-rw-r--r--audio/libmatemixer/pkg-descr6
-rw-r--r--audio/libmatemixer/pkg-plist52
4 files changed, 92 insertions, 0 deletions
diff --git a/audio/libmatemixer/Makefile b/audio/libmatemixer/Makefile
new file mode 100644
index 000000000000..c7c9210a8b10
--- /dev/null
+++ b/audio/libmatemixer/Makefile
@@ -0,0 +1,32 @@
+# $FreeBSD$
+
+PORTNAME= libmatemixer
+PORTVERSION= 1.10.0
+CATEGORIES= audio mate
+MASTER_SITES= MATE
+DIST_SUBDIR= mate
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Mixer library for MATE desktop
+
+LICENSE= LGPL21
+
+USES= gettext libtool pathfix pkgconfig tar:xz
+USE_GNOME= glib20 intltool
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-null \
+ --enable-oss \
+ --disable-gtk-doc \
+ --disable-gtk-doc-html \
+ --disable-gtk-doc-pdf
+INSTALL_TARGET= install-strip
+
+OPTIONS_DEFINE= PULSEAUDIO ALSA
+OPTIONS_SUB= yes
+
+PULSEAUDIO_CONFIGURE_ENABLE= pulseaudio
+PULSEAUDIO_LIB_DEPENDS= libpulse.so:${PORTSDIR}/audio/pulseaudio
+ALSA_CONFIGURE_ENABLE= alsa
+ALSA_LIB_DEPENDS= libasound.so:${PORTSDIR}/audio/alsa-lib
+
+.include <bsd.port.mk>
diff --git a/audio/libmatemixer/distinfo b/audio/libmatemixer/distinfo
new file mode 100644
index 000000000000..b72f0caa0425
--- /dev/null
+++ b/audio/libmatemixer/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mate/libmatemixer-1.10.0.tar.xz) = a4edc285fa07e6f556a3d6e384c7535f26d3a0bbe1cdc56eadd4f0c034ee5551
+SIZE (mate/libmatemixer-1.10.0.tar.xz) = 380208
diff --git a/audio/libmatemixer/pkg-descr b/audio/libmatemixer/pkg-descr
new file mode 100644
index 000000000000..6ea6ce6c0270
--- /dev/null
+++ b/audio/libmatemixer/pkg-descr
@@ -0,0 +1,6 @@
+libmatemixer is a mixer library for MATE desktop.
+
+It provides an abstract API allowing access to mixer functionality available
+in the PulseAudio, ALSA and OSS sound systems.
+
+WWW: https://github.com/mate-desktop/libmatemixer
diff --git a/audio/libmatemixer/pkg-plist b/audio/libmatemixer/pkg-plist
new file mode 100644
index 000000000000..0c64f2bc2e05
--- /dev/null
+++ b/audio/libmatemixer/pkg-plist
@@ -0,0 +1,52 @@
+include/mate-mixer/libmatemixer/matemixer-app-info.h
+include/mate-mixer/libmatemixer/matemixer-context.h
+include/mate-mixer/libmatemixer/matemixer-device-switch.h
+include/mate-mixer/libmatemixer/matemixer-device.h
+include/mate-mixer/libmatemixer/matemixer-enum-types.h
+include/mate-mixer/libmatemixer/matemixer-enums.h
+include/mate-mixer/libmatemixer/matemixer-stored-control.h
+include/mate-mixer/libmatemixer/matemixer-stream-control.h
+include/mate-mixer/libmatemixer/matemixer-stream-switch.h
+include/mate-mixer/libmatemixer/matemixer-stream-toggle.h
+include/mate-mixer/libmatemixer/matemixer-stream.h
+include/mate-mixer/libmatemixer/matemixer-switch-option.h
+include/mate-mixer/libmatemixer/matemixer-switch.h
+include/mate-mixer/libmatemixer/matemixer-types.h
+include/mate-mixer/libmatemixer/matemixer-version.h
+include/mate-mixer/libmatemixer/matemixer.h
+lib/libmatemixer.a
+lib/libmatemixer.so
+lib/libmatemixer.so.0
+lib/libmatemixer.so.0.0.0
+%%ALSA%%lib/libmatemixer/libmatemixer-alsa.a
+%%ALSA%%lib/libmatemixer/libmatemixer-alsa.so
+lib/libmatemixer/libmatemixer-oss.a
+lib/libmatemixer/libmatemixer-oss.so
+%%PULSEAUDIO%%lib/libmatemixer/libmatemixer-pulse.a
+%%PULSEAUDIO%%lib/libmatemixer/libmatemixer-pulse.so
+libdata/pkgconfig/libmatemixer.pc
+share/gtk-doc/html/libmatemixer/MateMixerAppInfo.html
+share/gtk-doc/html/libmatemixer/MateMixerContext.html
+share/gtk-doc/html/libmatemixer/MateMixerDevice.html
+share/gtk-doc/html/libmatemixer/MateMixerDeviceSwitch.html
+share/gtk-doc/html/libmatemixer/MateMixerStoredControl.html
+share/gtk-doc/html/libmatemixer/MateMixerStream.html
+share/gtk-doc/html/libmatemixer/MateMixerStreamControl.html
+share/gtk-doc/html/libmatemixer/MateMixerStreamSwitch.html
+share/gtk-doc/html/libmatemixer/MateMixerStreamToggle.html
+share/gtk-doc/html/libmatemixer/MateMixerSwitch.html
+share/gtk-doc/html/libmatemixer/MateMixerSwitchOption.html
+share/gtk-doc/html/libmatemixer/api-index-full.html
+share/gtk-doc/html/libmatemixer/ch01.html
+share/gtk-doc/html/libmatemixer/home.png
+share/gtk-doc/html/libmatemixer/index.html
+share/gtk-doc/html/libmatemixer/index.sgml
+share/gtk-doc/html/libmatemixer/left-insensitive.png
+share/gtk-doc/html/libmatemixer/left.png
+share/gtk-doc/html/libmatemixer/libmatemixer-MateMixer.html
+share/gtk-doc/html/libmatemixer/libmatemixer.devhelp2
+share/gtk-doc/html/libmatemixer/right-insensitive.png
+share/gtk-doc/html/libmatemixer/right.png
+share/gtk-doc/html/libmatemixer/style.css
+share/gtk-doc/html/libmatemixer/up-insensitive.png
+share/gtk-doc/html/libmatemixer/up.png