aboutsummaryrefslogtreecommitdiff
path: root/audio/libmp3splt
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2013-07-25 18:30:17 +0000
committerJohn Marino <marino@FreeBSD.org>2013-07-25 18:30:17 +0000
commitab73db34fb64ce7733ab35d0b79e20be18dd1d04 (patch)
tree0e85be3e22a47e7a931e92f2b0275eb415dc6139 /audio/libmp3splt
parente3d11f460c534f6026e597b161519865f4b3f51a (diff)
downloadports-ab73db34fb64ce7733ab35d0b79e20be18dd1d04.tar.gz
ports-ab73db34fb64ce7733ab35d0b79e20be18dd1d04.zip
audio/libmp3splt: Fix configure script test for modern binutils
The id3tag library will fail to be detected on systems using ld from recent binutils. This is because libid3tag is linked without zlib also being linked directly, and be default it doesn't search libraries linked to linked libraries. The configure script is patched with "-lz" to fix. Also remove redundant MAKE_JOBS_SAFE while we are here. Approved by: bapt (mentor), maintainer
Notes
Notes: svn path=/head/; revision=323660
Diffstat (limited to 'audio/libmp3splt')
-rw-r--r--audio/libmp3splt/Makefile1
-rw-r--r--audio/libmp3splt/files/patch-configure11
2 files changed, 11 insertions, 1 deletions
diff --git a/audio/libmp3splt/Makefile b/audio/libmp3splt/Makefile
index 55e0d2525738..e9417f82b72f 100644
--- a/audio/libmp3splt/Makefile
+++ b/audio/libmp3splt/Makefile
@@ -16,7 +16,6 @@ CONFIGURE_ARGS= --disable-cutter --disable-doxygen_doc
USES= pathfix
USE_LDCONFIG= yes
USE_AUTOTOOLS= libltdl
-MAKE_JOBS_SAFE= yes
OPTIONS_MULTI= plugin
OPTIONS_MULTI_plugin= MAD VORBIS
diff --git a/audio/libmp3splt/files/patch-configure b/audio/libmp3splt/files/patch-configure
new file mode 100644
index 000000000000..29a81eceafe0
--- /dev/null
+++ b/audio/libmp3splt/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2013-07-25 15:33:15.000000000 +0000
++++ configure
+@@ -15422,7 +15422,7 @@ elif test "x$prefix" != "xNONE"; then
+ ID3_LIBS="-L$prefix/lib"
+ fi
+
+-ID3_LIBS="$ID3_LIBS -lid3tag"
++ID3_LIBS="$ID3_LIBS -lid3tag -lz"
+
+ if test "x$id3_includes" != "x"; then
+ ID3_CFLAGS="-I$id3_includes"