aboutsummaryrefslogtreecommitdiff
path: root/audio/libsamplerate
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-11-23 22:44:00 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-11-23 22:44:00 +0000
commiteacb409b768c6d480ee18babc2bca6381534d917 (patch)
tree585e1fcf5beeae3f8a7988694339f6c4c5657878 /audio/libsamplerate
parent89e87d4771ee91b75945e1715054165dd837d17e (diff)
downloadports-eacb409b768c6d480ee18babc2bca6381534d917.tar.gz
ports-eacb409b768c6d480ee18babc2bca6381534d917.zip
Remove ',' at the end of the last entry of emumerator list.
While here Stageify port, update LIB_DEPEND syntax and depend on package name instead of looking for a file. PR: ports/161568 Submitted by: Takefu <takefu@airport.fm>
Notes
Notes: svn path=/head/; revision=334696
Diffstat (limited to 'audio/libsamplerate')
-rw-r--r--audio/libsamplerate/Makefile10
-rw-r--r--audio/libsamplerate/files/patch-src_samplerate.h11
2 files changed, 17 insertions, 4 deletions
diff --git a/audio/libsamplerate/Makefile b/audio/libsamplerate/Makefile
index 8820fd8c7289..5eaf67ca04aa 100644
--- a/audio/libsamplerate/Makefile
+++ b/audio/libsamplerate/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libsamplerate
PORTVERSION= 0.1.8
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= audio
MASTER_SITES= http://www.mega-nerd.com/SRC/
@@ -14,7 +14,6 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
USES= pathfix pkgconfig
-NO_STAGE= yes
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
@@ -38,9 +37,9 @@ CONFIGURE_ARGS+= --disable-fftw
.endif
.if ${PORT_OPTIONS:MEXAMPLES}
-LIB_DEPENDS+= sndfile.1:${PORTSDIR}/audio/libsndfile
+LIB_DEPENDS+= libsndfile.so:${PORTSDIR}/audio/libsndfile
.elif defined(MAINTAINER_MODE) || defined(PACKAGE_BUILDING)
-BUILD_DEPENDS += ${LOCALBASE}/lib/libsndfile.so:${PORTSDIR}/audio/libsndfile
+BUILD_DEPENDS += libsndfile>=0:${PORTSDIR}/audio/libsndfile
.else
CONFIGURE_ARGS+= --disable-sndfile
.endif
@@ -59,4 +58,7 @@ check regression-test test: build
check
.endif
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libsamplerate.so.1
+
.include <bsd.port.mk>
diff --git a/audio/libsamplerate/files/patch-src_samplerate.h b/audio/libsamplerate/files/patch-src_samplerate.h
new file mode 100644
index 000000000000..171ecfee62bd
--- /dev/null
+++ b/audio/libsamplerate/files/patch-src_samplerate.h
@@ -0,0 +1,11 @@
+--- src/samplerate.h.orig 2013-11-23 23:36:11.000000000 +0100
++++ src/samplerate.h 2013-11-23 23:36:25.000000000 +0100
+@@ -174,7 +174,7 @@
+ SRC_SINC_MEDIUM_QUALITY = 1,
+ SRC_SINC_FASTEST = 2,
+ SRC_ZERO_ORDER_HOLD = 3,
+- SRC_LINEAR = 4,
++ SRC_LINEAR = 4
+ } ;
+
+ /*