aboutsummaryrefslogtreecommitdiff
path: root/audio/libshairport
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-07-26 16:51:15 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-07-26 16:51:15 +0000
commit9fa9eb9ac7bf1d3de825ee25a8f0ae81b7b77896 (patch)
tree9b071a8105704e992946dcd6b801e9fcb7635142 /audio/libshairport
parent5a20e7990eb544509174d617d359bf0d4ac64737 (diff)
downloadports-9fa9eb9ac7bf1d3de825ee25a8f0ae81b7b77896.tar.gz
ports-9fa9eb9ac7bf1d3de825ee25a8f0ae81b7b77896.zip
Cleanup patches, a* categories.
Rename them to follow the make makepatch naming, and regenerate them. With hat: portmgr Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=419133
Diffstat (limited to 'audio/libshairport')
-rw-r--r--audio/libshairport/files/patch-configure.in8
-rw-r--r--audio/libshairport/files/patch-src_Makefile.am (renamed from audio/libshairport/files/patch-src-Makefile.am)4
-rw-r--r--audio/libshairport/files/patch-src_alac.c (renamed from audio/libshairport/files/patch-src-alac.c)14
-rw-r--r--audio/libshairport/files/patch-src_ao.h (renamed from audio/libshairport/files/patch-src-ao.h)4
-rw-r--r--audio/libshairport/files/patch-src_hairtunes.c (renamed from audio/libshairport/files/patch-src-hairtunes.c)40
-rw-r--r--audio/libshairport/files/patch-src_hairtunes.h (renamed from audio/libshairport/files/patch-src-hairtunes.h)4
-rw-r--r--audio/libshairport/files/patch-src_shairport.c (renamed from audio/libshairport/files/patch-src-shairport.c)92
-rw-r--r--audio/libshairport/files/patch-src_shairport.h (renamed from audio/libshairport/files/patch-src-shairport.h)6
-rw-r--r--audio/libshairport/files/patch-src_socketlib.c (renamed from audio/libshairport/files/patch-src-socketlib.c)16
9 files changed, 94 insertions, 94 deletions
diff --git a/audio/libshairport/files/patch-configure.in b/audio/libshairport/files/patch-configure.in
index 1a51ff291521..3ac6b33f836b 100644
--- a/audio/libshairport/files/patch-configure.in
+++ b/audio/libshairport/files/patch-configure.in
@@ -1,6 +1,6 @@
---- configure.in.orig 2011-09-23 22:56:46.000000000 +0200
-+++ configure.in 2012-10-09 12:09:33.000000000 +0200
-@@ -11,8 +11,9 @@
+--- configure.in.orig 2011-09-23 20:56:46 UTC
++++ configure.in
+@@ -11,8 +11,9 @@ AC_PROG_LIBTOOL
# Checks for libraries.
#AC_CHECK_LIB([c], [main])
@@ -11,7 +11,7 @@
AC_CHECK_LIB([pthread], [main],, AC_MSG_ERROR($missing_library))
OUTPUT_FILES="Makefile"
-@@ -21,4 +22,4 @@
+@@ -21,4 +22,4 @@ LIBDIR=$PREFIX
AC_CONFIG_FILES([${OUTPUT_FILES}])
AC_OUTPUT(Makefile src/Makefile)
diff --git a/audio/libshairport/files/patch-src-Makefile.am b/audio/libshairport/files/patch-src_Makefile.am
index 4f1d46973aee..2273cf45b9ce 100644
--- a/audio/libshairport/files/patch-src-Makefile.am
+++ b/audio/libshairport/files/patch-src_Makefile.am
@@ -1,5 +1,5 @@
---- src/Makefile.am.orig 2011-09-23 23:14:39.000000000 +0200
-+++ src/Makefile.am 2012-10-09 12:09:33.000000000 +0200
+--- src/Makefile.am.orig 2011-09-23 21:14:39 UTC
++++ src/Makefile.am
@@ -1,7 +1,7 @@
lib_LTLIBRARIES=libshairport.la
diff --git a/audio/libshairport/files/patch-src-alac.c b/audio/libshairport/files/patch-src_alac.c
index 8face193c68f..477b6f2f3a3b 100644
--- a/audio/libshairport/files/patch-src-alac.c
+++ b/audio/libshairport/files/patch-src_alac.c
@@ -1,6 +1,6 @@
---- src/alac.c.orig 2011-08-21 00:06:21.000000000 +0200
-+++ src/alac.c 2012-10-09 12:09:33.000000000 +0200
-@@ -804,7 +804,7 @@
+--- src/alac.c.orig 2011-08-20 22:06:21 UTC
++++ src/alac.c
+@@ -804,7 +804,7 @@ void decode_frame(alac_file *alac,
}
else
{
@@ -9,7 +9,7 @@
/* i think the only other prediction type (or perhaps this is just a
* boolean?) runs adaptive fir twice.. like:
* predictor_decompress_fir_adapt(predictor_error, tempout, ...)
-@@ -885,7 +885,7 @@
+@@ -885,7 +885,7 @@ void decode_frame(alac_file *alac,
}
case 20:
case 32:
@@ -18,7 +18,7 @@
break;
default:
break;
-@@ -1004,7 +1004,7 @@
+@@ -1004,7 +1004,7 @@ void decode_frame(alac_file *alac,
}
else
{ /* see mono case */
@@ -27,7 +27,7 @@
}
/* channel 2 */
-@@ -1029,7 +1029,7 @@
+@@ -1029,7 +1029,7 @@ void decode_frame(alac_file *alac,
}
else
{
@@ -36,7 +36,7 @@
}
}
else
-@@ -1106,7 +1106,7 @@
+@@ -1106,7 +1106,7 @@ void decode_frame(alac_file *alac,
}
case 20:
case 32:
diff --git a/audio/libshairport/files/patch-src-ao.h b/audio/libshairport/files/patch-src_ao.h
index 2e1ee3f78bcd..fdb8a165dafd 100644
--- a/audio/libshairport/files/patch-src-ao.h
+++ b/audio/libshairport/files/patch-src_ao.h
@@ -1,5 +1,5 @@
---- src/ao.h.orig 2012-10-09 12:33:01.000000000 +0200
-+++ src/ao.h 2012-10-09 12:09:33.000000000 +0200
+--- src/ao.h.orig 2016-07-26 15:10:45 UTC
++++ src/ao.h
@@ -0,0 +1,158 @@
+/*
+ *
diff --git a/audio/libshairport/files/patch-src-hairtunes.c b/audio/libshairport/files/patch-src_hairtunes.c
index b00621d1ea45..c79446151e87 100644
--- a/audio/libshairport/files/patch-src-hairtunes.c
+++ b/audio/libshairport/files/patch-src_hairtunes.c
@@ -1,5 +1,5 @@
---- src/hairtunes.c.orig 2011-09-23 21:55:48.000000000 +0200
-+++ src/hairtunes.c 2012-10-09 12:09:33.000000000 +0200
+--- src/hairtunes.c.orig 2011-09-23 19:55:48 UTC
++++ src/hairtunes.c
@@ -25,7 +25,7 @@
*/
@@ -18,7 +18,7 @@
#endif
#ifdef FANCY_RESAMPLING
-@@ -89,7 +89,6 @@
+@@ -89,7 +89,6 @@ int pipe_handle = -1;
// maximal resampling shift - conservative
#define OUTFRAME_BYTES (4*(frame_size+3))
@@ -26,7 +26,7 @@
alac_file *decoder_info;
#ifdef FANCY_RESAMPLING
-@@ -122,8 +121,8 @@
+@@ -122,8 +121,8 @@ pthread_mutex_t ab_mutex;
pthread_cond_t ab_buffer_ready;
static void die(char *why) {
@@ -37,7 +37,7 @@
}
static int hex2bin(unsigned char *buf, char *hex) {
-@@ -246,13 +245,13 @@
+@@ -246,13 +245,13 @@ int hairtunes_init(char *pAeskey, char *
continue;
}
if (!strcmp(line, "exit\n")) {
@@ -53,7 +53,7 @@
fflush(stderr);
#endif
-@@ -263,18 +262,28 @@
+@@ -263,18 +262,28 @@ void hairtunes_setvolume(float f)
{
assert(f<=0);
if (debug)
@@ -84,7 +84,7 @@
}
#ifdef HAIRTUNES_STANDALONE
-@@ -424,7 +433,7 @@
+@@ -424,7 +433,7 @@ static void buffer_put_packet(seq_t seqn
} else if (seq_order(ab_read, seqno)) { // late but not yet played
abuf = audio_buffer + BUFIDX(seqno);
} else { // too late.
@@ -93,7 +93,7 @@
}
buf_fill = ab_write - ab_read;
pthread_mutex_unlock(&ab_mutex);
-@@ -521,7 +530,7 @@
+@@ -521,7 +530,7 @@ static void rtp_request_resend(seq_t fir
if (seq_order(last, first))
return;
@@ -102,7 +102,7 @@
char req[8]; // *not* a standard RTCP NACK
req[0] = 0x80;
-@@ -605,8 +614,8 @@
+@@ -605,8 +614,8 @@ static int init_rtp(void) {
port += 3;
}
@@ -113,7 +113,7 @@
rtp_sockets[0] = sock;
rtp_sockets[1] = csock;
-@@ -709,7 +718,7 @@
+@@ -709,7 +718,7 @@ void bf_est_update(short fill) {
bf_est_drift = biquad_filt(&bf_drift_lpf, CONTROL_B*(bf_est_err*CONTROL_A + err_deriv) + bf_est_drift);
if (debug)
@@ -122,7 +122,7 @@
bf_playback_rate = 1.0 + CONTROL_A*bf_est_err + bf_est_drift;
bf_last_err = bf_est_err;
-@@ -725,7 +734,7 @@
+@@ -725,7 +734,7 @@ short *buffer_get_frame(void) {
buf_fill = ab_write - ab_read;
if (buf_fill < 1 || !ab_synced || ab_buffering) { // init or underrun. stop and wait
if (ab_synced)
@@ -131,7 +131,7 @@
ab_buffering = 1;
pthread_cond_wait(&ab_buffer_ready, &ab_mutex);
-@@ -737,7 +746,7 @@
+@@ -737,7 +746,7 @@ short *buffer_get_frame(void) {
return 0;
}
if (buf_fill >= BUFFER_FRAMES) { // overrunning! uh-oh. restart at a sane distance
@@ -140,7 +140,7 @@
ab_read = ab_write - START_FILL;
}
read = ab_read;
-@@ -749,7 +758,7 @@
+@@ -749,7 +758,7 @@ short *buffer_get_frame(void) {
volatile abuf_t *curframe = audio_buffer + BUFIDX(read);
if (!curframe->ready) {
@@ -149,7 +149,7 @@
memset(curframe->data, 0, FRAME_BYTES);
}
curframe->ready = 0;
-@@ -776,13 +785,13 @@
+@@ -776,13 +785,13 @@ int stuff_buffer(double playback_rate, s
if (stuff) {
if (stuff==1) {
if (debug)
@@ -165,7 +165,7 @@
inptr++;
inptr++;
}
-@@ -849,6 +858,11 @@
+@@ -849,6 +858,11 @@ void *audio_thread_func(void *arg) {
inbuf = buffer_get_frame();
} while (!inbuf && audio_running);
@@ -177,7 +177,7 @@
#ifdef FANCY_RESAMPLING
if (fancy_resampling) {
int i;
-@@ -881,7 +895,7 @@
+@@ -881,7 +895,7 @@ void *audio_thread_func(void *arg) {
}
#ifdef HAS_AO
} else {
@@ -186,7 +186,7 @@
#endif
}
}
-@@ -906,7 +920,7 @@
+@@ -906,7 +920,7 @@ void init_pipe(char* pipe) {
ao_device *dev;
void* init_ao() {
@@ -195,7 +195,7 @@
int driver;
#ifndef XBMC
-@@ -921,7 +935,7 @@
+@@ -921,7 +935,7 @@ void* init_ao() {
#endif
{
// otherwise choose the default
@@ -204,7 +204,7 @@
}
ao_sample_format fmt;
-@@ -944,9 +958,9 @@
+@@ -944,9 +958,9 @@ void* init_ao() {
}
#endif
@@ -216,7 +216,7 @@
if (dev == NULL) {
die("Could not open ao device");
}
-@@ -985,12 +999,13 @@
+@@ -985,12 +999,13 @@ void clean_output(void)
audio_running = 0;
pthread_join(audio_thread, NULL);
#ifdef HAS_AO
diff --git a/audio/libshairport/files/patch-src-hairtunes.h b/audio/libshairport/files/patch-src_hairtunes.h
index 0dfba09d6ff6..13ccb776b5aa 100644
--- a/audio/libshairport/files/patch-src-hairtunes.h
+++ b/audio/libshairport/files/patch-src_hairtunes.h
@@ -1,5 +1,5 @@
---- src/hairtunes.h.orig 2011-08-21 00:06:21.000000000 +0200
-+++ src/hairtunes.h 2012-10-09 12:09:33.000000000 +0200
+--- src/hairtunes.h.orig 2011-08-20 22:06:21 UTC
++++ src/hairtunes.h
@@ -4,6 +4,8 @@
int hairtunes_init(char *pAeskey, char *pAesiv, char *pFmtpstr, int pCtrlPort, int pTimingPort,
int pDataPort, char *pRtpHost, char*pPipeName, char *pLibaoDriver, char *pLibaoDeviceName, char *pLibaoDeviceId);
diff --git a/audio/libshairport/files/patch-src-shairport.c b/audio/libshairport/files/patch-src_shairport.c
index 00fd93c92d1c..b26546624481 100644
--- a/audio/libshairport/files/patch-src-shairport.c
+++ b/audio/libshairport/files/patch-src_shairport.c
@@ -1,5 +1,5 @@
---- src/shairport.c.orig 2011-08-21 01:57:56.000000000 +0200
-+++ src/shairport.c 2012-10-09 12:09:33.000000000 +0200
+--- src/shairport.c.orig 2011-08-20 23:57:56 UTC
++++ src/shairport.c
@@ -31,6 +31,27 @@
#include "shairport.h"
#include "hairtunes.h"
@@ -28,7 +28,7 @@
#ifndef TRUE
#define TRUE (-1)
#endif
-@@ -92,13 +113,26 @@
+@@ -92,13 +113,26 @@ static struct addrinfo *tAddrInfo;
static char tPassword[56] = "";
static char tHWID[HWID_SIZE] = {0,51,52,53,54,55};
@@ -56,7 +56,7 @@
char tHWID_Hex[HWID_SIZE * 2 + 1];
char tKnownHwid[32];
-@@ -177,22 +211,22 @@
+@@ -177,22 +211,22 @@ int shairport_main(int argc, char **argv
}
else if(!strcmp(arg, "-h") || !strcmp(arg, "--help"))
{
@@ -90,7 +90,7 @@
return(0);
}
-@@ -201,11 +235,11 @@
+@@ -201,11 +235,11 @@ int shairport_main(int argc, char **argv
int tPid = fork();
if(tPid < 0)
{
@@ -104,7 +104,7 @@
}
else
{
-@@ -246,10 +280,10 @@
+@@ -246,10 +280,10 @@ int shairport_main(int argc, char **argv
sscanf(tHWID_Hex, "%02X%02X%02X%02X%02X%02X", &tHWID[0], &tHWID[1], &tHWID[2], &tHWID[3], &tHWID[4], &tHWID[5]);
}
@@ -119,7 +119,7 @@
if(tSimLevel >= 1)
{
-@@ -263,12 +297,12 @@
+@@ -263,12 +297,12 @@ int shairport_main(int argc, char **argv
#ifndef XBMC
startAvahi(tHWID_Hex, tServerName, tPort);
#endif
@@ -134,7 +134,7 @@
return 0;
}
-@@ -295,7 +329,7 @@
+@@ -295,7 +329,7 @@ int shairport_loop(void)
int readsock;
@@ -143,7 +143,7 @@
while(m_running)
{
-@@ -327,7 +361,7 @@
+@@ -327,7 +361,7 @@ int shairport_loop(void)
{
freeaddrinfo(tAddrInfo);
tAddrInfo = NULL;
@@ -152,7 +152,7 @@
close(tServerSock);
handleClient(tClientSock, tPassword, tHWID);
//close(tClientSock);
-@@ -335,11 +369,11 @@
+@@ -335,11 +369,11 @@ int shairport_loop(void)
}
else
{
@@ -166,7 +166,7 @@
handleClient(tClientSock, tPassword, tHWID);
#endif
}
-@@ -349,7 +383,7 @@
+@@ -349,7 +383,7 @@ int shairport_loop(void)
}
}
@@ -175,7 +175,7 @@
if(tAddrInfo != NULL)
{
freeaddrinfo(tAddrInfo);
-@@ -360,6 +394,7 @@
+@@ -360,6 +394,7 @@ int shairport_loop(void)
void shairport_exit(void)
{
m_running = 0;
@@ -183,7 +183,7 @@
}
int shairport_is_running(void)
-@@ -407,7 +442,7 @@
+@@ -407,7 +442,7 @@ int findEnd(char *tReadBuf)
void handleClient(int pSock, char *pPassword, char *pHWADDR)
{
@@ -192,7 +192,7 @@
fflush(stdout);
socklen_t len;
-@@ -426,7 +461,7 @@
+@@ -426,7 +461,7 @@ void handleClient(int pSock, char *pPass
// deal with both IPv4 and IPv6:
if (addr.ss_family == AF_INET) {
@@ -201,7 +201,7 @@
struct sockaddr_in *s = (struct sockaddr_in *)&addr;
port = ntohs(s->sin_port);
inet_ntop(AF_INET, &s->sin_addr, ipstr, sizeof ipstr);
-@@ -446,20 +481,20 @@
+@@ -446,20 +481,20 @@ void handleClient(int pSock, char *pPass
if(memcmp(&addr.bin[0], "\x00\x00\x00\x00" "\x00\x00\x00\x00" "\x00\x00\xff\xff", 12) == 0)
{
// its ipv4...
@@ -226,7 +226,7 @@
int tMoreDataNeeded = 1;
struct keyring tKeys;
-@@ -478,18 +513,19 @@
+@@ -478,18 +513,19 @@ void handleClient(int pSock, char *pPass
while(1 == tMoreDataNeeded)
{
tError = readDataFromClient(pSock, &(tConn.recv));
@@ -250,7 +250,7 @@
cleanup(&tConn);
// pSock was already closed
return;
-@@ -498,13 +534,13 @@
+@@ -498,13 +534,13 @@ void handleClient(int pSock, char *pPass
}
else
{
@@ -266,7 +266,7 @@
//tConn->resp.data[tConn->resp.current-1] = '\0';
writeDataToClient(pSock, &(tConn.resp));
// Finished reading one message...
-@@ -517,9 +553,9 @@
+@@ -517,9 +553,9 @@ void handleClient(int pSock, char *pPass
void writeDataToClient(int pSock, struct shairbuffer *pResponse)
{
@@ -278,7 +278,7 @@
}
int readDataFromClient(int pSock, struct shairbuffer *pClientBuffer)
-@@ -532,7 +568,7 @@
+@@ -532,7 +568,7 @@ int readDataFromClient(int pSock, struct
while(tRetval > 0 && tEnd < 0)
{
// Read from socket until \n\n, \r\n\r\n, or \r\r is found
@@ -287,7 +287,7 @@
fflush(stdout);
tRetval = read(pSock, tReadBuf, MAX_SIZE);
// if new buffer contains the end of request string, only copy partial buffer?
-@@ -543,40 +579,40 @@
+@@ -543,40 +579,40 @@ int readDataFromClient(int pSock, struct
{
pClientBuffer->marker = tEnd+1; // Marks start of content
}
@@ -336,7 +336,7 @@
char* tFound = strstr(pBufferPtr, pField);
int tSize = 0;
if(tFound != NULL)
-@@ -597,7 +633,7 @@
+@@ -597,7 +633,7 @@ char *getFromBuffer(char *pBufferPtr, co
}
tSize = (int) (tShortest - tFound);
@@ -345,7 +345,7 @@
if(pReturnSize != NULL)
{
*pReturnSize = tSize;
-@@ -605,7 +641,7 @@
+@@ -605,7 +641,7 @@ char *getFromBuffer(char *pBufferPtr, co
}
else
{
@@ -354,7 +354,7 @@
}
return tFound;
}
-@@ -639,10 +675,10 @@
+@@ -639,10 +675,10 @@ int buildAppleResponse(struct connection
{
char tTrim[tFoundSize + 2];
getTrimmed(tFound, tFoundSize, TRUE, TRUE, tTrim);
@@ -367,7 +367,7 @@
int tCurSize = 0;
unsigned char tChalResp[38];
-@@ -664,7 +700,7 @@
+@@ -664,7 +700,7 @@ int buildAppleResponse(struct connection
}
char *tTmp = encode_base64((unsigned char *)tChalResp, tCurSize);
@@ -376,7 +376,7 @@
free(tTmp);
// RSA Encrypt
-@@ -709,15 +745,15 @@
+@@ -709,15 +745,15 @@ int parseMessage(struct connection *pCon
if(tContent != NULL)
{
int tContentSize = atoi(tContent);
@@ -396,7 +396,7 @@
}
}
// check if value in tContent > 2nd read from client.
-@@ -726,7 +762,7 @@
+@@ -726,7 +762,7 @@ int parseMessage(struct connection *pCon
}
else
{
@@ -405,7 +405,7 @@
}
// "Creates" a new Response Header for our response message
-@@ -739,7 +775,7 @@
+@@ -739,7 +775,7 @@ int parseMessage(struct connection *pCon
{
tLen = 20;
}
@@ -414,7 +414,7 @@
}
if(pConn->password != NULL)
-@@ -749,7 +785,7 @@
+@@ -749,7 +785,7 @@ int parseMessage(struct connection *pCon
if(buildAppleResponse(pConn, pIpBin, pIpBinLen, pHWID)) // need to free sig
{
@@ -423,7 +423,7 @@
}
// Find option, then based on option, do different actions.
-@@ -769,14 +805,14 @@
+@@ -769,14 +805,14 @@ int parseMessage(struct connection *pCon
int tKeySize = 0;
char tEncodedAesIV[tSize + 2];
getTrimmed(tHeaderVal, tSize, TRUE, TRUE, tEncodedAesIV);
@@ -440,7 +440,7 @@
// remove base64 coding from key
char *tDecodedAesKey = decode_base64((unsigned char*) tEncodedAesKey,
tKeySize, &tKeySize); // Need to free DecodedAesKey
-@@ -785,7 +821,7 @@
+@@ -785,7 +821,7 @@ int parseMessage(struct connection *pCon
int tFmtpSize = 0;
char *tFmtp = getFromContent(tContent, "a=fmtp", &tFmtpSize); // Don't need to free
tFmtp = getTrimmedMalloc(tFmtp, tFmtpSize, TRUE, FALSE); // will need to free
@@ -449,7 +449,7 @@
RSA *rsa = loadKey();
// Decrypt the binary aes key
-@@ -794,11 +830,11 @@
+@@ -794,11 +830,11 @@ int parseMessage(struct connection *pCon
if(RSA_private_decrypt(tKeySize, (unsigned char *)tDecodedAesKey,
(unsigned char*) tDecryptedKey, rsa, RSA_PKCS1_OAEP_PADDING) >= 0)
{
@@ -463,7 +463,7 @@
}
free(tDecodedAesKey);
RSA_free(rsa);
-@@ -814,13 +850,13 @@
+@@ -814,13 +850,13 @@ int parseMessage(struct connection *pCon
// struct comms *tComms = pConn->hairtunes;
// if (! (pipe(tComms->in) == 0 && pipe(tComms->out) == 0))
// {
@@ -479,7 +479,7 @@
#ifndef XBMC
int tPid = fork();
if(tPid == 0)
-@@ -836,11 +872,11 @@
+@@ -836,11 +872,11 @@ int parseMessage(struct connection *pCon
tFound = getFromSetup(pConn->recv.data, "timing_port", &tSize);
getTrimmed(tFound, tSize, 1, 0, tTPortStr);
@@ -493,7 +493,7 @@
char *tRtp = NULL;
char *tPipe = NULL;
char *tAoDriver = NULL;
-@@ -875,7 +911,7 @@
+@@ -875,7 +911,7 @@ int parseMessage(struct connection *pCon
tDataport, tRtp, tPipe, tAoDriver, tAoDeviceName, tAoDeviceId);
#ifndef XBMC
// Quit when finished.
@@ -502,7 +502,7 @@
return -1;
}
else if(tPid >0)
-@@ -888,7 +924,7 @@
+@@ -888,7 +924,7 @@ int parseMessage(struct connection *pCon
int tRead = read(tComms->out[0], tFromHairtunes, 80);
if(tRead <= 0)
{
@@ -511,7 +511,7 @@
}
else
{
-@@ -900,7 +936,7 @@
+@@ -900,7 +936,7 @@ int parseMessage(struct connection *pCon
}
else
{
@@ -520,7 +520,7 @@
}
}
-@@ -921,7 +957,7 @@
+@@ -921,7 +957,7 @@ int parseMessage(struct connection *pCon
}
else
{
@@ -529,7 +529,7 @@
return -1;
}
#endif
-@@ -933,7 +969,7 @@
+@@ -933,7 +969,7 @@ int parseMessage(struct connection *pCon
propogateCSeq(pConn);
#ifndef XBMC
close(pConn->hairtunes->in[1]);
@@ -538,7 +538,7 @@
#else
hairtunes_cleanup();
#endif
-@@ -954,21 +990,73 @@
+@@ -954,21 +990,73 @@ int parseMessage(struct connection *pCon
{
propogateCSeq(pConn);
int tSize = 0;
@@ -616,7 +616,7 @@
propogateCSeq(pConn);
}
addToShairBuffer(&(pConn->resp), "\r\n");
-@@ -1047,7 +1135,7 @@
+@@ -1047,7 +1135,7 @@ int startAvahi(const char *pHWStr, const
char tName[100 + HWID_SIZE + 3];
if(strlen(pServerName) > tMaxServerName)
{
@@ -625,7 +625,7 @@
"so we put a strncat in our command so we don't buffer overflow, while you listen to your flow.\n"
"We just used the first %d characters. Pick something shorter if you want\n", tMaxServerName);
}
-@@ -1058,7 +1146,7 @@
+@@ -1058,7 +1146,7 @@ int startAvahi(const char *pHWStr, const
strcat(tName, pHWStr);
strcat(tName, "@");
strncat(tName, pServerName, tMaxServerName);
@@ -634,7 +634,7 @@
execlp("avahi-publish-service", "avahi-publish-service", tName,
"_raop._tcp", tPort, "tp=UDP","sm=false","sv=false","ek=1","et=0,1",
-@@ -1070,12 +1158,12 @@
+@@ -1070,12 +1158,12 @@ int startAvahi(const char *pHWStr, const
perror("error");
}
@@ -650,7 +650,7 @@
}
return tPid;
}
-@@ -1083,7 +1171,7 @@
+@@ -1083,7 +1171,7 @@ int startAvahi(const char *pHWStr, const
void printBufferInfo(struct shairbuffer *pBuf, int pLevel)
{
@@ -659,7 +659,7 @@
}
int getAvailChars(struct shairbuffer *pBuf)
-@@ -1164,7 +1252,8 @@
+@@ -1164,7 +1252,8 @@ void slog(int pLevel, char *pFormat, ...
{
va_list argp;
va_start(argp, pFormat);
@@ -669,7 +669,7 @@
va_end(argp);
}
//#endif
-@@ -1218,9 +1307,9 @@
+@@ -1218,9 +1307,9 @@ void initBuffer(struct shairbuffer *pBuf
{
if(pBuf->data != NULL)
{
@@ -681,7 +681,7 @@
}
pBuf->current = 0;
pBuf->marker = 0;
-@@ -1278,6 +1367,6 @@
+@@ -1278,6 +1367,6 @@ RSA *loadKey()
BIO *tBio = BIO_new_mem_buf(AIRPORT_PRIVATE_KEY, -1);
RSA *rsa = PEM_read_bio_RSAPrivateKey(tBio, NULL, NULL, NULL); //NULL, NULL, NULL);
BIO_free(tBio);
diff --git a/audio/libshairport/files/patch-src-shairport.h b/audio/libshairport/files/patch-src_shairport.h
index 33337cee6792..08af5df34f1e 100644
--- a/audio/libshairport/files/patch-src-shairport.h
+++ b/audio/libshairport/files/patch-src_shairport.h
@@ -1,5 +1,5 @@
---- src/shairport.h.orig 2011-08-21 01:58:11.000000000 +0200
-+++ src/shairport.h 2012-10-09 12:09:33.000000000 +0200
+--- src/shairport.h.orig 2011-08-20 23:58:11 UTC
++++ src/shairport.h
@@ -11,14 +11,22 @@
#include <regex.h>
#include <sys/types.h>
@@ -27,7 +27,7 @@
struct shairbuffer
{
-@@ -58,13 +66,21 @@
+@@ -58,13 +66,21 @@ extern "C"
{
#endif /* __cplusplus */
diff --git a/audio/libshairport/files/patch-src-socketlib.c b/audio/libshairport/files/patch-src_socketlib.c
index c2b3e6c14b81..e9bef80a6d37 100644
--- a/audio/libshairport/files/patch-src-socketlib.c
+++ b/audio/libshairport/files/patch-src_socketlib.c
@@ -1,6 +1,6 @@
---- src/socketlib.c.orig 2011-09-23 22:00:48.000000000 +0200
-+++ src/socketlib.c 2012-10-09 12:09:33.000000000 +0200
-@@ -48,7 +48,7 @@
+--- src/socketlib.c.orig 2011-09-23 20:00:48 UTC
++++ src/socketlib.c
+@@ -48,7 +48,7 @@ int common_setup(struct addrinfo *pAddrI
if((tSock==-1) && (pAddrInfo->ai_family == AF_INET6) && (errno == EAFNOSUPPORT))
{
//Fallback to ipv4
@@ -9,7 +9,7 @@
pAddrInfo->ai_family = AF_INET;
tSock = socket(pAddrInfo->ai_family, pAddrInfo->ai_socktype, 0);
}
-@@ -82,7 +82,7 @@
+@@ -82,7 +82,7 @@ int setup_client(struct addrinfo *server
delay(RETRY_DELAY, &tRes);
}
}
@@ -18,7 +18,7 @@
return ERROR;
}
-@@ -102,7 +102,7 @@
+@@ -102,7 +102,7 @@ int getAddr(char *pHostname, char *pServ
tError = getaddrinfo(pHostname, pService, &hints, pAddrInfo);
if(tError != 0)
{
@@ -27,7 +27,7 @@
}
return tError;
}
-@@ -158,8 +158,8 @@
+@@ -158,8 +158,8 @@ int setupListenServer(struct addrinfo **
sprintf(tService, "%d", pPort); // copies port to string
int tFamily = AF_INET;
#ifdef AF_INET6
@@ -38,7 +38,7 @@
#else
//printf("Listening on IPv4 Socket");
#endif
-@@ -200,7 +200,7 @@
+@@ -200,7 +200,7 @@ static int getCorrectedEncodeSize(int pS
else
{
// Invalid encoded data, no other cases are possible.
@@ -47,7 +47,7 @@
return pSize;
}
}
-@@ -226,7 +226,7 @@
+@@ -226,7 +226,7 @@ char *decode_base64(unsigned char *pInpu
memset(input, 0, length);
memcpy(input, pInput, pLength);
memset(input+pLength, '=', length-pLength);