aboutsummaryrefslogtreecommitdiff
path: root/audio/libsidplay2
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-08-18 18:11:00 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-08-18 18:11:00 +0000
commit1100885686d84ccf95b4fe6c7614fec19de637f3 (patch)
tree681d70661270f6697c36497b04ec7894fb6f4368 /audio/libsidplay2
parentceeac267a22d2caf8d92cef2cb41cb59d666f697 (diff)
downloadports-1100885686d84ccf95b4fe6c7614fec19de637f3.tar.gz
ports-1100885686d84ccf95b4fe6c7614fec19de637f3.zip
Fix build with gcc-3.4
PR: ports/70627 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=116615
Diffstat (limited to 'audio/libsidplay2')
-rw-r--r--audio/libsidplay2/Makefile8
-rw-r--r--audio/libsidplay2/files/patch-libsidplay::include::sidplay::SmartPtr.h26
2 files changed, 27 insertions, 7 deletions
diff --git a/audio/libsidplay2/Makefile b/audio/libsidplay2/Makefile
index a2eb0312ff9f..90f26a25ebc0 100644
--- a/audio/libsidplay2/Makefile
+++ b/audio/libsidplay2/Makefile
@@ -26,14 +26,8 @@ LIBTOOLFILES= builders/hardsid-builder/configure \
resid/configure
INSTALLS_SHLIB= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 502126
-BROKEN= "Does not compile with gcc 3.4.2"
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|<malloc\.h>|<stdlib.h>|g' \
${WRKSRC}/libsidutils/src/ini/ini.cpp
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/audio/libsidplay2/files/patch-libsidplay::include::sidplay::SmartPtr.h b/audio/libsidplay2/files/patch-libsidplay::include::sidplay::SmartPtr.h
new file mode 100644
index 000000000000..df50ab655518
--- /dev/null
+++ b/audio/libsidplay2/files/patch-libsidplay::include::sidplay::SmartPtr.h
@@ -0,0 +1,26 @@
+--- libsidplay/include/sidplay/SmartPtr.h.orig Tue Jun 15 05:08:04 2004
++++ libsidplay/include/sidplay/SmartPtr.h Wed Aug 18 00:47:50 2004
+@@ -211,16 +211,16 @@
+ {
+ if ( bufferLen >= 1 )
+ {
+- pBufCurrent = ( bufBegin = buffer );
+- bufEnd = bufBegin + bufferLen;
+- bufLen = bufferLen;
+- status = true;
++ this->pBufCurrent = ( this->bufBegin = buffer );
++ this->bufEnd = this->bufBegin + bufferLen;
++ this->bufLen = bufferLen;
++ this->status = true;
+ }
+ else
+ {
+- pBufCurrent = bufBegin = bufEnd = 0;
+- bufLen = 0;
+- status = false;
++ this->pBufCurrent = this->bufBegin = this->bufEnd = 0;
++ this->bufLen = 0;
++ this->status = false;
+ }
+ }
+ };