aboutsummaryrefslogtreecommitdiff
path: root/audio/libsidplay2
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2021-01-03 15:30:33 +0000
committerRene Ladan <rene@FreeBSD.org>2021-01-03 15:30:33 +0000
commit4203f52bb2709044aed6614eb9fc944a13aeb867 (patch)
treed10fbd91c0f7f899d12a83cf039043c2de5acdee /audio/libsidplay2
parent29a48dc49fccacbf8063e99cbb7c8e93b5f3bffd (diff)
downloadports-4203f52bb2709044aed6614eb9fc944a13aeb867.tar.gz
ports-4203f52bb2709044aed6614eb9fc944a13aeb867.zip
audio/libsidplay2: several fixes and improvements
- fix build on architectures using GCC 6 - drop unused gmake dependency - use DIST* instead of PORT* PR: 252368 Submitted by: Daniel Engberg
Notes
Notes: svn path=/head/; revision=560012
Diffstat (limited to 'audio/libsidplay2')
-rw-r--r--audio/libsidplay2/Makefile10
-rw-r--r--audio/libsidplay2/files/patch-libsidplay_src-xsid_xsid.cpp13
2 files changed, 18 insertions, 5 deletions
diff --git a/audio/libsidplay2/Makefile b/audio/libsidplay2/Makefile
index 20c7c1cb277f..7185141bbfab 100644
--- a/audio/libsidplay2/Makefile
+++ b/audio/libsidplay2/Makefile
@@ -2,18 +2,18 @@
# $FreeBSD$
PORTNAME= libsidplay2
-PORTVERSION= 2.1.1
-PORTREVISION= 8
+DISTVERSION= 2.1.1
+PORTREVISION= 9
CATEGORIES= audio emulators
-MASTER_SITES= SF/sidplay2/sidplay2/sidplay-libs-${PORTVERSION}
-DISTNAME= sidplay-libs-${PORTVERSION}
+MASTER_SITES= SF/sidplay2/sidplay2/sidplay-libs-${DISTVERSION}
+DISTNAME= sidplay-libs-${DISTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Library to play Commodore 64 SID-tunes cycle accurately
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-USES= gmake libtool pathfix pkgconfig
+USES= libtool pathfix pkgconfig
USE_LDCONFIG= yes
post-patch:
diff --git a/audio/libsidplay2/files/patch-libsidplay_src-xsid_xsid.cpp b/audio/libsidplay2/files/patch-libsidplay_src-xsid_xsid.cpp
new file mode 100644
index 000000000000..54f89fce9c19
--- /dev/null
+++ b/audio/libsidplay2/files/patch-libsidplay_src-xsid_xsid.cpp
@@ -0,0 +1,13 @@
+--- libsidplay/src/xsid/xsid.cpp.orig 2004-06-14 20:08:02 UTC
++++ libsidplay/src/xsid/xsid.cpp
+@@ -96,8 +96,8 @@ const int8_t XSID::sampleConvertTable[16] =
+ */
+ const int8_t XSID::sampleConvertTable[16] =
+ {
+- '\x80', '\x94', '\xa9', '\xbc', '\xce', '\xe1', '\xf2', '\x03',
+- '\x1b', '\x2a', '\x3b', '\x49', '\x58', '\x66', '\x73', '\x7f'
++ (int8_t)'\x80', (int8_t)'\x94', (int8_t)'\xa9', (int8_t)'\xbc', (int8_t)'\xce', (int8_t)'\xe1', (int8_t)'\xf2', (int8_t)'\x03',
++ (int8_t)'\x1b', (int8_t)'\x2a', (int8_t)'\x3b', (int8_t)'\x49', (int8_t)'\x58', (int8_t)'\x66', (int8_t)'\x73', (int8_t)'\x7f'
+ };
+
+ const char *XSID::credit =