aboutsummaryrefslogtreecommitdiff
path: root/audio/libsndfile
diff options
context:
space:
mode:
authorBrendan Fabeny <bf@FreeBSD.org>2012-03-07 04:44:06 +0000
committerBrendan Fabeny <bf@FreeBSD.org>2012-03-07 04:44:06 +0000
commit752387e658eaaa125f075b2f10f316b02e343727 (patch)
treeef5f039bee177d74a5af357e352bcde7597dd670 /audio/libsndfile
parent7aedaa2e2f378d482ede29fbd877c2d92732e506 (diff)
downloadports-752387e658eaaa125f075b2f10f316b02e343727.tar.gz
ports-752387e658eaaa125f075b2f10f316b02e343727.zip
disable some machine-dependent code by default; add a test target
Notes
Notes: svn path=/head/; revision=292864
Diffstat (limited to 'audio/libsndfile')
-rw-r--r--audio/libsndfile/Makefile14
1 files changed, 13 insertions, 1 deletions
diff --git a/audio/libsndfile/Makefile b/audio/libsndfile/Makefile
index 6681e86175a3..3c27f44e4410 100644
--- a/audio/libsndfile/Makefile
+++ b/audio/libsndfile/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libsndfile
PORTVERSION= 1.0.25
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= http://www.mega-nerd.com/libsndfile/files/
@@ -34,10 +35,17 @@ MAN1= sndfile-concat.1 sndfile-cmp.1 sndfile-convert.1 \
PORTDOCS= AUTHORS ChangeLog NEWS README libsndfile.css \
new_file_type.HOWTO libsndfile.jpg *.html
-OPTIONS= EXTERNAL "Enable FLAC and Ogg Vorbis support" on
+OPTIONS= CPU_CLIP "Allow machine-dependent clipping" off \
+ EXTERNAL "Enable FLAC and Ogg Vorbis support" on
.include <bsd.port.pre.mk>
+.if !defined(WITH_CPU_CLIP)
+CONFIGURE_ARGS+= --disable-cpu-clip
+.else
+MANUAL_PACKAGE_BUILD= WITH_CPU_CLIP may customize the package for the build machine
+.endif
+
.if defined(WITHOUT_EXTERNAL)
CONFIGURE_ARGS+=--disable-external-libs
.else
@@ -48,6 +56,10 @@ LIB_DEPENDS+= FLAC.10:${PORTSDIR}/audio/flac \
post-patch:
@${REINPLACE_CMD} -e '/^SUBDIRS =/s/ doc / /g' ${WRKSRC}/Makefile.in
+check regression-test test: build
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${_MAKE_JOBS} ${MAKE_ARGS} \
+ check
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}