aboutsummaryrefslogtreecommitdiff
path: root/audio/libsndfile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-10-15 11:43:25 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-10-15 11:43:25 +0000
commitdb5cad7305de1313a888a4e4b9aba4766f671a93 (patch)
tree6ebfce35758475e88df2a2a94cffc71181715474 /audio/libsndfile
parent7282a5a6ef66057d030af727082465da65995c38 (diff)
downloadports-db5cad7305de1313a888a4e4b9aba4766f671a93.tar.gz
ports-db5cad7305de1313a888a4e4b9aba4766f671a93.zip
Notes
Diffstat (limited to 'audio/libsndfile')
-rw-r--r--audio/libsndfile/Makefile1
-rw-r--r--audio/libsndfile/files/patch-examples_sndfile-play.c29
2 files changed, 30 insertions, 0 deletions
diff --git a/audio/libsndfile/Makefile b/audio/libsndfile/Makefile
index 173515ee01d5..97185be9c014 100644
--- a/audio/libsndfile/Makefile
+++ b/audio/libsndfile/Makefile
@@ -8,6 +8,7 @@
PORTNAME= libsndfile
PORTVERSION= 1.0.10
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= http://www.mega-nerd.com/libsndfile/
diff --git a/audio/libsndfile/files/patch-examples_sndfile-play.c b/audio/libsndfile/files/patch-examples_sndfile-play.c
new file mode 100644
index 000000000000..ceecb8e27b52
--- /dev/null
+++ b/audio/libsndfile/files/patch-examples_sndfile-play.c
@@ -0,0 +1,29 @@
+--- examples/sndfile-play.c.orig Thu Oct 14 18:07:25 2004
++++ examples/sndfile-play.c Thu Oct 14 18:11:13 2004
+@@ -34,7 +34,7 @@
+ #include <sys/time.h>
+ #endif
+
+-#if defined (__linux__)
++#if defined (__linux__) || defined (__FreeBSD__)
+ #include <fcntl.h>
+ #include <sys/ioctl.h>
+ #include <sys/soundcard.h>
+@@ -326,7 +326,7 @@
+ ** Linux/OSS functions for playing a sound.
+ */
+
+-#if defined (__linux__)
++#if defined (__linux__) || defined (__FreeBSD__)
+
+ static int linux_open_dsp_device (int channels, int srate) ;
+
+@@ -869,7 +869,7 @@
+ return 1 ;
+ } ;
+
+-#if defined (__linux__)
++#if defined (__linux__) || defined(__FreeBSD__)
+ #if HAVE_ALSA_ASOUNDLIB_H
+ if (access ("/proc/asound/cards", R_OK) == 0)
+ alsa_play (argc, argv) ;