aboutsummaryrefslogtreecommitdiff
path: root/audio/libtremor
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-02-25 08:41:49 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-02-25 08:41:49 +0000
commit77de5d67f67d5b09d42afb720f1f8c9f614bc99c (patch)
tree5f6cd5c86f21aed34bade1d0ee0e32a35d6726ce /audio/libtremor
parentadbbde413ee063ee0d5d5a99c344fd2108c56296 (diff)
downloadports-77de5d67f67d5b09d42afb720f1f8c9f614bc99c.tar.gz
ports-77de5d67f67d5b09d42afb720f1f8c9f614bc99c.zip
Add libtremor, an integer-only fully Vorbis compliant software decoder library.
Submitted by: Koop Mast <kwm@rainbow-runner.nl>
Notes
Notes: svn path=/head/; revision=102042
Diffstat (limited to 'audio/libtremor')
-rw-r--r--audio/libtremor/Makefile53
-rw-r--r--audio/libtremor/distinfo2
-rw-r--r--audio/libtremor/pkg-descr4
-rw-r--r--audio/libtremor/pkg-plist9
4 files changed, 68 insertions, 0 deletions
diff --git a/audio/libtremor/Makefile b/audio/libtremor/Makefile
new file mode 100644
index 000000000000..f979e47a0924
--- /dev/null
+++ b/audio/libtremor/Makefile
@@ -0,0 +1,53 @@
+# New ports collection makefile for: libtremor
+# Date created: 07 December 2003
+# Whom: kwm@rainbow-runner.nl
+#
+# $FreeBSD$
+#
+
+PORTNAME= libtremor
+PORTVERSION= 1.0.2.${SNAP_DATE}
+CATEGORIES= audio
+MASTER_SITES= http://members.chello.nl/~g.mast/distfiles/
+DISTNAME= tremor_snapshot_${SNAP_DATE}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= kwm@rainbow-runner.nl
+COMMENT= Integer-only fully Ogg Vorbis compliant decoder library
+
+# pull in libtool this way because USE_LIBTOOL tries to patch
+# things that don't exist.
+
+BUILD_DEPENDS= libtoolize13:${PORTSDIR}/devel/libtool13
+
+SNAP_DATE= 02132004
+WRKSRC= ${WRKDIR}/Tremor
+USE_REINPLACE= yes
+USE_AUTOMAKE_VER= 15
+USE_AUTOCONF_VER= 253
+USE_LIBTOOL_VER= 13
+GNU_CONFIGURE= yes
+INSTALLS_SHLIB= yes
+
+pre-configure:
+ @cd ${WRKSRC} && ${ACLOCAL}
+ @cd ${WRKSRC} && ${LIBTOOLIZE} --automake
+ @cd ${WRKSRC} && ${AUTOMAKE} --add-missing
+ @cd ${WRKSRC} && ${AUTOCONF}
+
+do-install:
+ for i in ${WRKSRC}/.libs/libvorbisidec.so.1 \
+ ${WRKSRC}/.libs/libvorbisidec.so \
+ ${WRKSRC}/.libs/libvorbisidec.a ; do \
+ ${INSTALL_SCRIPT} $$i ${PREFIX}/lib ; \
+ done
+ @${MKDIR} ${PREFIX}/include/tremor
+ for i in ${WRKSRC}/config_types.h \
+ ${WRKSRC}/ivorbiscodec.h \
+ ${WRKSRC}/ivorbisfile.h \
+ ${WRKSRC}/ogg.h \
+ ${WRKSRC}/os_types.h ; do \
+ ${INSTALL_SCRIPT} $$i ${PREFIX}/include/tremor ; \
+ done
+
+.include <bsd.port.mk>
diff --git a/audio/libtremor/distinfo b/audio/libtremor/distinfo
new file mode 100644
index 000000000000..e85d5c6a83c9
--- /dev/null
+++ b/audio/libtremor/distinfo
@@ -0,0 +1,2 @@
+MD5 (tremor_snapshot_02132004.tgz) = d1e6e5b76f7120e55dd33e8002e394a1
+SIZE (tremor_snapshot_02132004.tgz) = 151996
diff --git a/audio/libtremor/pkg-descr b/audio/libtremor/pkg-descr
new file mode 100644
index 000000000000..6bd242ddb73e
--- /dev/null
+++ b/audio/libtremor/pkg-descr
@@ -0,0 +1,4 @@
+The Tremor decoder library is an integer-only fully Ogg Vorbis compliant
+software decoder library.
+
+WWW: http://www.xiph.org/ogg/vorbis/
diff --git a/audio/libtremor/pkg-plist b/audio/libtremor/pkg-plist
new file mode 100644
index 000000000000..ef84bfd64a29
--- /dev/null
+++ b/audio/libtremor/pkg-plist
@@ -0,0 +1,9 @@
+include/tremor/config_types.h
+include/tremor/ivorbiscodec.h
+include/tremor/ivorbisfile.h
+include/tremor/ogg.h
+include/tremor/os_types.h
+lib/libvorbisidec.a
+lib/libvorbisidec.so
+lib/libvorbisidec.so.1
+@dirrm include/tremor