aboutsummaryrefslogtreecommitdiff
path: root/audio/libvorbis
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2020-07-11 17:10:02 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2020-07-11 17:10:02 +0000
commit09f4feebf53462e3a444e76cfb2f75549d2dc360 (patch)
treed84b599f093c3ef4148eccd32d81bb339cb566e5 /audio/libvorbis
parent8b321afdf33c88151a17bbe2baf3e04b30d238a6 (diff)
downloadports-09f4feebf53462e3a444e76cfb2f75549d2dc360.tar.gz
ports-09f4feebf53462e3a444e76cfb2f75549d2dc360.zip
Explicitly link libvorbisfile with -lm.
The bundled libtool is broken and loses the -lm dependency_lib, but it is also bad practice to rely on the dependencies of a dependency. Submitted by: tijl
Notes
Notes: svn path=/head/; revision=541994
Diffstat (limited to 'audio/libvorbis')
-rw-r--r--audio/libvorbis/Makefile6
-rw-r--r--audio/libvorbis/files/patch-lib_Makefile.in13
2 files changed, 15 insertions, 4 deletions
diff --git a/audio/libvorbis/Makefile b/audio/libvorbis/Makefile
index f7c689f9b109..e3e1a1c343b6 100644
--- a/audio/libvorbis/Makefile
+++ b/audio/libvorbis/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libvorbis
PORTVERSION= 1.3.7
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 3
CATEGORIES= audio
MASTER_SITES= https://downloads.xiph.org/releases/vorbis/ \
@@ -17,13 +17,11 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libogg.so:audio/libogg
-# The included libtool is broken and loses the -lm dependency_lib.
-USES= libtool:build pathfix tar:xz
+USES= libtool pathfix tar:xz
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-ogg=${LOCALBASE}
-MAKE_ARGS= LIBTOOL=${PREFIX}/bin/libtool
INSTALL_TARGET= install-strip
TEST_TARGET= check
diff --git a/audio/libvorbis/files/patch-lib_Makefile.in b/audio/libvorbis/files/patch-lib_Makefile.in
new file mode 100644
index 000000000000..1fdd965e632a
--- /dev/null
+++ b/audio/libvorbis/files/patch-lib_Makefile.in
@@ -0,0 +1,13 @@
+The included libtool is broken and loses the -lm dependency_lib.
+
+--- lib/Makefile.in.orig 2020-07-11 16:57:29 UTC
++++ lib/Makefile.in
+@@ -461,7 +461,7 @@ libvorbis_la_LDFLAGS = -no-undefined -version-info @V_
+ libvorbis_la_LIBADD = @VORBIS_LIBS@ @OGG_LIBS@
+ libvorbisfile_la_SOURCES = vorbisfile.c
+ libvorbisfile_la_LDFLAGS = -no-undefined -version-info @VF_LIB_CURRENT@:@VF_LIB_REVISION@:@VF_LIB_AGE@
+-libvorbisfile_la_LIBADD = libvorbis.la @OGG_LIBS@
++libvorbisfile_la_LIBADD = libvorbis.la @OGG_LIBS@ -lm
+ libvorbisenc_la_SOURCES = vorbisenc.c
+ libvorbisenc_la_LDFLAGS = -no-undefined -version-info @VE_LIB_CURRENT@:@VE_LIB_REVISION@:@VE_LIB_AGE@
+ libvorbisenc_la_LIBADD = libvorbis.la @OGG_LIBS@