aboutsummaryrefslogtreecommitdiff
path: root/audio/libxmp
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2013-02-15 15:13:49 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2013-02-15 15:13:49 +0000
commitbd5092a95cbd81b760d83ec159616fba6240d06c (patch)
tree240ed3954c8bbc8777781c5ad446dd679f691d65 /audio/libxmp
parentfd2d1f533240add5d4a727913ca9565d48b0114a (diff)
downloadports-bd5092a95cbd81b760d83ec159616fba6240d06c.tar.gz
ports-bd5092a95cbd81b760d83ec159616fba6240d06c.zip
Add libxmp, a module rendering library for audio/xmp.
Notes
Notes: svn path=/head/; revision=312294
Diffstat (limited to 'audio/libxmp')
-rw-r--r--audio/libxmp/Makefile21
-rw-r--r--audio/libxmp/distinfo2
-rw-r--r--audio/libxmp/files/patch-Makefile.in13
-rw-r--r--audio/libxmp/pkg-descr5
4 files changed, 41 insertions, 0 deletions
diff --git a/audio/libxmp/Makefile b/audio/libxmp/Makefile
new file mode 100644
index 000000000000..d62d131048df
--- /dev/null
+++ b/audio/libxmp/Makefile
@@ -0,0 +1,21 @@
+# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= libxmp
+PORTVERSION= 4.0.0
+CATEGORIES= audio
+MASTER_SITES= SF/xmp/${PORTNAME}/${PORTVERSION}
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Module rendering library for xmp
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+
+MAKE_JOBS_SAFE= yes
+
+PLIST_FILES= include/xmp.h lib/libxmp.so lib/libxmp.so.4 \
+ lib/libxmp.so.${PORTVERSION} libdata/pkgconfig/libxmp.pc
+
+.include <bsd.port.mk>
diff --git a/audio/libxmp/distinfo b/audio/libxmp/distinfo
new file mode 100644
index 000000000000..3a15031308ce
--- /dev/null
+++ b/audio/libxmp/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libxmp-4.0.0.tar.gz) = 18d4e1141df0367ed29c4f007cc47d92b311f785d52cf9eeb9423ce22152378d
+SIZE (libxmp-4.0.0.tar.gz) = 1051276
diff --git a/audio/libxmp/files/patch-Makefile.in b/audio/libxmp/files/patch-Makefile.in
new file mode 100644
index 000000000000..3ea1f4eac263
--- /dev/null
+++ b/audio/libxmp/files/patch-Makefile.in
@@ -0,0 +1,13 @@
+--- ./Makefile.in.orig 2013-02-15 15:51:27.000000000 +0100
++++ ./Makefile.in 2013-02-15 15:52:39.000000000 +0100
+@@ -144,8 +144,8 @@
+ @echo "Installing xmp.h..."
+ @$(INSTALL) -m644 include/xmp.h $(DESTDIR)$(INCLUDEDIR)
+ @echo "Installing libxmp.pc..."
+- @mkdir -p $(DESTDIR)$(LIBDIR)/pkgconfig
+- @$(INSTALL) -m644 libxmp.pc $(DESTDIR)$(LIBDIR)/pkgconfig/
++ @mkdir -p $(DESTDIR)$(PREFIX)/libdata/pkgconfig
++ @$(INSTALL) -m644 libxmp.pc $(DESTDIR)$(PREFIX)/libdata/pkgconfig/
+
+ depend: test/all_tests.c
+ @echo Building dependencies...
diff --git a/audio/libxmp/pkg-descr b/audio/libxmp/pkg-descr
new file mode 100644
index 000000000000..f71952dd4da0
--- /dev/null
+++ b/audio/libxmp/pkg-descr
@@ -0,0 +1,5 @@
+Libxmp loads the module and renders the sound as linear PCM samples in a buffer
+at rate and format specified by the user. Applications for libxmp include
+players, module information extractors, module-to-mp3 renderers, etc.
+
+WWW: http://xmp.sourceforge.net/