aboutsummaryrefslogtreecommitdiff
path: root/audio/lilv
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2017-01-10 19:48:09 +0000
committerKurt Jaeger <pi@FreeBSD.org>2017-01-10 19:48:09 +0000
commit558589fa2c1f1f595b1ed833e02b089ac1b391c9 (patch)
treec7b2c4351ff53e37e8eeac91ba0b30c16eaadb1b /audio/lilv
parent6d5a27567e692e7b781507b320502c03fcb533ef (diff)
downloadports-558589fa2c1f1f595b1ed833e02b089ac1b391c9.tar.gz
ports-558589fa2c1f1f595b1ed833e02b089ac1b391c9.zip
New port: audio/lilv
Lilv is a C library to make the use of LV2 plugins as simple as possible for applications. Lilv is the successor to SLV2, rewritten to be significantly faster and have minimal dependencies. It is stable, well-tested software (the included test suite covers over 90% of the code) in use by several applications. WWW: http://drobilla.net/software/lilv/ PR: 213290 Submitted by: Michael Beer <beerml@sigma6audio.de> Reviewed by: Yuri Victorovich <yuri@rawbw.com>
Notes
Notes: svn path=/head/; revision=431129
Diffstat (limited to 'audio/lilv')
-rw-r--r--audio/lilv/Makefile33
-rw-r--r--audio/lilv/distinfo3
-rw-r--r--audio/lilv/pkg-descr7
-rw-r--r--audio/lilv/pkg-plist16
4 files changed, 59 insertions, 0 deletions
diff --git a/audio/lilv/Makefile b/audio/lilv/Makefile
new file mode 100644
index 000000000000..514c27849baa
--- /dev/null
+++ b/audio/lilv/Makefile
@@ -0,0 +1,33 @@
+# Created by: Michael Beer <beerml@sigma6audio.de>
+# $FreeBSD$
+
+PORTNAME= lilv
+PORTVERSION= 0.24.0
+CATEGORIES= audio
+MASTER_SITES= http://download.drobilla.net/
+
+MAINTAINER= beerml@sigma6audio.de
+COMMENT= Lilv makes the use of LV2 plugins as simple as possible
+
+LICENSE= ISCL
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= lv2>=1.14.0:audio/lv2
+LIB_DEPENDS= libserd-0.so:devel/serd libsord-0.so:devel/sord libsratom-0.so:audio/sratom libsndfile.so:audio/libsndfile
+
+USES= pkgconfig python:build tar:bzip2 waf
+
+USE_LDCONFIG= yes
+
+post-install:
+ @${MV} ${STAGEDIR}${PREFIX}/lib/pkgconfig/*.pc ${STAGEDIR}${PREFIX}/libdata/pkgconfig/
+ @${MV} ${STAGEDIR}${PREFIX}/share/man/man1 ${STAGEDIR}${PREFIX}/man/
+ @${RMDIR} ${STAGEDIR}${PREFIX}/share/man
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/liblilv-0.so.0.24.0
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/lilv-bench
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/lv2apply
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/lv2bench
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/lv2info
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/lv2ls
+
+.include <bsd.port.mk>
diff --git a/audio/lilv/distinfo b/audio/lilv/distinfo
new file mode 100644
index 000000000000..15bcea8568e2
--- /dev/null
+++ b/audio/lilv/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1483909389
+SHA256 (lilv-0.24.0.tar.bz2) = fa60de536d3648aa3b1a445261fd77bd80d0246a071eed2e7ca51ea91a27fb9e
+SIZE (lilv-0.24.0.tar.bz2) = 244079
diff --git a/audio/lilv/pkg-descr b/audio/lilv/pkg-descr
new file mode 100644
index 000000000000..270d08674f6a
--- /dev/null
+++ b/audio/lilv/pkg-descr
@@ -0,0 +1,7 @@
+Lilv is a C library to make the use of LV2 plugins as simple as possible
+for applications. Lilv is the successor to SLV2, rewritten to be significantly
+faster and have minimal dependencies. It is stable, well-tested
+software (the included test suite covers over 90% of the code) in use
+by several applications.
+
+WWW: http://drobilla.net/software/lilv/
diff --git a/audio/lilv/pkg-plist b/audio/lilv/pkg-plist
new file mode 100644
index 000000000000..1ce922f119ab
--- /dev/null
+++ b/audio/lilv/pkg-plist
@@ -0,0 +1,16 @@
+bin/lilv-bench
+bin/lv2apply
+bin/lv2bench
+bin/lv2info
+bin/lv2ls
+etc/bash_completion.d/lilv
+include/lilv-0/lilv/lilv.h
+include/lilv-0/lilv/lilvmm.hpp
+lib/liblilv-0.so
+lib/liblilv-0.so.0
+lib/liblilv-0.so.0.24.0
+libdata/pkgconfig/lilv-0.pc
+man/man1/lv2apply.1.gz
+man/man1/lv2info.1.gz
+man/man1/lv2ls.1.gz
+@dir lib/pkgconfig