aboutsummaryrefslogtreecommitdiff
path: root/audio/linuxsampler
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2017-11-22 17:39:01 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2017-11-22 17:39:01 +0000
commit3be6176466a376328b819c9f4accd93a6202a81b (patch)
tree47c2a58cd59474da16b33c6f98199ce274c7040f /audio/linuxsampler
parentc38a9d00bfa0b4b4b28d048f690b1384c05931bf (diff)
downloadports-3be6176466a376328b819c9f4accd93a6202a81b.tar.gz
ports-3be6176466a376328b819c9f4accd93a6202a81b.zip
audio/libgig: Update to 4.0.0; audio/linuxsampler: Update to 2.0.0; Bumped PORTREVISIONs of audio/gigedit, audio/qsampler
Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D13162
Notes
Notes: svn path=/head/; revision=454694
Diffstat (limited to 'audio/linuxsampler')
-rw-r--r--audio/linuxsampler/Makefile21
-rw-r--r--audio/linuxsampler/distinfo5
-rw-r--r--audio/linuxsampler/files/patch-configure176
-rw-r--r--audio/linuxsampler/files/patch-src_Makefile.in11
-rw-r--r--audio/linuxsampler/files/patch-src_common_Mutex.cpp2
-rw-r--r--audio/linuxsampler/files/patch-src_common_Pool.h11
-rw-r--r--audio/linuxsampler/files/patch-src_common_atomic.h2
-rw-r--r--audio/linuxsampler/files/patch-src_drivers_audio_AudioChannel.cpp2
-rw-r--r--audio/linuxsampler/pkg-plist11
9 files changed, 214 insertions, 27 deletions
diff --git a/audio/linuxsampler/Makefile b/audio/linuxsampler/Makefile
index 226733a4bdf5..ed4847ff9a51 100644
--- a/audio/linuxsampler/Makefile
+++ b/audio/linuxsampler/Makefile
@@ -2,36 +2,39 @@
# $FreeBSD$
PORTNAME= linuxsampler
-PORTVERSION= 1.0.0
-PORTREVISION= 8
+DISTVERSION= 2.0.0
CATEGORIES= audio
MASTER_SITES= http://download.linuxsampler.org/packages/
MAINTAINER= ports@FreeBSD.org
COMMENT= Modular MIDI sampler
-LIB_DEPENDS= libgig.so:audio/libgig
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
-RESTRICTED= no commercial use
-
-ONLY_FOR_ARCHS= i386 amd64
+ONLY_FOR_ARCHS= amd64 i386
ONLY_FOR_ARCHS_REASON= "not yet ported"
+BUILD_DEPENDS= lv2>0:audio/lv2
+LIB_DEPENDS= libgig.so:audio/libgig \
+ libsndfile.so:audio/libsndfile \
+ libuuid.so:misc/e2fsprogs-libuuid
+
OPTIONS_DEFINE= JACK ALSA DSSI LV2
OPTIONS_DEFAULT= JACK
DSSI_DESC= Enable DSSI support
LV2_DESC= Enable LV2 support
-USES= tar:bzip2 libtool gmake pathfix pkgconfig sqlite:3
+USES= bison gmake libtool pathfix pkgconfig sqlite:3 tar:bzip2
GNU_CONFIGURE= yes
CONFIGURE_ENV= HAVE_UNIX98=1
-USE_LDCONFIG= yes
+USE_LDCONFIG= ${PREFIX}/lib/linuxsampler
INSTALL_TARGET= install-strip
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ARGS+=--disable-arts-driver
+CONFIGURE_ARGS+= --disable-arts-driver
.include <bsd.port.options.mk>
diff --git a/audio/linuxsampler/distinfo b/audio/linuxsampler/distinfo
index 878b19b49c4f..15765a6b9aed 100644
--- a/audio/linuxsampler/distinfo
+++ b/audio/linuxsampler/distinfo
@@ -1,2 +1,3 @@
-SHA256 (linuxsampler-1.0.0.tar.bz2) = bf4f4f83b9ab706e8e8b017aafb560c363bb7663413aeae46d49f1f56110c9cf
-SIZE (linuxsampler-1.0.0.tar.bz2) = 701591
+TIMESTAMP = 1511122817
+SHA256 (linuxsampler-2.0.0.tar.bz2) = 1943d05006d96a9fb49f74a6f38129a4585cb78cc0648885fca9f056529c5c28
+SIZE (linuxsampler-2.0.0.tar.bz2) = 1318939
diff --git a/audio/linuxsampler/files/patch-configure b/audio/linuxsampler/files/patch-configure
new file mode 100644
index 000000000000..fd90fb39c897
--- /dev/null
+++ b/audio/linuxsampler/files/patch-configure
@@ -0,0 +1,176 @@
+--- configure.orig 2015-07-15 20:30:20 UTC
++++ configure
+@@ -10097,7 +10097,7 @@ $as_echo_n "checking whether the $compil
+ hardcode_minus_L=no
+ hardcode_shlibpath_var=unsupported
+ inherit_rpath=no
+- link_all_deplibs=unknown
++ link_all_deplibs=no
+ module_cmds=
+ module_expsym_cmds=
+ old_archive_from_new_cmds=
+@@ -10366,7 +10366,7 @@ _LT_EOF
+ wlarc=
+ else
+ archive_cmds='$CC -shared $pic_flag $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname -o $lib'
+- archive_expsym_cmds='$CC -shared $pic_flag $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname ${wl}-retain-symbols-file $wl$export_symbols -o $lib'
++ archive_expsym_cmds='echo "{ global:" > $lib-ver~ sed -e "s|$|;|" < $export_symbols >> $lib-ver~ echo "local: *; };" >> $lib-ver~$CC -shared $pic_flag $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname ${wl}-version-script $wl$lib-ver -o $lib'
+ fi
+ ;;
+
+@@ -10385,7 +10385,7 @@ _LT_EOF
+ _LT_EOF
+ elif $LD --help 2>&1 | $GREP ': supported targets:.* elf' > /dev/null; then
+ archive_cmds='$CC -shared $pic_flag $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname -o $lib'
+- archive_expsym_cmds='$CC -shared $pic_flag $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname ${wl}-retain-symbols-file $wl$export_symbols -o $lib'
++ archive_expsym_cmds='echo "{ global:" > $lib-ver~ sed -e "s|$|;|" < $export_symbols >> $lib-ver~ echo "local: *; };" >> $lib-ver~$CC -shared $pic_flag $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname ${wl}-version-script $wl$lib-ver -o $lib'
+ else
+ ld_shlibs=no
+ fi
+@@ -10414,7 +10414,7 @@ _LT_EOF
+ if $LD --help 2>&1 | $GREP ': supported targets:.* elf' > /dev/null; then
+ hardcode_libdir_flag_spec='${wl}-rpath ${wl}$libdir'
+ archive_cmds='$CC -shared $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname -o $lib'
+- archive_expsym_cmds='$CC -shared $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname ${wl}-retain-symbols-file $wl$export_symbols -o $lib'
++ archive_expsym_cmds='echo "{ global:" > $lib-ver~ sed -e "s|$|;|" < $export_symbols >> $lib-ver~ echo "local: *; };" >> $lib-ver~$CC -shared $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname ${wl}-version-script $wl$lib-ver -o $lib'
+ else
+ ld_shlibs=no
+ fi
+@@ -10432,7 +10432,7 @@ _LT_EOF
+ *)
+ if $LD --help 2>&1 | $GREP ': supported targets:.* elf' > /dev/null; then
+ archive_cmds='$CC -shared $pic_flag $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname -o $lib'
+- archive_expsym_cmds='$CC -shared $pic_flag $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname ${wl}-retain-symbols-file $wl$export_symbols -o $lib'
++ archive_expsym_cmds='echo "{ global:" > $lib-ver~ sed -e "s|$|;|" < $export_symbols >> $lib-ver~ echo "local: *; };" >> $lib-ver~$CC -shared $pic_flag $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname ${wl}-version-script $wl$lib-ver -o $lib'
+ else
+ ld_shlibs=no
+ fi
+@@ -11020,7 +11020,7 @@ $as_echo "$lt_cv_irix_exported_symbol" >
+ hardcode_direct_absolute=yes
+ if test -z "`echo __ELF__ | $CC -E - | $GREP __ELF__`" || test "$host_os-$host_cpu" = "openbsd2.8-powerpc"; then
+ archive_cmds='$CC -shared $pic_flag -o $lib $libobjs $deplibs $compiler_flags'
+- archive_expsym_cmds='$CC -shared $pic_flag -o $lib $libobjs $deplibs $compiler_flags ${wl}-retain-symbols-file,$export_symbols'
++ archive_expsym_cmds='echo "{ global:" > $lib-ver~ sed -e "s|$|;|" < $export_symbols >> $lib-ver~ echo "local: *; };" >> $lib-ver~$CC -shared $pic_flag -o $lib $libobjs $deplibs $compiler_flags ${wl}-version-script,$lib-ver'
+ hardcode_libdir_flag_spec='${wl}-rpath,$libdir'
+ export_dynamic_flag_spec='${wl}-E'
+ else
+@@ -11798,7 +11798,7 @@ freebsd* | dragonfly*)
+ version_type=freebsd-$objformat
+ case $version_type in
+ freebsd-elf*)
+- library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext} $libname${shared_ext}'
++ library_names_spec='$libname$release$shared_ext$versuffix $libname$release$shared_ext$major $libname$shared_ext' soname_spec='$libname$release$shared_ext$major'
+ need_version=no
+ need_lib_prefix=no
+ ;;
+@@ -12882,7 +12882,7 @@ striplib=
+ old_striplib=
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether stripping libraries is possible" >&5
+ $as_echo_n "checking whether stripping libraries is possible... " >&6; }
+-if test -n "$STRIP" && $STRIP -V 2>&1 | $GREP "GNU strip" >/dev/null; then
++if test -n "$STRIP" && $STRIP -V 2>&1 | $GREP "strip" >/dev/null; then
+ test -z "$old_striplib" && old_striplib="$STRIP --strip-debug"
+ test -z "$striplib" && striplib="$STRIP --strip-unneeded"
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
+@@ -13130,7 +13130,7 @@ hardcode_automatic_CXX=no
+ inherit_rpath_CXX=no
+ module_cmds_CXX=
+ module_expsym_cmds_CXX=
+-link_all_deplibs_CXX=unknown
++link_all_deplibs_CXX=no
+ old_archive_cmds_CXX=$old_archive_cmds
+ reload_flag_CXX=$reload_flag
+ reload_cmds_CXX=$reload_cmds
+@@ -13348,7 +13348,7 @@ with_gnu_ld=$lt_cv_prog_gnu_ld
+ # archiving commands below assume that GNU ld is being used.
+ if test "$with_gnu_ld" = yes; then
+ archive_cmds_CXX='$CC $pic_flag -shared -nostdlib $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags ${wl}-soname $wl$soname -o $lib'
+- archive_expsym_cmds_CXX='$CC $pic_flag -shared -nostdlib $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags ${wl}-soname $wl$soname ${wl}-retain-symbols-file $wl$export_symbols -o $lib'
++ archive_expsym_cmds_CXX='echo "{ global:" > $lib-ver~ sed -e "s|$|;|" < $export_symbols >> $lib-ver~ echo "local: *; };" >> $lib-ver~$CC $pic_flag -shared -nostdlib $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags ${wl}-soname $wl$soname ${wl}-version-script $wl$lib-ver -o $lib'
+
+ hardcode_libdir_flag_spec_CXX='${wl}-rpath ${wl}$libdir'
+ export_dynamic_flag_spec_CXX='${wl}--export-dynamic'
+@@ -13964,7 +13964,7 @@ fi
+ case `$CC -V 2>&1` in
+ *"Version 7."*)
+ archive_cmds_CXX='$CC -shared $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags ${wl}-soname $wl$soname -o $lib'
+- archive_expsym_cmds_CXX='$CC -shared $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags ${wl}-soname $wl$soname ${wl}-retain-symbols-file $wl$export_symbols -o $lib'
++ archive_expsym_cmds_CXX='echo "{ global:" > $lib-ver~ sed -e "s|$|;|" < $export_symbols >> $lib-ver~ echo "local: *; };" >> $lib-ver~$CC -shared $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags ${wl}-soname $wl$soname ${wl}-version-script $wl$lib-ver -o $lib'
+ ;;
+ *) # Version 8.0 or newer
+ tmp_idyn=
+@@ -13972,7 +13972,7 @@ fi
+ ia64*) tmp_idyn=' -i_dynamic';;
+ esac
+ archive_cmds_CXX='$CC -shared'"$tmp_idyn"' $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname -o $lib'
+- archive_expsym_cmds_CXX='$CC -shared'"$tmp_idyn"' $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname ${wl}-retain-symbols-file $wl$export_symbols -o $lib'
++ archive_expsym_cmds_CXX='echo "{ global:" > $lib-ver~ sed -e "s|$|;|" < $export_symbols >> $lib-ver~ echo "local: *; };" >> $lib-ver~$CC -shared'"$tmp_idyn"' $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname ${wl}-version-script $wl$lib-ver -o $lib'
+ ;;
+ esac
+ archive_cmds_need_lc_CXX=no
+@@ -14004,7 +14004,7 @@ fi
+ ;;
+ *) # Version 6 and above use weak symbols
+ archive_cmds_CXX='$CC -shared $pic_flag $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags ${wl}-soname ${wl}$soname -o $lib'
+- archive_expsym_cmds_CXX='$CC -shared $pic_flag $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags ${wl}-soname ${wl}$soname ${wl}-retain-symbols-file ${wl}$export_symbols -o $lib'
++ archive_expsym_cmds_CXX='echo "{ global:" > $lib-ver~ sed -e "s|$|;|" < $export_symbols >> $lib-ver~ echo "local: *; };" >> $lib-ver~$CC -shared $pic_flag $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags ${wl}-soname ${wl}$soname ${wl}-version-script ${wl}$lib-ver -o $lib'
+ ;;
+ esac
+
+@@ -14015,7 +14015,7 @@ fi
+ cxx*)
+ # Compaq C++
+ archive_cmds_CXX='$CC -shared $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags ${wl}-soname $wl$soname -o $lib'
+- archive_expsym_cmds_CXX='$CC -shared $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags ${wl}-soname $wl$soname -o $lib ${wl}-retain-symbols-file $wl$export_symbols'
++ archive_expsym_cmds_CXX='echo "{ global:" > $lib-ver~ sed -e "s|$|;|" < $export_symbols >> $lib-ver~ echo "local: *; };" >> $lib-ver~$CC -shared $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags ${wl}-soname $wl$soname -o $lib ${wl}-version-script $wl$lib-ver'
+
+ runpath_var=LD_RUN_PATH
+ hardcode_libdir_flag_spec_CXX='-rpath $libdir'
+@@ -14049,7 +14049,7 @@ fi
+ # Sun C++ 5.9
+ no_undefined_flag_CXX=' -zdefs'
+ archive_cmds_CXX='$CC -G${allow_undefined_flag} -h$soname -o $lib $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags'
+- archive_expsym_cmds_CXX='$CC -G${allow_undefined_flag} -h$soname -o $lib $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags ${wl}-retain-symbols-file ${wl}$export_symbols'
++ archive_expsym_cmds_CXX='echo "{ global:" > $lib-ver~ sed -e "s|$|;|" < $export_symbols >> $lib-ver~ echo "local: *; };" >> $lib-ver~$CC -G${allow_undefined_flag} -h$soname -o $lib $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags ${wl}-version-script ${wl}$lib-ver'
+ hardcode_libdir_flag_spec_CXX='-R$libdir'
+ whole_archive_flag_spec_CXX='${wl}--whole-archive`new_convenience=; for conv in $convenience\"\"; do test -z \"$conv\" || new_convenience=\"$new_convenience,$conv\"; done; func_echo_all \"$new_convenience\"` ${wl}--no-whole-archive'
+ compiler_needs_object_CXX=yes
+@@ -14122,7 +14122,7 @@ fi
+ archive_cmds_CXX='$CC -shared $pic_flag $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags -o $lib'
+ hardcode_libdir_flag_spec_CXX='${wl}-rpath,$libdir'
+ if test -z "`echo __ELF__ | $CC -E - | grep __ELF__`" || test "$host_os-$host_cpu" = "openbsd2.8-powerpc"; then
+- archive_expsym_cmds_CXX='$CC -shared $pic_flag $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags ${wl}-retain-symbols-file,$export_symbols -o $lib'
++ archive_expsym_cmds_CXX='echo "{ global:" > $lib-ver~ sed -e "s|$|;|" < $export_symbols >> $lib-ver~ echo "local: *; };" >> $lib-ver~$CC -shared $pic_flag $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags ${wl}-version-script,$lib-ver -o $lib'
+ export_dynamic_flag_spec_CXX='${wl}-E'
+ whole_archive_flag_spec_CXX="$wlarc"'--whole-archive$convenience '"$wlarc"'--no-whole-archive'
+ fi
+@@ -15630,7 +15630,7 @@ freebsd* | dragonfly*)
+ version_type=freebsd-$objformat
+ case $version_type in
+ freebsd-elf*)
+- library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext} $libname${shared_ext}'
++ library_names_spec='$libname$release$shared_ext$versuffix $libname$release$shared_ext$major $libname$shared_ext' soname_spec='$libname$release$shared_ext$major'
+ need_version=no
+ need_lib_prefix=no
+ ;;
+@@ -16768,9 +16768,9 @@ _ACEOF
+ CXX_CPU_SWITCH=
+ if ! echo "X $CXXFLAGS " | grep -q -- " \(-march=\|-mcpu=\|-mtune=\|-arch=\)" ; then
+ if test "$def_arch_x86" = 1 -a "$host_cpu" != "x86_64"; then
+- CXX_CPU_SWITCH="-march=$host_cpu"
++ CXX_CPU_SWITCH=
+ elif test "$target_cpu" = "ppc"; then
+- CXX_CPU_SWITCH="-arch=$host_cpu"
++ CXX_CPU_SWITCH=
+ fi
+ fi
+
+@@ -17482,7 +17482,7 @@ fi
+ # parser yacc tables.
+ if echo "$YACC" | grep -q bison; then
+ # NOTE: m4 removes [], that's why it needs to be escaped
+- bison_version=`$YACC --version | head -n 1 | sed -e 's/[^0-9.]*\([-0-9.]\+\)$/\1/'`
++ bison_version=`$YACC --version | head -n 1 | sed -e 's/[^0-9.]*\([-0-9.]\+\)$/\1/' | sed -e 's/[[:alpha:][:space:]()]*//'`
+ bison_version_major=`echo $bison_version | cut -d. -f1`
+ bison_version_minor=`echo $bison_version | cut -d. -f2`
+
diff --git a/audio/linuxsampler/files/patch-src_Makefile.in b/audio/linuxsampler/files/patch-src_Makefile.in
new file mode 100644
index 000000000000..9fd5b8289c5b
--- /dev/null
+++ b/audio/linuxsampler/files/patch-src_Makefile.in
@@ -0,0 +1,11 @@
+--- src/Makefile.in.orig 2017-11-19 23:18:33 UTC
++++ src/Makefile.in
+@@ -428,7 +428,7 @@ top_srcdir = @top_srcdir@
+
+ # set the include path found by configure
+ AM_CPPFLAGS = $(all_includes) $(GIG_CFLAGS) $(SQLITE3_CFLAGS)
+-@HAVE_WINDOWS_FALSE@system_libs = -lpthread -ldl
++@HAVE_WINDOWS_FALSE@system_libs = -lpthread
+ @HAVE_WINDOWS_TRUE@system_libs =
+ @HAVE_WINDOWS_FALSE@SHELL_SUBDIR = shell
+ @HAVE_WINDOWS_TRUE@SHELL_SUBDIR =
diff --git a/audio/linuxsampler/files/patch-src_common_Mutex.cpp b/audio/linuxsampler/files/patch-src_common_Mutex.cpp
index 6ee360146153..9069f596356d 100644
--- a/audio/linuxsampler/files/patch-src_common_Mutex.cpp
+++ b/audio/linuxsampler/files/patch-src_common_Mutex.cpp
@@ -1,4 +1,4 @@
---- src/common/Mutex.cpp.orig 2007-11-15 00:23:37 UTC
+--- src/common/Mutex.cpp.orig 2007-11-14 23:42:15 UTC
+++ src/common/Mutex.cpp
@@ -36,7 +36,6 @@
#if !defined(WIN32)
diff --git a/audio/linuxsampler/files/patch-src_common_Pool.h b/audio/linuxsampler/files/patch-src_common_Pool.h
deleted file mode 100644
index d87e3dbaf10d..000000000000
--- a/audio/linuxsampler/files/patch-src_common_Pool.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/common/Pool.h.orig 2008-12-07 00:18:04 UTC
-+++ src/common/Pool.h
-@@ -393,7 +393,7 @@ class RTList : public RTListBase<T> {
- inline Iterator allocAppend() {
- if (pPool->poolIsEmpty()) return RTListBase<T>::begin();
- Iterator element = pPool->alloc();
-- append(element);
-+ this->append(element);
- #if CONFIG_DEVMODE
- element.list = this;
- #endif // CONFIG_DEVMODE
diff --git a/audio/linuxsampler/files/patch-src_common_atomic.h b/audio/linuxsampler/files/patch-src_common_atomic.h
index 3f45d5feaf49..d5753f41bffd 100644
--- a/audio/linuxsampler/files/patch-src_common_atomic.h
+++ b/audio/linuxsampler/files/patch-src_common_atomic.h
@@ -1,4 +1,4 @@
---- src/common/atomic.h.orig 2009-03-29 18:43:39 UTC
+--- src/common/atomic.h.orig 2009-03-29 18:43:40 UTC
+++ src/common/atomic.h
@@ -38,7 +38,7 @@
#define CONFIG_SMP /* ... the macro the kernel headers use */
diff --git a/audio/linuxsampler/files/patch-src_drivers_audio_AudioChannel.cpp b/audio/linuxsampler/files/patch-src_drivers_audio_AudioChannel.cpp
index 8ae98c5f5e62..0a635e63620d 100644
--- a/audio/linuxsampler/files/patch-src_drivers_audio_AudioChannel.cpp
+++ b/audio/linuxsampler/files/patch-src_drivers_audio_AudioChannel.cpp
@@ -1,4 +1,4 @@
---- src/drivers/audio/AudioChannel.cpp.orig 2009-07-04 12:13:58 UTC
+--- src/drivers/audio/AudioChannel.cpp.orig 2012-10-04 18:16:26 UTC
+++ src/drivers/audio/AudioChannel.cpp
@@ -26,7 +26,7 @@
#include "../../common/global_private.h"
diff --git a/audio/linuxsampler/pkg-plist b/audio/linuxsampler/pkg-plist
index 76d64519c50a..2f8710d60b4a 100644
--- a/audio/linuxsampler/pkg-plist
+++ b/audio/linuxsampler/pkg-plist
@@ -1,7 +1,10 @@
bin/linuxsampler
+bin/ls_instr_script
+bin/lscp
include/linuxsampler/EventListeners.h
include/linuxsampler/Sampler.h
include/linuxsampler/common/Condition.h
+include/linuxsampler/common/ConstCapacityArray.h
include/linuxsampler/common/Exception.h
include/linuxsampler/common/Mutex.h
include/linuxsampler/common/SynchronizedConfig.h
@@ -20,6 +23,9 @@ include/linuxsampler/drivers/midi/VirtualMidiDevice.h
include/linuxsampler/drivers/midi/midi.h
include/linuxsampler/effects/Effect.h
include/linuxsampler/effects/EffectChain.h
+include/linuxsampler/effects/EffectControl.h
+include/linuxsampler/effects/EffectFactory.h
+include/linuxsampler/effects/EffectInfo.h
include/linuxsampler/engines/Engine.h
include/linuxsampler/engines/EngineChannel.h
include/linuxsampler/engines/FxSend.h
@@ -30,8 +36,8 @@ include/linuxsampler/plugins/InstrumentEditorFactory.h
%%DSSI%%lib/dssi/linuxsampler.so
lib/linuxsampler/liblinuxsampler.a
lib/linuxsampler/liblinuxsampler.so
-lib/linuxsampler/liblinuxsampler.so.3
-lib/linuxsampler/liblinuxsampler.so.3.0.0
+lib/linuxsampler/liblinuxsampler.so.4
+lib/linuxsampler/liblinuxsampler.so.4.0.0
lib/linuxsampler/plugins/.keep_me
%%LV2%%lib/lv2/linuxsampler.lv2/linuxsampler.a
%%LV2%%lib/lv2/linuxsampler.lv2/linuxsampler.so
@@ -39,6 +45,7 @@ lib/linuxsampler/plugins/.keep_me
%%LV2%%lib/lv2/linuxsampler.lv2/manifest.ttl
libdata/pkgconfig/linuxsampler.pc
man/man1/linuxsampler.1.gz
+man/man1/lscp.1.gz
/var/lib/linuxsampler/instruments.db
@dir /var/lib/linuxsampler
@dir /var/lib