aboutsummaryrefslogtreecommitdiff
path: root/audio/linuxsampler
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-05-07 05:51:28 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-05-07 05:51:28 +0000
commit7a16d47d11832824f2711358624518fd034252f4 (patch)
tree1fe1fca7390ac9708a63410f273f12a7c1b7cef8 /audio/linuxsampler
parent1aabdc4e97adf2680a89e5ec22410222bd6c92e2 (diff)
downloadports-7a16d47d11832824f2711358624518fd034252f4.tar.gz
ports-7a16d47d11832824f2711358624518fd034252f4.zip
audio/linuxsampler: Update 2.0.0 -> 2.1.0
* Change to option helpers * Update http -> https Reported by: protonlucifer <protonlucifer@protonmail.com>
Notes
Notes: svn path=/head/; revision=500950
Diffstat (limited to 'audio/linuxsampler')
-rw-r--r--audio/linuxsampler/Makefile54
-rw-r--r--audio/linuxsampler/distinfo6
-rw-r--r--audio/linuxsampler/files/patch-configure140
-rw-r--r--audio/linuxsampler/files/patch-src_common_Mutex.cpp16
-rw-r--r--audio/linuxsampler/pkg-descr2
-rw-r--r--audio/linuxsampler/pkg-plist7
6 files changed, 102 insertions, 123 deletions
diff --git a/audio/linuxsampler/Makefile b/audio/linuxsampler/Makefile
index 3be3e88cd1f0..1c83e37a04f8 100644
--- a/audio/linuxsampler/Makefile
+++ b/audio/linuxsampler/Makefile
@@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= linuxsampler
-DISTVERSION= 2.0.0
-PORTREVISION= 1
+DISTVERSION= 2.1.0
CATEGORIES= audio
-MASTER_SITES= http://download.linuxsampler.org/packages/
+MASTER_SITES= https://download.linuxsampler.org/packages/
MAINTAINER= yuri@FreeBSD.org
COMMENT= Modular MIDI sampler
@@ -21,54 +20,31 @@ LIB_DEPENDS= libgig.so:audio/libgig \
libsndfile.so:audio/libsndfile \
libuuid.so:misc/e2fsprogs-libuuid
-OPTIONS_DEFINE= JACK ALSA DSSI LV2
-OPTIONS_DEFAULT= JACK
-DSSI_DESC= Enable DSSI support
-LV2_DESC= Enable LV2 support
-
USES= bison gmake libtool pathfix pkgconfig sqlite:3 tar:bzip2
GNU_CONFIGURE= yes
CONFIGURE_ENV= HAVE_UNIX98=1
USE_LDCONFIG= ${PREFIX}/lib/linuxsampler
INSTALL_TARGET= install-strip
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-
CONFIGURE_ARGS+= --disable-arts-driver
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= JACK ALSA DSSI LV2
+OPTIONS_DEFAULT= JACK
+OPTIONS_SUB= yes
-.if ${PORT_OPTIONS:MJACK}
-LIB_DEPENDS+= libjack.so:audio/jack
-.else
-CONFIGURE_ARGS+=--disable-jack-driver
-.endif
+JACK_LIB_DEPENDS= libjack.so:audio/jack
+JACK_CONFIGURE_ENABLE= jack-driver
-.if ${PORT_OPTIONS:MALSA}
-LIB_DEPENDS+= libasound.so:audio/alsa-lib
-.else
-CONFIGURE_ARGS+=--disable-alsa-driver
-.endif
+ALSA_LIB_DEPENDS= libasound.so:audio/alsa-lib
+ALSA_CONFIGURE_ENABLE= alsa-driver
-.if ${PORT_OPTIONS:MDSSI}
-BUILD_DEPENDS+= dssi>=0:audio/dssi
-RUN_DEPENDS+= dssi>=0:audio/dssi
-PLIST_SUB+= DSSI=""
-CPPFLAGS:= -I${LOCALBASE}/include/dssi ${CPPFLAGS}
-.else
-CONFIGURE_ENV+= ac_cv_header_dssi_h=no
-PLIST_SUB+= DSSI="@comment "
-.endif
+DSSI_DESC= Enable DSSI support
+DSSI_BUILD_DEPENDS= dssi>0:audio/dssi
+DSSI_CPPFLAGS= -I${LOCALBASE}/include/dssi
-.if ${PORT_OPTIONS:MLV2}
-BUILD_DEPENDS+= lv2>=1.14.0_1:audio/lv2
-RUN_DEPENDS+= lv2>=1.14.0_1:audio/lv2
-PLIST_SUB+= LV2=""
-.else
-CONFIGURE_ENV+= ac_cv_header_lv2_h=no
-PLIST_SUB+= LV2="@comment "
-.endif
+LV2_DESC= Enable LV2 support
+LV2_BUILD_DEPENDS= lv2>0:audio/lv2
+LV2_CONFIGURE_ENV_OFF= ac_cv_header_lv2_h=no
post-patch:
@${REINPLACE_CMD} -e \
diff --git a/audio/linuxsampler/distinfo b/audio/linuxsampler/distinfo
index 15765a6b9aed..1c016337f8a1 100644
--- a/audio/linuxsampler/distinfo
+++ b/audio/linuxsampler/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1511122817
-SHA256 (linuxsampler-2.0.0.tar.bz2) = 1943d05006d96a9fb49f74a6f38129a4585cb78cc0648885fca9f056529c5c28
-SIZE (linuxsampler-2.0.0.tar.bz2) = 1318939
+TIMESTAMP = 1557208173
+SHA256 (linuxsampler-2.1.0.tar.bz2) = 4e0a49efeae9c26a223094247b7e01108d829a69618492282a203a290fbfbd39
+SIZE (linuxsampler-2.1.0.tar.bz2) = 1154834
diff --git a/audio/linuxsampler/files/patch-configure b/audio/linuxsampler/files/patch-configure
index fd90fb39c897..e959a52e8cef 100644
--- a/audio/linuxsampler/files/patch-configure
+++ b/audio/linuxsampler/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2015-07-15 20:30:20 UTC
+--- configure.orig 2017-11-25 17:33:38 UTC
+++ configure
-@@ -10097,7 +10097,7 @@ $as_echo_n "checking whether the $compil
+@@ -10376,7 +10376,7 @@ $as_echo_n "checking whether the $compil
hardcode_minus_L=no
hardcode_shlibpath_var=unsupported
inherit_rpath=no
@@ -9,61 +9,61 @@
module_cmds=
module_expsym_cmds=
old_archive_from_new_cmds=
-@@ -10366,7 +10366,7 @@ _LT_EOF
+@@ -10678,7 +10678,7 @@ _LT_EOF
wlarc=
else
- archive_cmds='$CC -shared $pic_flag $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname -o $lib'
-- archive_expsym_cmds='$CC -shared $pic_flag $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname ${wl}-retain-symbols-file $wl$export_symbols -o $lib'
-+ archive_expsym_cmds='echo "{ global:" > $lib-ver~ sed -e "s|$|;|" < $export_symbols >> $lib-ver~ echo "local: *; };" >> $lib-ver~$CC -shared $pic_flag $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname ${wl}-version-script $wl$lib-ver -o $lib'
+ archive_cmds='$CC -shared $pic_flag $libobjs $deplibs $compiler_flags $wl-soname $wl$soname -o $lib'
+- archive_expsym_cmds='$CC -shared $pic_flag $libobjs $deplibs $compiler_flags $wl-soname $wl$soname $wl-retain-symbols-file $wl$export_symbols -o $lib'
++ archive_expsym_cmds='echo "{ global:" > $lib-ver~ sed -e "s|$|;|" < $export_symbols >> $lib-ver~ echo "local: *; };" >> $lib-ver~$CC -shared $pic_flag $libobjs $deplibs $compiler_flags $wl-soname $wl$soname $wl-version-script $wl$lib-ver -o $lib'
fi
;;
-@@ -10385,7 +10385,7 @@ _LT_EOF
+@@ -10697,7 +10697,7 @@ _LT_EOF
_LT_EOF
elif $LD --help 2>&1 | $GREP ': supported targets:.* elf' > /dev/null; then
- archive_cmds='$CC -shared $pic_flag $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname -o $lib'
-- archive_expsym_cmds='$CC -shared $pic_flag $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname ${wl}-retain-symbols-file $wl$export_symbols -o $lib'
-+ archive_expsym_cmds='echo "{ global:" > $lib-ver~ sed -e "s|$|;|" < $export_symbols >> $lib-ver~ echo "local: *; };" >> $lib-ver~$CC -shared $pic_flag $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname ${wl}-version-script $wl$lib-ver -o $lib'
+ archive_cmds='$CC -shared $pic_flag $libobjs $deplibs $compiler_flags $wl-soname $wl$soname -o $lib'
+- archive_expsym_cmds='$CC -shared $pic_flag $libobjs $deplibs $compiler_flags $wl-soname $wl$soname $wl-retain-symbols-file $wl$export_symbols -o $lib'
++ archive_expsym_cmds='echo "{ global:" > $lib-ver~ sed -e "s|$|;|" < $export_symbols >> $lib-ver~ echo "local: *; };" >> $lib-ver~$CC -shared $pic_flag $libobjs $deplibs $compiler_flags $wl-soname $wl$soname $wl-version-script $wl$lib-ver -o $lib'
else
ld_shlibs=no
fi
-@@ -10414,7 +10414,7 @@ _LT_EOF
+@@ -10726,7 +10726,7 @@ _LT_EOF
if $LD --help 2>&1 | $GREP ': supported targets:.* elf' > /dev/null; then
- hardcode_libdir_flag_spec='${wl}-rpath ${wl}$libdir'
- archive_cmds='$CC -shared $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname -o $lib'
-- archive_expsym_cmds='$CC -shared $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname ${wl}-retain-symbols-file $wl$export_symbols -o $lib'
-+ archive_expsym_cmds='echo "{ global:" > $lib-ver~ sed -e "s|$|;|" < $export_symbols >> $lib-ver~ echo "local: *; };" >> $lib-ver~$CC -shared $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname ${wl}-version-script $wl$lib-ver -o $lib'
+ hardcode_libdir_flag_spec='$wl-rpath $wl$libdir'
+ archive_cmds='$CC -shared $libobjs $deplibs $compiler_flags $wl-soname $wl$soname -o $lib'
+- archive_expsym_cmds='$CC -shared $libobjs $deplibs $compiler_flags $wl-soname $wl$soname $wl-retain-symbols-file $wl$export_symbols -o $lib'
++ archive_expsym_cmds='echo "{ global:" > $lib-ver~ sed -e "s|$|;|" < $export_symbols >> $lib-ver~ echo "local: *; };" >> $lib-ver~$CC -shared $libobjs $deplibs $compiler_flags $wl-soname $wl$soname $wl-version-script $wl$lib-ver -o $lib'
else
ld_shlibs=no
fi
-@@ -10432,7 +10432,7 @@ _LT_EOF
+@@ -10744,7 +10744,7 @@ _LT_EOF
*)
if $LD --help 2>&1 | $GREP ': supported targets:.* elf' > /dev/null; then
- archive_cmds='$CC -shared $pic_flag $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname -o $lib'
-- archive_expsym_cmds='$CC -shared $pic_flag $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname ${wl}-retain-symbols-file $wl$export_symbols -o $lib'
-+ archive_expsym_cmds='echo "{ global:" > $lib-ver~ sed -e "s|$|;|" < $export_symbols >> $lib-ver~ echo "local: *; };" >> $lib-ver~$CC -shared $pic_flag $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname ${wl}-version-script $wl$lib-ver -o $lib'
+ archive_cmds='$CC -shared $pic_flag $libobjs $deplibs $compiler_flags $wl-soname $wl$soname -o $lib'
+- archive_expsym_cmds='$CC -shared $pic_flag $libobjs $deplibs $compiler_flags $wl-soname $wl$soname $wl-retain-symbols-file $wl$export_symbols -o $lib'
++ archive_expsym_cmds='echo "{ global:" > $lib-ver~ sed -e "s|$|;|" < $export_symbols >> $lib-ver~ echo "local: *; };" >> $lib-ver~$CC -shared $pic_flag $libobjs $deplibs $compiler_flags $wl-soname $wl$soname $wl-version-script $wl$lib-ver -o $lib'
else
ld_shlibs=no
fi
-@@ -11020,7 +11020,7 @@ $as_echo "$lt_cv_irix_exported_symbol" >
+@@ -11393,7 +11393,7 @@ $as_echo "$lt_cv_irix_exported_symbol" >
hardcode_direct_absolute=yes
- if test -z "`echo __ELF__ | $CC -E - | $GREP __ELF__`" || test "$host_os-$host_cpu" = "openbsd2.8-powerpc"; then
+ if test -z "`echo __ELF__ | $CC -E - | $GREP __ELF__`"; then
archive_cmds='$CC -shared $pic_flag -o $lib $libobjs $deplibs $compiler_flags'
-- archive_expsym_cmds='$CC -shared $pic_flag -o $lib $libobjs $deplibs $compiler_flags ${wl}-retain-symbols-file,$export_symbols'
-+ archive_expsym_cmds='echo "{ global:" > $lib-ver~ sed -e "s|$|;|" < $export_symbols >> $lib-ver~ echo "local: *; };" >> $lib-ver~$CC -shared $pic_flag -o $lib $libobjs $deplibs $compiler_flags ${wl}-version-script,$lib-ver'
- hardcode_libdir_flag_spec='${wl}-rpath,$libdir'
- export_dynamic_flag_spec='${wl}-E'
+- archive_expsym_cmds='$CC -shared $pic_flag -o $lib $libobjs $deplibs $compiler_flags $wl-retain-symbols-file,$export_symbols'
++ archive_expsym_cmds='echo "{ global:" > $lib-ver~ sed -e "s|$|;|" < $export_symbols >> $lib-ver~ echo "local: *; };" >> $lib-ver~$CC -shared $pic_flag -o $lib $libobjs $deplibs $compiler_flags $wl-version-script,$lib-ver'
+ hardcode_libdir_flag_spec='$wl-rpath,$libdir'
+ export_dynamic_flag_spec='$wl-E'
else
-@@ -11798,7 +11798,7 @@ freebsd* | dragonfly*)
+@@ -12242,7 +12242,7 @@ freebsd* | dragonfly*)
version_type=freebsd-$objformat
case $version_type in
freebsd-elf*)
-- library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext} $libname${shared_ext}'
+- library_names_spec='$libname$release$shared_ext$versuffix $libname$release$shared_ext$major $libname$shared_ext'
+ library_names_spec='$libname$release$shared_ext$versuffix $libname$release$shared_ext$major $libname$shared_ext' soname_spec='$libname$release$shared_ext$major'
+ soname_spec='$libname$release$shared_ext$major'
need_version=no
need_lib_prefix=no
- ;;
-@@ -12882,7 +12882,7 @@ striplib=
+@@ -13386,7 +13386,7 @@ striplib=
old_striplib=
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether stripping libraries is possible" >&5
$as_echo_n "checking whether stripping libraries is possible... " >&6; }
@@ -72,7 +72,7 @@
test -z "$old_striplib" && old_striplib="$STRIP --strip-debug"
test -z "$striplib" && striplib="$STRIP --strip-unneeded"
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
-@@ -13130,7 +13130,7 @@ hardcode_automatic_CXX=no
+@@ -13638,7 +13638,7 @@ hardcode_automatic_CXX=no
inherit_rpath_CXX=no
module_cmds_CXX=
module_expsym_cmds_CXX=
@@ -81,79 +81,79 @@
old_archive_cmds_CXX=$old_archive_cmds
reload_flag_CXX=$reload_flag
reload_cmds_CXX=$reload_cmds
-@@ -13348,7 +13348,7 @@ with_gnu_ld=$lt_cv_prog_gnu_ld
+@@ -13849,7 +13849,7 @@ with_gnu_ld=$lt_cv_prog_gnu_ld
# archiving commands below assume that GNU ld is being used.
- if test "$with_gnu_ld" = yes; then
- archive_cmds_CXX='$CC $pic_flag -shared -nostdlib $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags ${wl}-soname $wl$soname -o $lib'
-- archive_expsym_cmds_CXX='$CC $pic_flag -shared -nostdlib $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags ${wl}-soname $wl$soname ${wl}-retain-symbols-file $wl$export_symbols -o $lib'
-+ archive_expsym_cmds_CXX='echo "{ global:" > $lib-ver~ sed -e "s|$|;|" < $export_symbols >> $lib-ver~ echo "local: *; };" >> $lib-ver~$CC $pic_flag -shared -nostdlib $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags ${wl}-soname $wl$soname ${wl}-version-script $wl$lib-ver -o $lib'
+ if test yes = "$with_gnu_ld"; then
+ archive_cmds_CXX='$CC $pic_flag -shared -nostdlib $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags $wl-soname $wl$soname -o $lib'
+- archive_expsym_cmds_CXX='$CC $pic_flag -shared -nostdlib $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags $wl-soname $wl$soname $wl-retain-symbols-file $wl$export_symbols -o $lib'
++ archive_expsym_cmds_CXX='echo "{ global:" > $lib-ver~ sed -e "s|$|;|" < $export_symbols >> $lib-ver~ echo "local: *; };" >> $lib-ver~$CC $pic_flag -shared -nostdlib $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags $wl-soname $wl$soname $wl-version-script $wl$lib-ver -o $lib'
- hardcode_libdir_flag_spec_CXX='${wl}-rpath ${wl}$libdir'
- export_dynamic_flag_spec_CXX='${wl}--export-dynamic'
-@@ -13964,7 +13964,7 @@ fi
+ hardcode_libdir_flag_spec_CXX='$wl-rpath $wl$libdir'
+ export_dynamic_flag_spec_CXX='$wl--export-dynamic'
+@@ -14541,7 +14541,7 @@ fi
case `$CC -V 2>&1` in
*"Version 7."*)
- archive_cmds_CXX='$CC -shared $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags ${wl}-soname $wl$soname -o $lib'
-- archive_expsym_cmds_CXX='$CC -shared $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags ${wl}-soname $wl$soname ${wl}-retain-symbols-file $wl$export_symbols -o $lib'
-+ archive_expsym_cmds_CXX='echo "{ global:" > $lib-ver~ sed -e "s|$|;|" < $export_symbols >> $lib-ver~ echo "local: *; };" >> $lib-ver~$CC -shared $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags ${wl}-soname $wl$soname ${wl}-version-script $wl$lib-ver -o $lib'
+ archive_cmds_CXX='$CC -shared $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags $wl-soname $wl$soname -o $lib'
+- archive_expsym_cmds_CXX='$CC -shared $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags $wl-soname $wl$soname $wl-retain-symbols-file $wl$export_symbols -o $lib'
++ archive_expsym_cmds_CXX='echo "{ global:" > $lib-ver~ sed -e "s|$|;|" < $export_symbols >> $lib-ver~ echo "local: *; };" >> $lib-ver~$CC -shared $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags $wl-soname $wl$soname $wl-version-script $wl$lib-ver -o $lib'
;;
*) # Version 8.0 or newer
tmp_idyn=
-@@ -13972,7 +13972,7 @@ fi
+@@ -14549,7 +14549,7 @@ fi
ia64*) tmp_idyn=' -i_dynamic';;
esac
- archive_cmds_CXX='$CC -shared'"$tmp_idyn"' $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname -o $lib'
-- archive_expsym_cmds_CXX='$CC -shared'"$tmp_idyn"' $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname ${wl}-retain-symbols-file $wl$export_symbols -o $lib'
-+ archive_expsym_cmds_CXX='echo "{ global:" > $lib-ver~ sed -e "s|$|;|" < $export_symbols >> $lib-ver~ echo "local: *; };" >> $lib-ver~$CC -shared'"$tmp_idyn"' $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname ${wl}-version-script $wl$lib-ver -o $lib'
+ archive_cmds_CXX='$CC -shared'"$tmp_idyn"' $libobjs $deplibs $compiler_flags $wl-soname $wl$soname -o $lib'
+- archive_expsym_cmds_CXX='$CC -shared'"$tmp_idyn"' $libobjs $deplibs $compiler_flags $wl-soname $wl$soname $wl-retain-symbols-file $wl$export_symbols -o $lib'
++ archive_expsym_cmds_CXX='echo "{ global:" > $lib-ver~ sed -e "s|$|;|" < $export_symbols >> $lib-ver~ echo "local: *; };" >> $lib-ver~$CC -shared'"$tmp_idyn"' $libobjs $deplibs $compiler_flags $wl-soname $wl$soname $wl-version-script $wl$lib-ver -o $lib'
;;
esac
archive_cmds_need_lc_CXX=no
-@@ -14004,7 +14004,7 @@ fi
+@@ -14581,7 +14581,7 @@ fi
;;
*) # Version 6 and above use weak symbols
- archive_cmds_CXX='$CC -shared $pic_flag $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags ${wl}-soname ${wl}$soname -o $lib'
-- archive_expsym_cmds_CXX='$CC -shared $pic_flag $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags ${wl}-soname ${wl}$soname ${wl}-retain-symbols-file ${wl}$export_symbols -o $lib'
-+ archive_expsym_cmds_CXX='echo "{ global:" > $lib-ver~ sed -e "s|$|;|" < $export_symbols >> $lib-ver~ echo "local: *; };" >> $lib-ver~$CC -shared $pic_flag $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags ${wl}-soname ${wl}$soname ${wl}-version-script ${wl}$lib-ver -o $lib'
+ archive_cmds_CXX='$CC -shared $pic_flag $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags $wl-soname $wl$soname -o $lib'
+- archive_expsym_cmds_CXX='$CC -shared $pic_flag $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags $wl-soname $wl$soname $wl-retain-symbols-file $wl$export_symbols -o $lib'
++ archive_expsym_cmds_CXX='echo "{ global:" > $lib-ver~ sed -e "s|$|;|" < $export_symbols >> $lib-ver~ echo "local: *; };" >> $lib-ver~$CC -shared $pic_flag $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags $wl-soname $wl$soname $wl-version-script $wl$lib-ver -o $lib'
;;
esac
-@@ -14015,7 +14015,7 @@ fi
+@@ -14592,7 +14592,7 @@ fi
cxx*)
# Compaq C++
- archive_cmds_CXX='$CC -shared $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags ${wl}-soname $wl$soname -o $lib'
-- archive_expsym_cmds_CXX='$CC -shared $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags ${wl}-soname $wl$soname -o $lib ${wl}-retain-symbols-file $wl$export_symbols'
-+ archive_expsym_cmds_CXX='echo "{ global:" > $lib-ver~ sed -e "s|$|;|" < $export_symbols >> $lib-ver~ echo "local: *; };" >> $lib-ver~$CC -shared $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags ${wl}-soname $wl$soname -o $lib ${wl}-version-script $wl$lib-ver'
+ archive_cmds_CXX='$CC -shared $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags $wl-soname $wl$soname -o $lib'
+- archive_expsym_cmds_CXX='$CC -shared $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags $wl-soname $wl$soname -o $lib $wl-retain-symbols-file $wl$export_symbols'
++ archive_expsym_cmds_CXX='echo "{ global:" > $lib-ver~ sed -e "s|$|;|" < $export_symbols >> $lib-ver~ echo "local: *; };" >> $lib-ver~$CC -shared $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags $wl-soname $wl$soname -o $lib $wl-version-script $wl$lib-ver'
runpath_var=LD_RUN_PATH
hardcode_libdir_flag_spec_CXX='-rpath $libdir'
-@@ -14049,7 +14049,7 @@ fi
+@@ -14626,7 +14626,7 @@ fi
# Sun C++ 5.9
no_undefined_flag_CXX=' -zdefs'
- archive_cmds_CXX='$CC -G${allow_undefined_flag} -h$soname -o $lib $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags'
-- archive_expsym_cmds_CXX='$CC -G${allow_undefined_flag} -h$soname -o $lib $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags ${wl}-retain-symbols-file ${wl}$export_symbols'
-+ archive_expsym_cmds_CXX='echo "{ global:" > $lib-ver~ sed -e "s|$|;|" < $export_symbols >> $lib-ver~ echo "local: *; };" >> $lib-ver~$CC -G${allow_undefined_flag} -h$soname -o $lib $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags ${wl}-version-script ${wl}$lib-ver'
+ archive_cmds_CXX='$CC -G$allow_undefined_flag -h$soname -o $lib $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags'
+- archive_expsym_cmds_CXX='$CC -G$allow_undefined_flag -h$soname -o $lib $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags $wl-retain-symbols-file $wl$export_symbols'
++ archive_expsym_cmds_CXX='echo "{ global:" > $lib-ver~ sed -e "s|$|;|" < $export_symbols >> $lib-ver~ echo "local: *; };" >> $lib-ver~$CC -G$allow_undefined_flag -h$soname -o $lib $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags $wl-version-script $wl$lib-ver'
hardcode_libdir_flag_spec_CXX='-R$libdir'
- whole_archive_flag_spec_CXX='${wl}--whole-archive`new_convenience=; for conv in $convenience\"\"; do test -z \"$conv\" || new_convenience=\"$new_convenience,$conv\"; done; func_echo_all \"$new_convenience\"` ${wl}--no-whole-archive'
+ whole_archive_flag_spec_CXX='$wl--whole-archive`new_convenience=; for conv in $convenience\"\"; do test -z \"$conv\" || new_convenience=\"$new_convenience,$conv\"; done; func_echo_all \"$new_convenience\"` $wl--no-whole-archive'
compiler_needs_object_CXX=yes
-@@ -14122,7 +14122,7 @@ fi
+@@ -14694,7 +14694,7 @@ fi
archive_cmds_CXX='$CC -shared $pic_flag $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags -o $lib'
- hardcode_libdir_flag_spec_CXX='${wl}-rpath,$libdir'
- if test -z "`echo __ELF__ | $CC -E - | grep __ELF__`" || test "$host_os-$host_cpu" = "openbsd2.8-powerpc"; then
-- archive_expsym_cmds_CXX='$CC -shared $pic_flag $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags ${wl}-retain-symbols-file,$export_symbols -o $lib'
-+ archive_expsym_cmds_CXX='echo "{ global:" > $lib-ver~ sed -e "s|$|;|" < $export_symbols >> $lib-ver~ echo "local: *; };" >> $lib-ver~$CC -shared $pic_flag $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags ${wl}-version-script,$lib-ver -o $lib'
- export_dynamic_flag_spec_CXX='${wl}-E'
- whole_archive_flag_spec_CXX="$wlarc"'--whole-archive$convenience '"$wlarc"'--no-whole-archive'
+ hardcode_libdir_flag_spec_CXX='$wl-rpath,$libdir'
+ if test -z "`echo __ELF__ | $CC -E - | grep __ELF__`"; then
+- archive_expsym_cmds_CXX='$CC -shared $pic_flag $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags $wl-retain-symbols-file,$export_symbols -o $lib'
++ archive_expsym_cmds_CXX='echo "{ global:" > $lib-ver~ sed -e "s|$|;|" < $export_symbols >> $lib-ver~ echo "local: *; };" >> $lib-ver~$CC -shared $pic_flag $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags $wl-version-script,$lib-ver -o $lib'
+ export_dynamic_flag_spec_CXX='$wl-E'
+ whole_archive_flag_spec_CXX=$wlarc'--whole-archive$convenience '$wlarc'--no-whole-archive'
fi
-@@ -15630,7 +15630,7 @@ freebsd* | dragonfly*)
+@@ -16219,7 +16219,7 @@ freebsd* | dragonfly*)
version_type=freebsd-$objformat
case $version_type in
freebsd-elf*)
-- library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext} $libname${shared_ext}'
+- library_names_spec='$libname$release$shared_ext$versuffix $libname$release$shared_ext$major $libname$shared_ext'
+ library_names_spec='$libname$release$shared_ext$versuffix $libname$release$shared_ext$major $libname$shared_ext' soname_spec='$libname$release$shared_ext$major'
+ soname_spec='$libname$release$shared_ext$major'
need_version=no
need_lib_prefix=no
- ;;
-@@ -16768,9 +16768,9 @@ _ACEOF
+@@ -17406,9 +17406,9 @@ _ACEOF
CXX_CPU_SWITCH=
if ! echo "X $CXXFLAGS " | grep -q -- " \(-march=\|-mcpu=\|-mtune=\|-arch=\)" ; then
if test "$def_arch_x86" = 1 -a "$host_cpu" != "x86_64"; then
@@ -165,7 +165,7 @@
fi
fi
-@@ -17482,7 +17482,7 @@ fi
+@@ -18120,7 +18120,7 @@ fi
# parser yacc tables.
if echo "$YACC" | grep -q bison; then
# NOTE: m4 removes [], that's why it needs to be escaped
diff --git a/audio/linuxsampler/files/patch-src_common_Mutex.cpp b/audio/linuxsampler/files/patch-src_common_Mutex.cpp
index 9069f596356d..f0a362f49951 100644
--- a/audio/linuxsampler/files/patch-src_common_Mutex.cpp
+++ b/audio/linuxsampler/files/patch-src_common_Mutex.cpp
@@ -1,10 +1,10 @@
---- src/common/Mutex.cpp.orig 2007-11-14 23:42:15 UTC
+--- src/common/Mutex.cpp.orig 2019-05-07 05:18:11 UTC
+++ src/common/Mutex.cpp
-@@ -36,7 +36,6 @@
+@@ -40,7 +40,6 @@
#if !defined(WIN32)
- #if !defined(_XOPEN_SOURCE) || _XOPEN_SOURCE < 500
- # undef _XOPEN_SOURCE
--# define _XOPEN_SOURCE 500 /* to define PTHREAD_MUTEX_ERRORCHECK */
- # warning "Seems you don't have a UNIX98 compatible system."
- # warning "Please run LinuxSampler's selftest to make sure this won't be a problem!"
- # warning "(compile tests with 'make tests', run them with 'src/testcases/linuxsamplertest')"
+ # if !defined(_XOPEN_SOURCE) || _XOPEN_SOURCE < 500
+ # undef _XOPEN_SOURCE
+-# define _XOPEN_SOURCE 500 /* to define PTHREAD_MUTEX_RECURSIVE */
+ # if (!defined(POSIX_C_SOURCE) || POSIX_C_SOURCE < 199801L) && !__DARWIN_UNIX03
+ # warning "Seems you don't have a UNIX98 compatible system."
+ # warning "Please run LinuxSampler's selftest to make sure this won't be a problem!"
diff --git a/audio/linuxsampler/pkg-descr b/audio/linuxsampler/pkg-descr
index e92a5b7e1c98..43a5131e1d0b 100644
--- a/audio/linuxsampler/pkg-descr
+++ b/audio/linuxsampler/pkg-descr
@@ -4,4 +4,4 @@ with professional grade features, comparable to both hardware and
commercial Windows/Mac software samplers and to introduce new
features not yet available by any other sampler in the world.
-WWW: http://www.linuxsampler.org/
+WWW: https://www.linuxsampler.org/
diff --git a/audio/linuxsampler/pkg-plist b/audio/linuxsampler/pkg-plist
index 2f8710d60b4a..1604efca7582 100644
--- a/audio/linuxsampler/pkg-plist
+++ b/audio/linuxsampler/pkg-plist
@@ -32,12 +32,15 @@ include/linuxsampler/engines/FxSend.h
include/linuxsampler/engines/InstrumentManager.h
include/linuxsampler/plugins/InstrumentEditor.h
include/linuxsampler/plugins/InstrumentEditorFactory.h
+include/linuxsampler/scriptvm/ScriptVM.h
+include/linuxsampler/scriptvm/ScriptVMFactory.h
+include/linuxsampler/scriptvm/common.h
%%DSSI%%lib/dssi/linuxsampler.a
%%DSSI%%lib/dssi/linuxsampler.so
lib/linuxsampler/liblinuxsampler.a
lib/linuxsampler/liblinuxsampler.so
-lib/linuxsampler/liblinuxsampler.so.4
-lib/linuxsampler/liblinuxsampler.so.4.0.0
+lib/linuxsampler/liblinuxsampler.so.5
+lib/linuxsampler/liblinuxsampler.so.5.0.0
lib/linuxsampler/plugins/.keep_me
%%LV2%%lib/lv2/linuxsampler.lv2/linuxsampler.a
%%LV2%%lib/lv2/linuxsampler.lv2/linuxsampler.so