aboutsummaryrefslogtreecommitdiff
path: root/audio/liteamp
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2010-06-06 20:39:21 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2010-06-06 20:39:21 +0000
commitf613ac049d40272c3b27a76dbab7f6723f2a2ba2 (patch)
treee62b67c39f729f55f17b68f6438f9f1beeadd10c /audio/liteamp
parent2f2aafd9bf4a01f681da4598e18663001e4a9406 (diff)
downloadports-f613ac049d40272c3b27a76dbab7f6723f2a2ba2.tar.gz
ports-f613ac049d40272c3b27a76dbab7f6723f2a2ba2.zip
Notes
Diffstat (limited to 'audio/liteamp')
-rw-r--r--audio/liteamp/Makefile4
-rw-r--r--audio/liteamp/files/patch-src_playback.c10
2 files changed, 12 insertions, 2 deletions
diff --git a/audio/liteamp/Makefile b/audio/liteamp/Makefile
index 2b77b798eb31..7c49630d0128 100644
--- a/audio/liteamp/Makefile
+++ b/audio/liteamp/Makefile
@@ -6,14 +6,14 @@
PORTNAME= liteamp
PORTVERSION= 0.2.3.2
-PORTREVISION= 17
+PORTREVISION= 18
CATEGORIES= audio gnome
MASTER_SITES= http://kldp.net/frs/download.php/547/
MAINTAINER= ports@FreeBSD.org
COMMENT= Light-weight Music Player for GNOME2
-LIB_DEPENDS= ao.3:${PORTSDIR}/audio/libao \
+LIB_DEPENDS= ao.4:${PORTSDIR}/audio/libao \
mad.2:${PORTSDIR}/audio/mad \
vorbisfile.6:${PORTSDIR}/audio/libvorbis
diff --git a/audio/liteamp/files/patch-src_playback.c b/audio/liteamp/files/patch-src_playback.c
new file mode 100644
index 000000000000..17e83dfc69f8
--- /dev/null
+++ b/audio/liteamp/files/patch-src_playback.c
@@ -0,0 +1,10 @@
+--- src/playback.c.orig 2010-06-05 23:11:54.000000000 +0200
++++ src/playback.c 2010-06-05 23:12:22.000000000 +0200
+@@ -275,6 +275,7 @@ void playback_open_playdevice(int srate,
+ and restore it afterwards */
+ signal(SIGINT, SIG_DFL);
+
++ memset(&format, 0, sizeof(format));
+ format.bits = bitrate;
+ format.rate = srate;
+ format.channels = nch;