aboutsummaryrefslogtreecommitdiff
path: root/audio/lmms
diff options
context:
space:
mode:
authorRodrigo Osorio <rodrigo@FreeBSD.org>2014-04-22 14:37:50 +0000
committerRodrigo Osorio <rodrigo@FreeBSD.org>2014-04-22 14:37:50 +0000
commitb8edf55058f8b28f57a89fb9945ca324d2084290 (patch)
tree14c2b0c2f2cc69bfd026f39a944ba3152c1e51e3 /audio/lmms
parent5d7a9aceb6a93f723b9f8aa8dfce7b8d6dcc39a8 (diff)
downloadports-b8edf55058f8b28f57a89fb9945ca324d2084290.tar.gz
ports-b8edf55058f8b28f57a89fb9945ca324d2084290.zip
- support staging
Submitted by: rodrigo@freeBSD.org (maintainer) Approved by: bapt (mentor)
Notes
Notes: svn path=/head/; revision=351843
Diffstat (limited to 'audio/lmms')
-rw-r--r--audio/lmms/Makefile15
-rw-r--r--audio/lmms/files/patch-plugins_zynaddsubfx_src_Effects_Alienwah.cpp20
-rw-r--r--audio/lmms/pkg-plist428
3 files changed, 237 insertions, 226 deletions
diff --git a/audio/lmms/Makefile b/audio/lmms/Makefile
index 6b22d0e22a31..f35a3faa54d9 100644
--- a/audio/lmms/Makefile
+++ b/audio/lmms/Makefile
@@ -24,17 +24,14 @@ RUN_DEPENDS= ${LOCALBASE}/share/ladspa/rdf/caps.rdf:${PORTSDIR}/audio/caps-plugi
${LOCALBASE}/lib/ladspa/cmt.so:${PORTSDIR}/audio/cmt \
${LOCALBASE}/share/ladspa/rdf/swh-plugins.rdf:${PORTSDIR}/audio/swhplugins \
${LOCALBASE}/share/ladspa/rdf/tap-plugins.rdf:${PORTSDIR}/audio/tap-plugins \
- update-mime-database:${PORTSDIR}/misc/shared-mime-info
OPTIONS_DEFINE= JACK PULSEAUDIO SDL
USE_LDCONFIG= yes
-NO_STAGE= yes
-USE_BZIP2= yes
USE_XORG= xft
USE_QT4= corelib gui xml moc_build uic_build rcc_build \
qmake_build
-USES= cmake pkgconfig
+USES= cmake pkgconfig tar:bzip2 desktop-file-utils shared-mime-info
CMAKE_ARGS= -DWANT_ALSA:BOOL=OFF \
-DWANT_CALF:BOOL=OFF \
-DWANT_CAPS:BOOL=OFF \
@@ -45,11 +42,6 @@ CMAKE_ARGS= -DWANT_ALSA:BOOL=OFF \
-DWANT_VST:BOOL=OFF \
-DHAVE_STRTOLL=ON
-MANCOMPRESSED= yes
-MAN1= lmms.1
-
-USE_DOS2UNIX= plugins/midi_import/portsmf/allegrowr.cpp plugins/midi_import/portsmf/mfmidi.cpp
-
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MJACK}
@@ -90,10 +82,9 @@ post-patch:
post-install:
@${LN} -sf ${DATADIR}/themes/default/icon.png \
- ${PREFIX}/share/pixmaps/lmms.png
- @-update-mime-database ${PREFIX}/share/mime
+ ${STAGEDIR}${PREFIX}/share/pixmaps/lmms.png
# make it setuid-root to be able to set realtime priority
# (root privileges are dropped in the main routine)
- ${CHMOD} u+s ${PREFIX}/bin/lmms
+ ${CHMOD} u+s ${STAGEDIR}${PREFIX}/bin/lmms
.include <bsd.port.mk>
diff --git a/audio/lmms/files/patch-plugins_zynaddsubfx_src_Effects_Alienwah.cpp b/audio/lmms/files/patch-plugins_zynaddsubfx_src_Effects_Alienwah.cpp
new file mode 100644
index 000000000000..15c648bdab92
--- /dev/null
+++ b/audio/lmms/files/patch-plugins_zynaddsubfx_src_Effects_Alienwah.cpp
@@ -0,0 +1,20 @@
+--- plugins/zynaddsubfx/src/Effects/Alienwah.cpp.orig 2014-02-25 15:16:26.000000000 +0200
++++ plugins/zynaddsubfx/src/Effects/Alienwah.cpp 2014-02-25 15:17:00.000000000 +0200
+@@ -67,7 +67,7 @@
+ tmp = clfol * x + oldclfol * x1;
+
+ out = tmp * oldl[oldk];
+- out.real() += (1 - fabs(fb)) * smp.l[i] * (1.0 - panning);
++ out += (1 - fabs(fb)) * smp.l[i] * (1.0 - panning);
+
+ oldl[oldk] = out;
+ REALTYPE l = out.real() * 10.0 * (fb + 0.1);
+@@ -76,7 +76,7 @@
+ tmp = clfor * x + oldclfor * x1;
+
+ out = tmp * oldr[oldk];
+- out.real() += (1 - fabs(fb)) * smp.r[i] * (1.0 - panning);
++ out += (1 - fabs(fb)) * smp.r[i] * (1.0 - panning);
+
+ oldr[oldk] = out;
+ REALTYPE r = out.real() * 10.0 * (fb + 0.1);
diff --git a/audio/lmms/pkg-plist b/audio/lmms/pkg-plist
index 0343a08baef4..cf2789cff6fa 100644
--- a/audio/lmms/pkg-plist
+++ b/audio/lmms/pkg-plist
@@ -1,3 +1,213 @@
+%%QT_BINDIR%%/lmms
+include/lmms/AudioAlsa.h
+include/lmms/AudioDevice.h
+include/lmms/AudioDummy.h
+include/lmms/AudioFileDevice.h
+include/lmms/AudioFileOgg.h
+include/lmms/AudioFileWave.h
+include/lmms/AudioJack.h
+include/lmms/AudioOss.h
+include/lmms/AudioPort.h
+include/lmms/AudioPortAudio.h
+include/lmms/AudioPulseAudio.h
+include/lmms/AudioSampleRecorder.h
+include/lmms/AudioSdl.h
+include/lmms/AutomatableModel.h
+include/lmms/AutomatableModelView.h
+include/lmms/AutomationEditor.h
+include/lmms/AutomationPattern.h
+include/lmms/AutomationPatternView.h
+include/lmms/AutomationTrack.h
+include/lmms/Clipboard.h
+include/lmms/ComboBoxModel.h
+include/lmms/Controller.h
+include/lmms/ControllerConnection.h
+include/lmms/ControllerConnectionDialog.h
+include/lmms/ControllerDialog.h
+include/lmms/ControllerRackView.h
+include/lmms/ControllerView.h
+include/lmms/DetuningHelper.h
+include/lmms/DummyEffect.h
+include/lmms/DummyInstrument.h
+include/lmms/DummyPlugin.h
+include/lmms/Effect.h
+include/lmms/EffectChain.h
+include/lmms/EffectControlDialog.h
+include/lmms/EffectControls.h
+include/lmms/EffectRackView.h
+include/lmms/EffectSelectDialog.h
+include/lmms/EffectView.h
+include/lmms/EnvelopeAndLfoParameters.h
+include/lmms/EnvelopeAndLfoView.h
+include/lmms/FxMixer.h
+include/lmms/FxMixerView.h
+include/lmms/ImportFilter.h
+include/lmms/InlineAutomation.h
+include/lmms/Instrument.h
+include/lmms/InstrumentFunctionViews.h
+include/lmms/InstrumentFunctions.h
+include/lmms/InstrumentMidiIOView.h
+include/lmms/InstrumentPlayHandle.h
+include/lmms/InstrumentSoundShaping.h
+include/lmms/InstrumentSoundShapingView.h
+include/lmms/InstrumentTrack.h
+include/lmms/InstrumentView.h
+include/lmms/JournallingObject.h
+include/lmms/LadspaBase.h
+include/lmms/LadspaControl.h
+include/lmms/LadspaControlView.h
+include/lmms/LfoController.h
+include/lmms/MainWindow.h
+include/lmms/MeterDialog.h
+include/lmms/MeterModel.h
+include/lmms/MicroTimer.h
+include/lmms/MidiAlsaRaw.h
+include/lmms/MidiAlsaSeq.h
+include/lmms/MidiClient.h
+include/lmms/MidiController.h
+include/lmms/MidiDummy.h
+include/lmms/MidiEventProcessor.h
+include/lmms/MidiOss.h
+include/lmms/MidiPort.h
+include/lmms/MidiPortMenu.h
+include/lmms/MidiWinMM.h
+include/lmms/Model.h
+include/lmms/ModelView.h
+include/lmms/Oscillator.h
+include/lmms/PeakController.h
+include/lmms/Piano.h
+include/lmms/PianoView.h
+include/lmms/Plugin.h
+include/lmms/PluginView.h
+include/lmms/ProjectJournal.h
+include/lmms/ProjectRenderer.h
+include/lmms/RemotePlugin.h
+include/lmms/SerializingObject.h
+include/lmms/SideBar.h
+include/lmms/SideBarWidget.h
+include/lmms/SweepOscillator.h
+include/lmms/TempoSyncKnob.h
+include/lmms/TempoSyncKnobModel.h
+include/lmms/ToolPlugin.h
+include/lmms/ToolPluginView.h
+include/lmms/VST_sync_shm.h
+include/lmms/about_dialog.h
+include/lmms/aeffectx.h
+include/lmms/atomic_int.h
+include/lmms/automatable_button.h
+include/lmms/automatable_slider.h
+include/lmms/base64.h
+include/lmms/basic_filters.h
+include/lmms/bb_editor.h
+include/lmms/bb_track.h
+include/lmms/bb_track_container.h
+include/lmms/caption_menu.h
+include/lmms/combobox.h
+include/lmms/config_mgr.h
+include/lmms/cpuload_widget.h
+include/lmms/custom_events.h
+include/lmms/debug.h
+include/lmms/drumsynth.h
+include/lmms/effect_lib.h
+include/lmms/embed.cpp
+include/lmms/embed.h
+include/lmms/endian_handling.h
+include/lmms/engine.h
+include/lmms/export.h
+include/lmms/export_project_dialog.h
+include/lmms/fade_button.h
+include/lmms/fader.h
+include/lmms/fft_helpers.h
+include/lmms/fifo_buffer.h
+include/lmms/file_browser.h
+include/lmms/graph.h
+include/lmms/group_box.h
+include/lmms/gui_templates.h
+include/lmms/interpolation.h
+include/lmms/knob.h
+include/lmms/ladspa.h
+include/lmms/ladspa_2_lmms.h
+include/lmms/ladspa_manager.h
+include/lmms/lcd_spinbox.h
+include/lmms/led_checkbox.h
+include/lmms/lmms_basics.h
+include/lmms/lmms_constants.h
+include/lmms/lmms_math.h
+include/lmms/lmms_style.h
+include/lmms/lmmsconfig.h
+include/lmms/lmmsversion.h
+include/lmms/midi.h
+include/lmms/midi_time.h
+include/lmms/mixer.h
+include/lmms/mmp.h
+include/lmms/note.h
+include/lmms/note_play_handle.h
+include/lmms/nstate_button.h
+include/lmms/panning.h
+include/lmms/panning_constants.h
+include/lmms/pattern.h
+include/lmms/pch.h
+include/lmms/piano_roll.h
+include/lmms/pixmap_button.h
+include/lmms/play_handle.h
+include/lmms/plugin_browser.h
+include/lmms/preset_preview_play_handle.h
+include/lmms/project_notes.h
+include/lmms/project_version.h
+include/lmms/rename_dialog.h
+include/lmms/rubberband.h
+include/lmms/sample_buffer.h
+include/lmms/sample_play_handle.h
+include/lmms/sample_record_handle.h
+include/lmms/sample_track.h
+include/lmms/setup_dialog.h
+include/lmms/shared_object.h
+include/lmms/song.h
+include/lmms/song_editor.h
+include/lmms/string_pair_drag.h
+include/lmms/surround_area.h
+include/lmms/tab_bar.h
+include/lmms/tab_button.h
+include/lmms/tab_widget.h
+include/lmms/templates.h
+include/lmms/text_float.h
+include/lmms/timeline.h
+include/lmms/tool_button.h
+include/lmms/tooltip.h
+include/lmms/track.h
+include/lmms/track_container.h
+include/lmms/track_container_view.h
+include/lmms/track_label_button.h
+include/lmms/transformable_auto_model.h
+include/lmms/update_event.h
+include/lmms/visualization_widget.h
+include/lmms/volume.h
+lib64/lmms/RemoteZynAddSubFx
+lib64/lmms/libZynAddSubFxCore.so
+lib64/lmms/libaudiofileprocessor.so
+lib64/lmms/libbassbooster.so
+lib64/lmms/libbitinvader.so
+lib64/lmms/libflpimport.so
+lib64/lmms/libhydrogenimport.so
+lib64/lmms/libkicker.so
+lib64/lmms/libladspabrowser.so
+lib64/lmms/libladspaeffect.so
+lib64/lmms/liblb302.so
+lib64/lmms/libmidiimport.so
+lib64/lmms/liborganic.so
+lib64/lmms/libpapu.so
+lib64/lmms/libpatman.so
+lib64/lmms/libpeakcontrollereffect.so
+lib64/lmms/libsf2player.so
+lib64/lmms/libsid.so
+lib64/lmms/libspectrumanalyzer.so
+lib64/lmms/libstereoenhancer.so
+lib64/lmms/libstereomatrix.so
+lib64/lmms/libtripleoscillator.so
+lib64/lmms/libvibedstrings.so
+lib64/lmms/libzynaddsubfx.so
+man/man1/lmms.1.gz
+share/applications/lmms.desktop
%%DATADIR%%/backgrounds/lmms_tile.png
%%DATADIR%%/backgrounds/vinnie.png
%%DATADIR%%/locale/ca.qm
@@ -1767,222 +1977,11 @@
%%DATADIR%%/themes/default/zoom.png
%%DATADIR%%/themes/default/zoom_x.png
%%DATADIR%%/themes/default/zoom_y.png
-bin/lmms
-include/lmms/AudioAlsa.h
-include/lmms/AudioDevice.h
-include/lmms/AudioDummy.h
-include/lmms/AudioFileDevice.h
-include/lmms/AudioFileOgg.h
-include/lmms/AudioFileWave.h
-include/lmms/AudioJack.h
-include/lmms/AudioOss.h
-include/lmms/AudioPort.h
-include/lmms/AudioPortAudio.h
-include/lmms/AudioPulseAudio.h
-include/lmms/AudioSampleRecorder.h
-include/lmms/AudioSdl.h
-include/lmms/AutomatableModel.h
-include/lmms/AutomatableModelView.h
-include/lmms/AutomationEditor.h
-include/lmms/AutomationPattern.h
-include/lmms/AutomationPatternView.h
-include/lmms/AutomationTrack.h
-include/lmms/Clipboard.h
-include/lmms/ComboBoxModel.h
-include/lmms/Controller.h
-include/lmms/ControllerConnection.h
-include/lmms/ControllerConnectionDialog.h
-include/lmms/ControllerDialog.h
-include/lmms/ControllerRackView.h
-include/lmms/ControllerView.h
-include/lmms/DetuningHelper.h
-include/lmms/DummyEffect.h
-include/lmms/DummyInstrument.h
-include/lmms/DummyPlugin.h
-include/lmms/Effect.h
-include/lmms/EffectChain.h
-include/lmms/EffectControlDialog.h
-include/lmms/EffectControls.h
-include/lmms/EffectRackView.h
-include/lmms/EffectSelectDialog.h
-include/lmms/EffectView.h
-include/lmms/EnvelopeAndLfoParameters.h
-include/lmms/EnvelopeAndLfoView.h
-include/lmms/FxMixer.h
-include/lmms/FxMixerView.h
-include/lmms/ImportFilter.h
-include/lmms/InlineAutomation.h
-include/lmms/Instrument.h
-include/lmms/InstrumentFunctionViews.h
-include/lmms/InstrumentFunctions.h
-include/lmms/InstrumentMidiIOView.h
-include/lmms/InstrumentPlayHandle.h
-include/lmms/InstrumentSoundShaping.h
-include/lmms/InstrumentSoundShapingView.h
-include/lmms/InstrumentTrack.h
-include/lmms/InstrumentView.h
-include/lmms/JournallingObject.h
-include/lmms/LadspaBase.h
-include/lmms/LadspaControl.h
-include/lmms/LadspaControlView.h
-include/lmms/LfoController.h
-include/lmms/MainWindow.h
-include/lmms/MeterDialog.h
-include/lmms/MeterModel.h
-include/lmms/MicroTimer.h
-include/lmms/MidiAlsaRaw.h
-include/lmms/MidiAlsaSeq.h
-include/lmms/MidiClient.h
-include/lmms/MidiController.h
-include/lmms/MidiDummy.h
-include/lmms/MidiEventProcessor.h
-include/lmms/MidiOss.h
-include/lmms/MidiPort.h
-include/lmms/MidiPortMenu.h
-include/lmms/MidiWinMM.h
-include/lmms/Model.h
-include/lmms/ModelView.h
-include/lmms/Oscillator.h
-include/lmms/PeakController.h
-include/lmms/Piano.h
-include/lmms/PianoView.h
-include/lmms/Plugin.h
-include/lmms/PluginView.h
-include/lmms/ProjectJournal.h
-include/lmms/ProjectRenderer.h
-include/lmms/RemotePlugin.h
-include/lmms/SerializingObject.h
-include/lmms/SideBar.h
-include/lmms/SideBarWidget.h
-include/lmms/SweepOscillator.h
-include/lmms/TempoSyncKnob.h
-include/lmms/TempoSyncKnobModel.h
-include/lmms/ToolPlugin.h
-include/lmms/ToolPluginView.h
-include/lmms/VST_sync_shm.h
-include/lmms/about_dialog.h
-include/lmms/aeffectx.h
-include/lmms/atomic_int.h
-include/lmms/automatable_button.h
-include/lmms/automatable_slider.h
-include/lmms/base64.h
-include/lmms/basic_filters.h
-include/lmms/bb_editor.h
-include/lmms/bb_track.h
-include/lmms/bb_track_container.h
-include/lmms/caption_menu.h
-include/lmms/combobox.h
-include/lmms/config_mgr.h
-include/lmms/cpuload_widget.h
-include/lmms/custom_events.h
-include/lmms/debug.h
-include/lmms/drumsynth.h
-include/lmms/effect_lib.h
-include/lmms/embed.cpp
-include/lmms/embed.h
-include/lmms/endian_handling.h
-include/lmms/engine.h
-include/lmms/export.h
-include/lmms/export_project_dialog.h
-include/lmms/fade_button.h
-include/lmms/fader.h
-include/lmms/fft_helpers.h
-include/lmms/fifo_buffer.h
-include/lmms/file_browser.h
-include/lmms/graph.h
-include/lmms/group_box.h
-include/lmms/gui_templates.h
-include/lmms/interpolation.h
-include/lmms/knob.h
-include/lmms/ladspa.h
-include/lmms/ladspa_2_lmms.h
-include/lmms/ladspa_manager.h
-include/lmms/lcd_spinbox.h
-include/lmms/led_checkbox.h
-include/lmms/lmms_basics.h
-include/lmms/lmms_constants.h
-include/lmms/lmms_math.h
-include/lmms/lmms_style.h
-include/lmms/lmmsconfig.h
-include/lmms/lmmsversion.h
-include/lmms/midi.h
-include/lmms/midi_time.h
-include/lmms/mixer.h
-include/lmms/mmp.h
-include/lmms/note.h
-include/lmms/note_play_handle.h
-include/lmms/nstate_button.h
-include/lmms/panning.h
-include/lmms/panning_constants.h
-include/lmms/pattern.h
-include/lmms/pch.h
-include/lmms/piano_roll.h
-include/lmms/pixmap_button.h
-include/lmms/play_handle.h
-include/lmms/plugin_browser.h
-include/lmms/preset_preview_play_handle.h
-include/lmms/project_notes.h
-include/lmms/project_version.h
-include/lmms/rename_dialog.h
-include/lmms/rubberband.h
-include/lmms/sample_buffer.h
-include/lmms/sample_play_handle.h
-include/lmms/sample_record_handle.h
-include/lmms/sample_track.h
-include/lmms/setup_dialog.h
-include/lmms/shared_object.h
-include/lmms/song.h
-include/lmms/song_editor.h
-include/lmms/string_pair_drag.h
-include/lmms/surround_area.h
-include/lmms/tab_bar.h
-include/lmms/tab_button.h
-include/lmms/tab_widget.h
-include/lmms/templates.h
-include/lmms/text_float.h
-include/lmms/timeline.h
-include/lmms/tool_button.h
-include/lmms/tooltip.h
-include/lmms/track.h
-include/lmms/track_container.h
-include/lmms/track_container_view.h
-include/lmms/track_label_button.h
-include/lmms/transformable_auto_model.h
-include/lmms/update_event.h
-include/lmms/visualization_widget.h
-include/lmms/volume.h
-lib/lmms/RemoteZynAddSubFx
-lib/lmms/libZynAddSubFxCore.so
-lib/lmms/libaudiofileprocessor.so
-lib/lmms/libbassbooster.so
-lib/lmms/libbitinvader.so
-lib/lmms/libflpimport.so
-lib/lmms/libhydrogenimport.so
-lib/lmms/libkicker.so
-lib/lmms/libladspabrowser.so
-lib/lmms/libladspaeffect.so
-lib/lmms/liblb302.so
-lib/lmms/libmidiimport.so
-lib/lmms/liborganic.so
-lib/lmms/libpapu.so
-lib/lmms/libpatman.so
-lib/lmms/libpeakcontrollereffect.so
-lib/lmms/libsf2player.so
-lib/lmms/libsid.so
-lib/lmms/libspectrumanalyzer.so
-lib/lmms/libstereoenhancer.so
-lib/lmms/libstereomatrix.so
-lib/lmms/libtripleoscillator.so
-lib/lmms/libvibedstrings.so
-lib/lmms/libzynaddsubfx.so
-share/applications/lmms.desktop
share/menu/lmms
-share/mime/application/x-lmms-project.xml
share/mime/packages/lmms.xml
share/pixmaps/lmms.png
+@dirrmtry share/mime/packages
@dirrmtry share/menu
-@dirrm lib/lmms/
-@dirrm include/lmms/
@dirrm %%DATADIR%%/themes/default
@dirrm %%DATADIR%%/themes
@dirrm %%DATADIR%%/samples/stringsnpads
@@ -2061,5 +2060,6 @@ share/pixmaps/lmms.png
@dirrm %%DATADIR%%/locale
@dirrm %%DATADIR%%/backgrounds
@dirrm %%DATADIR%%
-@exec %%LOCALBASE%%/bin/update-mime-database %D/share/mime
-@unexec %%LOCALBASE%%/bin/update-mime-database %D/share/mime
+@dirrm include/lmms
+@dirrm lib64/lmms
+@dirrmtry lib64