aboutsummaryrefslogtreecommitdiff
path: root/audio/logitechmediaserver-sqlplaylist
diff options
context:
space:
mode:
authorBen Woods <woodsb02@FreeBSD.org>2016-10-05 22:50:25 +0000
committerBen Woods <woodsb02@FreeBSD.org>2016-10-05 22:50:25 +0000
commit9ecc2f4ce05cc7a62a4a39a0a601ea726c71c5f4 (patch)
treeda3277c834f8a29abe39b1e949a67897a24c1598 /audio/logitechmediaserver-sqlplaylist
parent32a27683541c18d3e2aee45c17086c43f520b42b (diff)
downloadports-9ecc2f4ce05cc7a62a4a39a0a601ea726c71c5f4.tar.gz
ports-9ecc2f4ce05cc7a62a4a39a0a601ea726c71c5f4.zip
Move audio/squeezeboxserver to audio/logitechmediaserver
audio/squeezeboxserver: - Move to audio/logitechmediaserver - Update to 7.9.0 pre-release (git commit from 7.9 branch on 2016.09.30) - Change default install and database locations to suit new PORTNAME - Remove softsqueeze.sh as it is no longer bundled with the server - Add /usr/local/etc/newsyslog.conf.d/, don't edit /etc/newsyslog.conf - Add LICENSE details - Update maintainer (previous maintainer timeout) - Use customized perl modules provided in distfile and slimserver-vendor GitHub repo, rather than using perl dependencies from ports - Changed install method to now copy directly to stagedir instead of an intermediate step to TMP_SLIMDIR audio/squeezeboxserver-dynamicplaylist: - Move to audio/logitechmediaserver-dynamicplaylist - Update to 2.9.3853 - Fix MASTER_SITES - Add LICENSE details - Update maintainer audio/squeezeboxserver-lazysearch: - Move to audio/logitechmediaserver-lazysearch - Add LICENSE details - Update maintainer audio/squeezeboxserver-sqlplaylist: - Move to audio/logitechmediaserver-sqlplaylist - Update to 2.5.3859 - Fix MASTER_SITES - Add LICENSE details - Update maintainer audio/squeezeboxserver-superdatetime: - Move to audio/logitechmediaserver-superdatetime - Add LICENSE details - Update maintainer audio/squeezeboxserver-trackstat: - Move to audio/logitechmediaserver-trackstat - Update to 3.2.3951 - Fix MASTER_SITES - Add LICENSE details - Update maintainer PR: 180034 PR: 203266 Submitted by: woodsb02, mark@tranquillussoftware.co.uk (new maintainer) Reported by: david@dawninglight.net, amdmi3 Approved by: markk@knigma.org (maintainer timeout), tdb (maintainer), adamw (mentor) Differential Revision: https://reviews.freebsd.org/D6483
Notes
Notes: svn path=/head/; revision=423393
Diffstat (limited to 'audio/logitechmediaserver-sqlplaylist')
-rw-r--r--audio/logitechmediaserver-sqlplaylist/Makefile34
-rw-r--r--audio/logitechmediaserver-sqlplaylist/distinfo3
-rw-r--r--audio/logitechmediaserver-sqlplaylist/pkg-descr20
-rw-r--r--audio/logitechmediaserver-sqlplaylist/pkg-plist106
4 files changed, 163 insertions, 0 deletions
diff --git a/audio/logitechmediaserver-sqlplaylist/Makefile b/audio/logitechmediaserver-sqlplaylist/Makefile
new file mode 100644
index 000000000000..c771f6bba3f3
--- /dev/null
+++ b/audio/logitechmediaserver-sqlplaylist/Makefile
@@ -0,0 +1,34 @@
+# Created by: Tim Bishop <tdb@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= sqlplaylist
+PORTVERSION= 2.5.3859
+CATEGORIES= audio
+MASTER_SITES= http://downloads.isaksson.info/download/do/downloadapplication?name=slimserver-sqlplaylist&filename=/
+PKGNAMEPREFIX= logitechmediaserver-
+DISTNAME= SQLPlayList-${PORTVERSION:S/b/beta/}
+DIST_SUBDIR= logitechmediaserver
+
+MAINTAINER= mark@tranquillussoftware.co.uk
+COMMENT= Logitech Media Server plugin to create playlists based on SQL queries
+
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/SQLPlayList/LICENSE.txt
+
+RUN_DEPENDS= ${LOCALBASE}/${SLIMDIR}/slimserver.pl:audio/logitechmediaserver \
+ ${LOCALBASE}/${SLIMDIR}/Plugins/DynamicPlayList/install.xml:audio/logitechmediaserver-dynamicplaylist
+
+FETCH_BEFORE_ARGS= -o ${DISTFILES}
+USES= zip
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+NO_ARCH= yes
+
+SLIMDIR?= share/logitechmediaserver
+PLIST_SUB+= SLIMDIR=${SLIMDIR}
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/${SLIMDIR}/Plugins/SQLPlayList
+ ${CP} -R ${WRKSRC}/SQLPlayList/* ${STAGEDIR}${PREFIX}/${SLIMDIR}/Plugins/SQLPlayList
+
+.include <bsd.port.mk>
diff --git a/audio/logitechmediaserver-sqlplaylist/distinfo b/audio/logitechmediaserver-sqlplaylist/distinfo
new file mode 100644
index 000000000000..3f4abc0a4e4e
--- /dev/null
+++ b/audio/logitechmediaserver-sqlplaylist/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1463782116
+SHA256 (logitechmediaserver/SQLPlayList-2.5.3859.zip) = b0363cbd0433ebae58e6357cee26ce40548f7b8b87ae4a7dae9bbff4a4bfdd53
+SIZE (logitechmediaserver/SQLPlayList-2.5.3859.zip) = 188051
diff --git a/audio/logitechmediaserver-sqlplaylist/pkg-descr b/audio/logitechmediaserver-sqlplaylist/pkg-descr
new file mode 100644
index 000000000000..8625f3dfb638
--- /dev/null
+++ b/audio/logitechmediaserver-sqlplaylist/pkg-descr
@@ -0,0 +1,20 @@
+This plugin for Logitech Media Server makes it possible to create smart
+playlists. Although the standard Logitech Media Server doesn't support
+smart playlists by itself, together with iTunes and the standard
+Logitech Media Server iTunes integration, it is possible to use smart
+playlists defined in iTunes. The problem though is that the integrated
+iTunes smart playlists will not be recalculated until the next time
+you perform a rescan in Logitech Media Server. The SQL Playlist plugin
+takes care of this problem and implements native smart playlist in
+Logitech Media Server without any need to use iTunes. The smart playlists
+implemented in SQL Playlist will also be automatically re-calculated
+after each track played so they will be based on the latest statistic
+information.
+
+A smart playlist in SQL Playlist are continous and will run forever in
+the same way as the standard Random Mix plugin, you can optionally
+also choose that a smart playlist shouldn't repeat already played
+tracks and in that case the music will stop when all songs matching
+the playlist has been played.
+
+WWW: http://wiki.slimdevices.com/index.php/SQL_Playlist_plugin
diff --git a/audio/logitechmediaserver-sqlplaylist/pkg-plist b/audio/logitechmediaserver-sqlplaylist/pkg-plist
new file mode 100644
index 000000000000..c0c3a6215010
--- /dev/null
+++ b/audio/logitechmediaserver-sqlplaylist/pkg-plist
@@ -0,0 +1,106 @@
+%%SLIMDIR%%/Plugins/SQLPlayList/BaseSettings.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/ConfigManager/BaseParser.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/ConfigManager/ContentParser.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/ConfigManager/DirectoryLoader.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/ConfigManager/Main.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/ConfigManager/ParameterHandler.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/ConfigManager/PlaylistWebAdminMethods.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/ConfigManager/PluginLoader.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/ConfigManager/TemplateContentParser.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/ConfigManager/TemplateParser.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/ConfigManager/WebAdminMethods.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/HTML/Classic/html/images/sqlplaylist_mix.gif
+%%SLIMDIR%%/Plugins/SQLPlayList/HTML/Default/html/images/sqlplaylist_mix.gif
+%%SLIMDIR%%/Plugins/SQLPlayList/HTML/Default/plugins/SQLPlayList/dynamicplaylistlink.html
+%%SLIMDIR%%/Plugins/SQLPlayList/HTML/EN/plugins/SQLPlayList/catchtab.js
+%%SLIMDIR%%/Plugins/SQLPlayList/HTML/EN/plugins/SQLPlayList/dynamicplaylistlink.html
+%%SLIMDIR%%/Plugins/SQLPlayList/HTML/EN/plugins/SQLPlayList/mixerlink.html
+%%SLIMDIR%%/Plugins/SQLPlayList/HTML/EN/plugins/SQLPlayList/settings/basic.html
+%%SLIMDIR%%/Plugins/SQLPlayList/HTML/EN/plugins/SQLPlayList/settings/subpage_chooser.html
+%%SLIMDIR%%/Plugins/SQLPlayList/HTML/EN/plugins/SQLPlayList/sqlplaylist_list.html
+%%SLIMDIR%%/Plugins/SQLPlayList/HTML/EN/plugins/SQLPlayList/sqlplaylist_redirect.html
+%%SLIMDIR%%/Plugins/SQLPlayList/HTML/EN/plugins/SQLPlayList/sqlplaylist_reload.html
+%%SLIMDIR%%/Plugins/SQLPlayList/HTML/EN/plugins/SQLPlayList/webadminmethods_edititem.html
+%%SLIMDIR%%/Plugins/SQLPlayList/HTML/EN/plugins/SQLPlayList/webadminmethods_editsimpleitem.html
+%%SLIMDIR%%/Plugins/SQLPlayList/HTML/EN/plugins/SQLPlayList/webadminmethods_login.html
+%%SLIMDIR%%/Plugins/SQLPlayList/HTML/EN/plugins/SQLPlayList/webadminmethods_newitem.html
+%%SLIMDIR%%/Plugins/SQLPlayList/HTML/EN/plugins/SQLPlayList/webadminmethods_newitemparameters.html
+%%SLIMDIR%%/Plugins/SQLPlayList/HTML/EN/plugins/SQLPlayList/webadminmethods_newitemtypes.html
+%%SLIMDIR%%/Plugins/SQLPlayList/HTML/EN/plugins/SQLPlayList/webadminmethods_newsimpleitem.html
+%%SLIMDIR%%/Plugins/SQLPlayList/HTML/EN/plugins/SQLPlayList/webadminmethods_publishitemparameters.html
+%%SLIMDIR%%/Plugins/SQLPlayList/HTML/EN/plugins/SQLPlayList/webadminmethods_register.html
+%%SLIMDIR%%/Plugins/SQLPlayList/HTML/EN/plugins/SQLPlayList/webadminmethods_savedownloadeditem.html
+%%SLIMDIR%%/Plugins/SQLPlayList/HTML/Fishbone/html/images/sqlplaylist_mix.gif
+%%SLIMDIR%%/Plugins/SQLPlayList/LICENSE.txt
+%%SLIMDIR%%/Plugins/SQLPlayList/MixHandler.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/Mixes/sqlplaylist.cb.mix.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Playlists/randomalbums.sql.values.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Playlists/randomalbumsforartist.sql.values.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Playlists/randomalbumsfordecade.sql.values.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Playlists/randomalbumsforgenre.sql.values.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Playlists/randomalbumsforplaylist.sql.values.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Playlists/randomalbumsforyear.sql.values.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Playlists/randomartists.sql.values.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Playlists/randomforalbum.sql.values.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Playlists/randomforartist.sql.values.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Playlists/randomfordecade.sql.values.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Playlists/randomforgenre.sql.values.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Playlists/randomforplaylist.sql.values.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Playlists/randomforyear.sql.values.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Playlists/randomtracks.sql.values.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Playlists/randomyears.sql.values.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Plugin.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/README.txt
+%%SLIMDIR%%/Plugins/SQLPlayList/Settings.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/Template/Reader.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/advanced.sql.template
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/advanced.sql.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/advancedwithrating.sql.template
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/advancedwithrating.sql.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/randomalbums.sql.template
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/randomalbums.sql.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/randomartists.sql.template
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/randomartists.sql.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/randomforrating.sql.template
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/randomforrating.sql.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/randomforratingandartist.sql.template
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/randomforratingandartist.sql.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/randomforratingandgenre.sql.template
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/randomforratingandgenre.sql.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/randomforratingandyear.sql.template
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/randomforratingandyear.sql.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/randomfrommixer.sql.template
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/randomfrommixer.sql.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/randomplaylisttracks.sql.template
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/randomplaylisttracks.sql.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/randomtracks.sql.template
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/randomtracks.sql.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/randomweightedtracks.sql.template
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/randomweightedtracks.sql.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/randomyears.sql.template
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/randomyears.sql.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/simple.sql.template
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/simple.sql.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/topratedforalbum.sql.template
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/topratedforalbum.sql.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/topratedforartist.sql.template
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/topratedforartist.sql.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/topratedfordecade.sql.template
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/topratedfordecade.sql.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/topratedforgenre.sql.template
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/topratedforgenre.sql.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/topratedforplaylist.sql.template
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/topratedforplaylist.sql.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/topratedforyear.sql.template
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/topratedforyear.sql.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/install.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/lib/SOAP/Constants.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/lib/SOAP/Lite.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/lib/SOAP/Lite/Deserializer/XMLSchema1999.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/lib/SOAP/Lite/Deserializer/XMLSchema2001.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/lib/SOAP/Lite/Deserializer/XMLSchemaSOAP1_1.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/lib/SOAP/Lite/Deserializer/XMLSchemaSOAP1_2.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/lib/SOAP/Lite/Utils.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/lib/SOAP/Packager.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/lib/SOAP/Transport/HTTP.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/strings.txt