aboutsummaryrefslogtreecommitdiff
path: root/audio/lollypop/Makefile
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2021-03-01 12:55:35 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2021-03-01 12:55:35 +0000
commit6d1b70c3d92867f863bfa9924853015d2a9e6cc3 (patch)
tree80ef737ce6d29619a41fb2e58c1c0bbc8f262aa3 /audio/lollypop/Makefile
parentb391b0ea3a6c86c33237d80a5300b3264a4d1173 (diff)
downloadports-6d1b70c3d92867f863bfa9924853015d2a9e6cc3.tar.gz
ports-6d1b70c3d92867f863bfa9924853015d2a9e6cc3.zip
Notes
Diffstat (limited to 'audio/lollypop/Makefile')
-rw-r--r--audio/lollypop/Makefile21
1 files changed, 12 insertions, 9 deletions
diff --git a/audio/lollypop/Makefile b/audio/lollypop/Makefile
index b9b69cb74969..ece2002318ff 100644
--- a/audio/lollypop/Makefile
+++ b/audio/lollypop/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= lollypop
-DISTVERSION= 1.0.12
+DISTVERSION= 1.4.16
CATEGORIES= audio
MAINTAINER= greg@unrelenting.technology
@@ -13,33 +13,36 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${RUN_DEPENDS} \
itstool:textproc/itstool
+LIB_DEPENDS= libnotify.so:devel/libnotify \
+ libhandy-1.so:x11-toolkits/libhandy \
+ libappstream-glib.so:devel/appstream-glib \
+ libtotem-plparser.so:multimedia/totem-pl-parser
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>=2.7.8:databases/py-sqlite3@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}cairo>=1.0.0:graphics/py-cairo@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}beautifulsoup>=4.0.0:www/py-beautifulsoup@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}dbus>=1.1.1:devel/py-dbus@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}gstreamer1>=1.4.0:multimedia/py-gstreamer1@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pylast>=1.4.0:audio/py-pylast@${PY_FLAVOR} \
${PY_PILLOW}
-LIB_DEPENDS= libnotify.so:devel/libnotify \
- libappstream-glib.so:devel/appstream-glib \
- libtotem-plparser.so:multimedia/totem-pl-parser
USES= python:3.6+ pkgconfig gnome gettext meson shebangfix sqlite desktop-file-utils
USE_GITLAB= yes
GL_SITE= https://gitlab.gnome.org
GL_ACCOUNT= World
-GL_COMMIT= fdcb83e6a3dbd7afa9c479490d124d6603dbc7df
-GL_TUPLE= gnumdk:lollypop-po:7dd29b33dbd6f976f4d376a32851fe8abbda2949:po/subprojects/po
+GL_COMMIT= 5b2d95f4f8509d80fa86ab7d65b118326dc82a95
+GL_TUPLE= gnumdk:lollypop-po:94a7300004ec15adfd596c7d2b8670bbf5c2e33a:po/subprojects/po
USE_GNOME= glib20 gtk30 pygobject3 introspection:build intltool intlhack
USE_GSTREAMER1= yes mpg123 ogg flac opus libav faad good speex
USE_PYTHON= py3kplist
INSTALLS_ICONS= yes
-SHEBANG_FILES= lollypop/*.py meson_post_install.py
+SHEBANG_FILES= lollypop.in search-provider/lollypop-sp.in meson_post_install.py
GLIB_SCHEMAS= org.gnome.Lollypop.gschema.xml
+BINARY_ALIAS= python3=${PYTHON_VERSION}
+
OPTIONS_DEFINE= PULSEAUDIO
PULSEAUDIO_USE= gstreamer1=pulse
-SUB_FILES= pkg-message
-
.include <bsd.port.mk>