aboutsummaryrefslogtreecommitdiff
path: root/audio/lollypop/Makefile
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2015-04-18 20:28:20 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2015-04-18 20:28:20 +0000
commit863bb399c13abeb7ab6189fcabc9e8c9b6929160 (patch)
treeb62ed51c949f6c370bd2cb7112418b09abbc18bb /audio/lollypop/Makefile
parent909a2680c86624c328f56aa646d96d42dbf33876 (diff)
Notes
Diffstat (limited to 'audio/lollypop/Makefile')
-rw-r--r--audio/lollypop/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/audio/lollypop/Makefile b/audio/lollypop/Makefile
index 98847d8df4f9..b4d8ca686369 100644
--- a/audio/lollypop/Makefile
+++ b/audio/lollypop/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= lollypop
-PORTVERSION= 0.9.5
+PORTVERSION= 0.9.11
CATEGORIES= audio
MASTER_SITES= https://github.com/gnumdk/%SUBDIR%/
MASTER_SITE_SUBDIR= ${PORTNAME}/releases/download/${PORTVERSION}
@@ -13,17 +13,16 @@ COMMENT= Play and organize your music collection
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mutagen>=1.26:${PORTSDIR}/audio/py-mutagen \
- ${PYTHON_PKGNAMEPREFIX}sqlite3>=2.7.8:${PORTSDIR}/databases/py-sqlite3 \
- ${PYTHON_PKGNAMEPREFIX}dbus>=1.1.1:${PORTSDIR}/devel/py3-dbus
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>=2.7.8:${PORTSDIR}/databases/py-sqlite3 \
+ ${PYTHON_PKGNAMEPREFIX}dbus>=1.1.1:${PORTSDIR}/devel/py3-dbus \
+ ${PYTHON_PKGNAMEPREFIX}gstreamer1>=1.4.0:${PORTSDIR}/multimedia/py3-gstreamer1
LIB_DEPENDS= libnotify.so:${PORTSDIR}/devel/libnotify
-RUN_DEPENDS= gnome-icon-theme>=3.6.2:${PORTSDIR}/x11-themes/gnome-icon-theme-symbolic
USES= shebangfix python:3 pkgconfig gettext gmake tar:xz
GNU_CONFIGURE= yes
USE_GNOME= glib20 gtk30 py3gobject3 introspection:build intltool intlhack
USE_SQLITE= yes
-USE_GSTREAMER1= yes mad ogg flac opus libav
+USE_GSTREAMER1= yes mad ogg flac opus libav faad good speex
USE_PYTHON= py3kplist
INSTALLS_ICONS= yes