aboutsummaryrefslogtreecommitdiff
path: root/audio/lua-mpd
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2020-04-14 15:49:36 +0000
committerMathieu Arnold <mat@FreeBSD.org>2020-04-14 15:49:36 +0000
commitbeb1c1fe19992999ef068d0dcb07c0d02f4aea71 (patch)
tree464f76d8fe2b9fd7499e26491ee739bfe0a5444e /audio/lua-mpd
parent496124accdd4d4221bb883770cd6fe27184bfc96 (diff)
downloadports-beb1c1fe19992999ef068d0dcb07c0d02f4aea71.tar.gz
ports-beb1c1fe19992999ef068d0dcb07c0d02f4aea71.zip
USES=lua gained flavors.
Ports using USES=lua:module or lua:flavors will be flavored. A range of supported lua versions can be set using XX-YY (or XX-, or -YY, or simply ZZ) for ports not supporting all lua versions. USES=lua sets LUA_FLAVOR that needs to be used on all dependencies of flavored lua ports, in a similar way as PHP or Python flavors. PR: 245038 Submitted by: andrew tao11 riddles org uk Reviewed by: mat, kevans, russ haley gmail com Approved by: mat (portmgr) Differential Revision: https://reviews.freebsd.org/D16494
Notes
Notes: svn path=/head/; revision=531700
Diffstat (limited to 'audio/lua-mpd')
-rw-r--r--audio/lua-mpd/Makefile34
-rw-r--r--audio/lua-mpd/distinfo2
-rw-r--r--audio/lua-mpd/pkg-descr3
-rw-r--r--audio/lua-mpd/pkg-plist5
4 files changed, 44 insertions, 0 deletions
diff --git a/audio/lua-mpd/Makefile b/audio/lua-mpd/Makefile
new file mode 100644
index 000000000000..a0d3a029bc4b
--- /dev/null
+++ b/audio/lua-mpd/Makefile
@@ -0,0 +1,34 @@
+# $FreeBSD$
+
+PORTNAME= mpd
+PORTVERSION= 0.1
+PORTREVISION= 1
+DISTVERSIONPREFIX= v
+CATEGORIES= audio
+PKGNAMEPREFIX= ${LUA_PKGNAMEPREFIX}
+
+MAINTAINER= demelier.david@gmail.com
+COMMENT= Lua library for musicpd
+
+RUN_DEPENDS= ${LUA_REFMODLIBDIR}/socket/core.so:net/luasocket@${LUA_FLAVOR}
+
+OPTIONS_DEFINE= DOCS
+DOCSDIR= ${LUA_DOCSDIR}
+
+GH_ACCOUNT= silentbicycle
+GH_PROJECT= lua-mpd
+
+USES= lua:51,module
+USE_GITHUB= yes
+NO_BUILD= yes
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${LUA_MODSHAREDIR}
+ ${INSTALL_DATA} ${WRKSRC}/mpd.lua ${STAGEDIR}${LUA_MODSHAREDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR} ${STAGEDIR}${DOCSDIR}/modules ${STAGEDIR}${DOCSDIR}/files
+ ${INSTALL_DATA} ${WRKSRC}/index.html ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/luadoc.css ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/files/mpd.html ${STAGEDIR}${DOCSDIR}/files
+ ${INSTALL_DATA} ${WRKSRC}/modules/mpd.html ${STAGEDIR}${DOCSDIR}/modules
+
+.include <bsd.port.mk>
diff --git a/audio/lua-mpd/distinfo b/audio/lua-mpd/distinfo
new file mode 100644
index 000000000000..8333aa8c6899
--- /dev/null
+++ b/audio/lua-mpd/distinfo
@@ -0,0 +1,2 @@
+SHA256 (silentbicycle-lua-mpd-v0.1_GH0.tar.gz) = 296f168887e10646624cce98c2f7504b168cb35b5445e2d21ba5fccb50a8f68b
+SIZE (silentbicycle-lua-mpd-v0.1_GH0.tar.gz) = 16351
diff --git a/audio/lua-mpd/pkg-descr b/audio/lua-mpd/pkg-descr
new file mode 100644
index 000000000000..f0a6a49c5cdc
--- /dev/null
+++ b/audio/lua-mpd/pkg-descr
@@ -0,0 +1,3 @@
+This is a Lua client for mpd.
+
+WWW: https://github.com/silentbicycle/lua-mpd
diff --git a/audio/lua-mpd/pkg-plist b/audio/lua-mpd/pkg-plist
new file mode 100644
index 000000000000..984c9c92b2ed
--- /dev/null
+++ b/audio/lua-mpd/pkg-plist
@@ -0,0 +1,5 @@
+%%LUA_MODSHAREDIR%%/mpd.lua
+%%PORTDOCS%%%%DOCSDIR%%/files/mpd.html
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/luadoc.css
+%%PORTDOCS%%%%DOCSDIR%%/modules/mpd.html