aboutsummaryrefslogtreecommitdiff
path: root/audio/lv2lint
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-05-04 20:03:30 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-05-04 20:03:30 +0000
commitd4daf8b790f25863764afaec5f78fa2be9dc7d78 (patch)
treef416ce0cfab12d4d2b473ac00670165262d9fa3d /audio/lv2lint
parentf17a49746f8a282bbf349d8163f5723e6a7b8c65 (diff)
downloadports-d4daf8b790f25863764afaec5f78fa2be9dc7d78.tar.gz
ports-d4daf8b790f25863764afaec5f78fa2be9dc7d78.zip
New port: audio/lv2lint: Check whether a given LV2 plugin is up to the specification
Notes
Notes: svn path=/head/; revision=500824
Diffstat (limited to 'audio/lv2lint')
-rw-r--r--audio/lv2lint/Makefile28
-rw-r--r--audio/lv2lint/distinfo3
-rw-r--r--audio/lv2lint/files/patch-lv2lint.h11
-rw-r--r--audio/lv2lint/pkg-descr8
4 files changed, 50 insertions, 0 deletions
diff --git a/audio/lv2lint/Makefile b/audio/lv2lint/Makefile
new file mode 100644
index 000000000000..10218da79a65
--- /dev/null
+++ b/audio/lv2lint/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= lv2lint
+DISTVERSION= g20190403
+CATEGORIES= audio
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Check whether a given LV2 plugin is up to the specification
+
+LICENSE= ART20
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= lv2>0:audio/lv2 \
+ curl>0:ftp/curl \
+ libelf>0:devel/libelf
+LIB_DEPENDS= liblilv-0.so:audio/lilv
+RUN_DEPENDS= curl>0:ftp/curl \
+ libelf>0:devel/libelf
+
+USES= meson pkgconfig
+USE_GITHUB= yes
+GH_ACCOUNT= OpenMusicKontrollers
+GH_TAGNAME= 3c24394
+
+PLIST_FILES= bin/lv2lint \
+ man/man1/lv2lint.1.gz
+
+.include <bsd.port.mk>
diff --git a/audio/lv2lint/distinfo b/audio/lv2lint/distinfo
new file mode 100644
index 000000000000..187429f290ea
--- /dev/null
+++ b/audio/lv2lint/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1556999377
+SHA256 (OpenMusicKontrollers-lv2lint-g20190403-3c24394_GH0.tar.gz) = 8f4b6b766a0d171205f7482288b6ec57ede420792330facdc61e3d2defc5d756
+SIZE (OpenMusicKontrollers-lv2lint-g20190403-3c24394_GH0.tar.gz) = 33858
diff --git a/audio/lv2lint/files/patch-lv2lint.h b/audio/lv2lint/files/patch-lv2lint.h
new file mode 100644
index 000000000000..774905a10638
--- /dev/null
+++ b/audio/lv2lint/files/patch-lv2lint.h
@@ -0,0 +1,11 @@
+--- lv2lint.h.orig 2019-05-04 19:51:19 UTC
++++ lv2lint.h
+@@ -38,7 +38,7 @@
+ # include <curl/curl.h>
+ #endif
+
+-#define __unused __attribute__((unused))
++//#define __unused __attribute__((unused))
+
+ typedef enum _ansi_color_t {
+ ANSI_COLOR_BOLD,
diff --git a/audio/lv2lint/pkg-descr b/audio/lv2lint/pkg-descr
new file mode 100644
index 000000000000..7aa093324f68
--- /dev/null
+++ b/audio/lv2lint/pkg-descr
@@ -0,0 +1,8 @@
+lv2lint can optionally test your plugin URIs for existence. If you want that,
+you need to enable it at compile time (-Donline-tests=true) and link to libcurl.
+
+lv2lint can optionally test your plugin symbol visibility and link dependencies.
+If you want that, you need to enable it at compile time (-Delf-tests=true) and
+link to libelf.
+
+WWW: https://github.com/OpenMusicKontrollers/lv2lint