aboutsummaryrefslogtreecommitdiff
path: root/audio/lvtk
diff options
context:
space:
mode:
authorRichard Gallamore <ultima@FreeBSD.org>2017-08-13 22:34:00 +0000
committerRichard Gallamore <ultima@FreeBSD.org>2017-08-13 22:34:00 +0000
commita1453be727eb6e9cff615021bf325635dcd6cd64 (patch)
tree5e72b90fa268ffc23b07837b7f5c256d880ca4c8 /audio/lvtk
parent368f3a8d4276aa061e2b91f5ea3a91a37cac9002 (diff)
downloadports-a1453be727eb6e9cff615021bf325635dcd6cd64.tar.gz
ports-a1453be727eb6e9cff615021bf325635dcd6cd64.zip
This toolkit contains libraries that wrap the LV2 C API and extensions into
easy to use C++ classes. The original work for this was mostly done by Lars Luthman in lv2-c++-tools. WWW: https://github.com/lvtk/lvtk PR: 221272 Submitted by: Yuri Victorovich (maintainer) Reviewed by: matthew (mentor) Approved by: matthew (mentor) Differential Revision: https://reviews.freebsd.org/D12013
Notes
Notes: svn path=/head/; revision=447921
Diffstat (limited to 'audio/lvtk')
-rw-r--r--audio/lvtk/Makefile21
-rw-r--r--audio/lvtk/distinfo3
-rw-r--r--audio/lvtk/pkg-descr5
-rw-r--r--audio/lvtk/pkg-plist38
4 files changed, 67 insertions, 0 deletions
diff --git a/audio/lvtk/Makefile b/audio/lvtk/Makefile
new file mode 100644
index 000000000000..5abb7b031141
--- /dev/null
+++ b/audio/lvtk/Makefile
@@ -0,0 +1,21 @@
+# Created by: Yuri Victorovich <yuri@rawbw.com>
+# $FreeBSD$
+
+PORTNAME= lvtk
+PORTVERSION= 1.2.0
+CATEGORIES= audio
+
+MAINTAINER= yuri@rawbw.com
+COMMENT= Wraps the LV2 C API and extensions into easy to use C++ classes
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= lv2>0:audio/lv2 \
+ ${LOCALBASE}/include/gtkmm-2.4/gtkmm.h:x11-toolkits/gtkmm24
+
+USES= waf pkgconfig
+USE_GITHUB= yes
+GH_TAGNAME= 7c0ffdf
+
+.include <bsd.port.mk>
diff --git a/audio/lvtk/distinfo b/audio/lvtk/distinfo
new file mode 100644
index 000000000000..6e675232404e
--- /dev/null
+++ b/audio/lvtk/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1502006846
+SHA256 (lvtk-lvtk-1.2.0-7c0ffdf_GH0.tar.gz) = a23a3f72637334fb82a141c6b117d91a68e54b84a1737ddc03422b572e55f9b4
+SIZE (lvtk-lvtk-1.2.0-7c0ffdf_GH0.tar.gz) = 188503
diff --git a/audio/lvtk/pkg-descr b/audio/lvtk/pkg-descr
new file mode 100644
index 000000000000..d55a3c16fed5
--- /dev/null
+++ b/audio/lvtk/pkg-descr
@@ -0,0 +1,5 @@
+This toolkit contains libraries that wrap the LV2 C API and extensions into
+easy to use C++ classes. The original work for this was mostly done by
+Lars Luthman in lv2-c++-tools.
+
+WWW: https://github.com/lvtk/lvtk
diff --git a/audio/lvtk/pkg-plist b/audio/lvtk/pkg-plist
new file mode 100644
index 000000000000..30b3d42f0e63
--- /dev/null
+++ b/audio/lvtk/pkg-plist
@@ -0,0 +1,38 @@
+include/lvtk-2/lvtk/behaviors/write_midi.hpp
+include/lvtk-2/lvtk/ext/atom.hpp
+include/lvtk-2/lvtk/ext/bufsize.hpp
+include/lvtk-2/lvtk/ext/common.h
+include/lvtk-2/lvtk/ext/data_access.hpp
+include/lvtk-2/lvtk/ext/event.hpp
+include/lvtk-2/lvtk/ext/extra.hpp
+include/lvtk-2/lvtk/ext/idle_interface.hpp
+include/lvtk-2/lvtk/ext/instance_access.hpp
+include/lvtk-2/lvtk/ext/log.hpp
+include/lvtk-2/lvtk/ext/midi.hpp
+include/lvtk-2/lvtk/ext/morph.hpp
+include/lvtk-2/lvtk/ext/options.hpp
+include/lvtk-2/lvtk/ext/patch.hpp
+include/lvtk-2/lvtk/ext/resize_port.hpp
+include/lvtk-2/lvtk/ext/state.hpp
+include/lvtk-2/lvtk/ext/time.hpp
+include/lvtk-2/lvtk/ext/units.hpp
+include/lvtk-2/lvtk/ext/urid.hpp
+include/lvtk-2/lvtk/ext/urimap.hpp
+include/lvtk-2/lvtk/ext/worker.hpp
+include/lvtk-2/lvtk/feature.hpp
+include/lvtk-2/lvtk/gtkui.hpp
+include/lvtk-2/lvtk/lvtk.hpp
+include/lvtk-2/lvtk/plugin.hpp
+include/lvtk-2/lvtk/private/debug.hpp
+include/lvtk-2/lvtk/private/types.hpp
+include/lvtk-2/lvtk/private/ui_features.hpp
+include/lvtk-2/lvtk/qt4ui.hpp
+include/lvtk-2/lvtk/synth.hpp
+include/lvtk-2/lvtk/ui.hpp
+include/lvtk-2/lvtk/version.h
+lib/liblvtk_plugin2.a
+lib/liblvtk_ui2.a
+libdata/pkgconfig/lvtk-2.pc
+libdata/pkgconfig/lvtk-gtkui-2.pc
+libdata/pkgconfig/lvtk-plugin-2.pc
+libdata/pkgconfig/lvtk-ui-2.pc