aboutsummaryrefslogtreecommitdiff
path: root/audio/lxmusic/Makefile
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2016-05-26 19:32:15 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2016-05-26 19:32:15 +0000
commit876594fc4bf5e1c6485720a4ff3235ec23e6fb15 (patch)
tree918b10851be559dca004ce0403ae528c85a3fc1d /audio/lxmusic/Makefile
parent7cc82580f81b90022185efcafdf49de1ca519770 (diff)
downloadports-876594fc4bf5e1c6485720a4ff3235ec23e6fb15.tar.gz
ports-876594fc4bf5e1c6485720a4ff3235ec23e6fb15.zip
Notes
Diffstat (limited to 'audio/lxmusic/Makefile')
-rw-r--r--audio/lxmusic/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/audio/lxmusic/Makefile b/audio/lxmusic/Makefile
index b9b731e4b690..ab62a2d306de 100644
--- a/audio/lxmusic/Makefile
+++ b/audio/lxmusic/Makefile
@@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= lxmusic
-PORTVERSION= 0.4.5
-PORTREVISION= 1
+PORTVERSION= 0.4.7
CATEGORIES= audio
-MASTER_SITES= SF/ghostbsdproject/package/LXMusic/
+MASTER_SITES= SF/lxde/LXMusic%20%28music%20player%29/LXMusic%20${PORTVERSION:R}.x/
MAINTAINER= ericturgeon@ghostbsd.org
COMMENT= LXDE music player based on xmms2
@@ -16,24 +15,24 @@ LICENSE_COMB= dual
LIB_DEPENDS= libxmmsclient.so:audio/xmms2 \
libnotify.so:devel/libnotify
-USES= gmake desktop-file-utils pkgconfig
+USES= gettext-tools gmake desktop-file-utils localbase \
+ pkgconfig tar:xz
USE_GNOME= gtk20 intltool
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
INSTALL_TARGET= install-strip
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -lpthread -L${LOCALBASE}/lib
+LDFLAGS+= -lpthread
PORTDOCS= AUTHORS README
OPTIONS_DEFINE= DOCS NLS
OPTIONS_SUB= yes
-NLS_USES= gettext
+NLS_USES= gettext-runtime
NLS_CONFIGURE_ENABLE=nls
-post-install:
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}