aboutsummaryrefslogtreecommitdiff
path: root/audio/mac
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2010-09-08 13:15:27 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2010-09-08 13:15:27 +0000
commit613dfbdf5ac137fe1a668532198b3f73560fb007 (patch)
tree550d13a0ce14fdf3a24eef8c5aebaa6b383fe605 /audio/mac
parent064cf3b4530a38307dbb19d40c5d89f56aebcefe (diff)
downloadports-613dfbdf5ac137fe1a668532198b3f73560fb007.tar.gz
ports-613dfbdf5ac137fe1a668532198b3f73560fb007.zip
- Install missing headers (make port useful as dependency)
- Augment MASTER_SITES and clean up Makefile while here Based on PR: ports/150297
Notes
Notes: svn path=/head/; revision=260765
Diffstat (limited to 'audio/mac')
-rw-r--r--audio/mac/Makefile10
-rw-r--r--audio/mac/pkg-plist3
2 files changed, 10 insertions, 3 deletions
diff --git a/audio/mac/Makefile b/audio/mac/Makefile
index cc0d7e2a5d5d..d245cb1d35ec 100644
--- a/audio/mac/Makefile
+++ b/audio/mac/Makefile
@@ -7,8 +7,9 @@
PORTNAME= mac
PORTVERSION= 3.99.4.5
+PORTREVISION= 1
CATEGORIES= audio
-MASTER_SITES= CENKES
+MASTER_SITES= http://supermmx.org/resources/linux/mac/ CENKES
DISTNAME= ${PORTNAME}-3.99-u4-b5
MAINTAINER= danfe@FreeBSD.org
@@ -17,15 +18,18 @@ COMMENT= Monkey's Audio lossless codec
USE_AUTOTOOLS= libtool:22
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-static
.include <bsd.port.pre.mk>
.if ${ARCH} == "i386" || ${ARCH} == "amd64"
-BUILD_DEPENDS+= yasm:${PORTSDIR}/devel/yasm
+BUILD_DEPENDS= yasm:${PORTSDIR}/devel/yasm
.endif
post-patch:
@${REINPLACE_CMD} -e 's|-O3||' ${WRKSRC}/configure
+post-install:
+ cd ${WRKSRC}/src/MACLib && ${INSTALL_DATA} BitArray.h \
+ Prepare.h UnBitArrayBase.h ${PREFIX}/include/mac
+
.include <bsd.port.post.mk>
diff --git a/audio/mac/pkg-plist b/audio/mac/pkg-plist
index d937cf104581..01efe5a42983 100644
--- a/audio/mac/pkg-plist
+++ b/audio/mac/pkg-plist
@@ -8,6 +8,7 @@ include/mac/APEInfo.h
include/mac/APELink.h
include/mac/APETag.h
include/mac/All.h
+include/mac/BitArray.h
include/mac/CharacterHelper.h
include/mac/CircleBuffer.h
include/mac/GlobalFunctions.h
@@ -17,8 +18,10 @@ include/mac/MACLib.h
include/mac/MACProgressHelper.h
include/mac/MACUtils.h
include/mac/NoWindows.h
+include/mac/Prepare.h
include/mac/SmartPtr.h
include/mac/StdLibFileIO.h
+include/mac/UnBitArrayBase.h
include/mac/config.h
lib/libmac.a
lib/libmac.la