aboutsummaryrefslogtreecommitdiff
path: root/audio/madplay
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-12-07 01:05:38 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-12-07 01:05:38 +0000
commit96ffab3c238fbce7434b75a6f3079308ab9396b9 (patch)
tree643da4498cb327f684df300b9a516eabdc1545f4 /audio/madplay
parent402c1f8fdefee70e6ca7404a993b913ac8a27272 (diff)
downloadports-96ffab3c238fbce7434b75a6f3079308ab9396b9.tar.gz
ports-96ffab3c238fbce7434b75a6f3079308ab9396b9.zip
Add madplay, the MP3 player portion of the MAD audio project.
PR: 59704 Submitted by: Sergey Akifyev <asa@gascom.ru>
Notes
Notes: svn path=/head/; revision=95221
Diffstat (limited to 'audio/madplay')
-rw-r--r--audio/madplay/Makefile39
-rw-r--r--audio/madplay/distinfo1
-rw-r--r--audio/madplay/files/patch-configure10
-rw-r--r--audio/madplay/pkg-descr8
-rw-r--r--audio/madplay/pkg-plist17
5 files changed, 75 insertions, 0 deletions
diff --git a/audio/madplay/Makefile b/audio/madplay/Makefile
new file mode 100644
index 000000000000..a91652d639e5
--- /dev/null
+++ b/audio/madplay/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: madplay
+# Date created: 26 November 2003
+# Whom: Sergey Akifyev <asa@gascom.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= madplay
+PORTVERSION= 0.15.0b
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ ftp://ftp.mars.org/pub/mpeg/
+MASTER_SITE_SUBDIR= mad
+
+MAINTAINER= asa@gascom.ru
+COMMENT= Madplay MP3 player (part of MAD project)
+
+LIB_DEPENDS= intl.5:${PORTSDIR}/devel/gettext \
+ mad.2:${PORTSDIR}/audio/libmad \
+ id3tag.2:${PORTSDIR}/audio/libid3tag
+
+WANT_GNOME= yes
+
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
+
+MAN1= abxtest.1 madplay.1
+
+.include <bsd.port.pre.mk>
+
+.if ${HAVE_GNOME:Mesound}!=""
+USE_GNOME+= esound
+PKGNAMESUFFIX= -esound
+.else
+CONFIGURE_ARGS+= --without-esd
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/audio/madplay/distinfo b/audio/madplay/distinfo
new file mode 100644
index 000000000000..53153c45078f
--- /dev/null
+++ b/audio/madplay/distinfo
@@ -0,0 +1 @@
+MD5 (madplay-0.15.0b.tar.gz) = 35762ddeb46fba8bbf0a260b6c425e82
diff --git a/audio/madplay/files/patch-configure b/audio/madplay/files/patch-configure
new file mode 100644
index 000000000000..f195f07b43c6
--- /dev/null
+++ b/audio/madplay/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig Wed Dec 11 18:31:51 2002
++++ configure Thu Dec 12 12:07:17 2002
+@@ -7414,6 +7414,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/audio/madplay/pkg-descr b/audio/madplay/pkg-descr
new file mode 100644
index 000000000000..f6ae9fe4f025
--- /dev/null
+++ b/audio/madplay/pkg-descr
@@ -0,0 +1,8 @@
+MAD is a high-quality MPEG audio decoder. It currently supports MPEG-1
+as well as the MPEG-2 extension to Lower Sampling Frequencies. All
+three audio layers (Layer I, Layer II, and Layer III a.k.a. MP3) are
+fully implemented.
+
+This is madplay (MP3-player) which is part of the project
+
+WWW: http://mad.sourceforge.net/
diff --git a/audio/madplay/pkg-plist b/audio/madplay/pkg-plist
new file mode 100644
index 000000000000..1c80a3d1e2aa
--- /dev/null
+++ b/audio/madplay/pkg-plist
@@ -0,0 +1,17 @@
+bin/abxtest
+bin/madplay
+share/locale/en/LC_MESSAGES/madplay.mo
+share/locale/es/LC_MESSAGES/madplay.mo
+share/locale/fr/LC_MESSAGES/madplay.mo
+share/locale/hr/LC_MESSAGES/madplay.mo
+share/locale/no/LC_MESSAGES/madplay.mo
+@exec rmdir %D/share/locale/no/LC_MESSAGES 2>/dev/null || true
+@exec rmdir %D/share/locale/no 2>/dev/null || true
+@exec rmdir %D/share/locale/hr/LC_MESSAGES 2>/dev/null || true
+@exec rmdir %D/share/locale/hr 2>/dev/null || true
+@exec rmdir %D/share/locale/fr/LC_MESSAGES 2>/dev/null || true
+@exec rmdir %D/share/locale/fr 2>/dev/null || true
+@exec rmdir %D/share/locale/es/LC_MESSAGES 2>/dev/null || true
+@exec rmdir %D/share/locale/es 2>/dev/null || true
+@exec rmdir %D/share/locale/en/LC_MESSAGES 2>/dev/null || true
+@exec rmdir %D/share/locale/en 2>/dev/null || true