aboutsummaryrefslogtreecommitdiff
path: root/audio/maplay/files
diff options
context:
space:
mode:
authorJordan K. Hubbard <jkh@FreeBSD.org>1995-02-14 08:32:41 +0000
committerJordan K. Hubbard <jkh@FreeBSD.org>1995-02-14 08:32:41 +0000
commitb957235ce2b4bcf36ac6a776b5d839c54c22ed7f (patch)
tree10fdd5ec1944421959d0e95ca339677892e67d5f /audio/maplay/files
parent935cee0496f6b84c8fc807f6fb3571355bfc586b (diff)
downloadports-b957235ce2b4bcf36ac6a776b5d839c54c22ed7f.tar.gz
ports-b957235ce2b4bcf36ac6a776b5d839c54c22ed7f.zip
Notes
Diffstat (limited to 'audio/maplay/files')
-rw-r--r--audio/maplay/files/patch-ab31
1 files changed, 31 insertions, 0 deletions
diff --git a/audio/maplay/files/patch-ab b/audio/maplay/files/patch-ab
new file mode 100644
index 000000000000..0007783c7492
--- /dev/null
+++ b/audio/maplay/files/patch-ab
@@ -0,0 +1,31 @@
+*** work/Makefile.orig Tue Feb 14 08:18:41 1995
+--- work/Makefile Tue Feb 14 08:19:52 1995
+***************
+*** 39,45 ****
+
+ .SUFFIXES: .cc
+
+! install:
+ @./configuration.sh
+
+ all: maplay
+--- 39,45 ----
+
+ .SUFFIXES: .cc
+
+! pre-install:
+ @./configuration.sh
+
+ all: maplay
+***************
+*** 47,52 ****
+--- 47,55 ----
+ maplay: $(OBJS)
+ $(COMPILER) $(CFLAGS) $(OBJS) -o $@ $(LIBRARIES) -lm
+ -strip $@
++
++ install: all
++ ${INSTALL} -s -c -m 755 maplay ${PREFIX}/bin
+
+ .cc.o:
+ $(COMPILER) -c $(CFLAGS) $(INCLUDEDIRS) $*.cc -o $@