aboutsummaryrefslogtreecommitdiff
path: root/audio/mcplay
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-03-20 18:55:54 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-03-20 18:55:54 +0000
commitd6843fd87e4b4a10ad3d0846296a638f17d78caa (patch)
tree9c1fb15df63098f40bfb3942f3bb25db4bc30e10 /audio/mcplay
parentbad2f86a36898749d81849a329706e22465d72ed (diff)
downloadports-d6843fd87e4b4a10ad3d0846296a638f17d78caa.tar.gz
ports-d6843fd87e4b4a10ad3d0846296a638f17d78caa.zip
Notes
Diffstat (limited to 'audio/mcplay')
-rw-r--r--audio/mcplay/Makefile31
-rw-r--r--audio/mcplay/distinfo3
-rw-r--r--audio/mcplay/files/mcplay.165
-rw-r--r--audio/mcplay/files/patch-Makefile20
-rw-r--r--audio/mcplay/files/patch-config.h11
-rw-r--r--audio/mcplay/files/patch-mixer.c11
-rw-r--r--audio/mcplay/files/patch-screen.c17
-rw-r--r--audio/mcplay/pkg-descr11
8 files changed, 169 insertions, 0 deletions
diff --git a/audio/mcplay/Makefile b/audio/mcplay/Makefile
new file mode 100644
index 000000000000..f7a961981339
--- /dev/null
+++ b/audio/mcplay/Makefile
@@ -0,0 +1,31 @@
+# Ports collection makefile for: mcplay
+# Date created: 18 Mar 2010
+# Whom: Charlie Kester <corky1951@comcast.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mcplay
+DISTVERSION= 0.3i
+CATEGORIES= audio
+MASTER_SITES= http://www.yahuxo.de/${PORTNAME}/
+
+MAINTAINER= corky1951@comcast.net
+COMMENT= A curses based front-end to various audioplayers
+
+LIB_DEPENDS= glib-12:${PORTSDIR}/devel/glib12
+
+.if !defined(NO_INSTALL_MANPAGES)
+MAN1= ${PORTNAME}.1
+MANCOMPRESSED= no
+.endif
+
+PLIST_FILES= bin/${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+.if !defined(NO_INSTALL_MANPAGES)
+ ${INSTALL_MAN} ${FILESDIR}/${PORTNAME}.1 ${MAN1PREFIX}/man/man1
+.endif
+
+.include <bsd.port.mk>
diff --git a/audio/mcplay/distinfo b/audio/mcplay/distinfo
new file mode 100644
index 000000000000..6f7076e49606
--- /dev/null
+++ b/audio/mcplay/distinfo
@@ -0,0 +1,3 @@
+MD5 (mcplay-0.3i.tar.gz) = 11448f55ea7d6b337ec3b9e2c0bf7b13
+SHA256 (mcplay-0.3i.tar.gz) = 1bfbc6f3f5b263de0d1939cd19381da83a667d16275dcbfefa9fdbf9cd11ee93
+SIZE (mcplay-0.3i.tar.gz) = 102592
diff --git a/audio/mcplay/files/mcplay.1 b/audio/mcplay/files/mcplay.1
new file mode 100644
index 000000000000..17ca254ccba9
--- /dev/null
+++ b/audio/mcplay/files/mcplay.1
@@ -0,0 +1,65 @@
+.TH MCPLAY "1" "March 2010" "mcplay 0.3i" "User Commands"
+.SH NAME
+mcplay \- A curses based front-end for various audio players
+.SH SYNOPSIS
+.B mcplay
+[\fIoptions\fR] [\fIfile|dir|playlist\fR]...
+.SH DESCRIPTION
+.B mcplay
+is a reimplementation in C of the well-known python program 'cplay'.
+.PP
+The following players are supported: mpg123 ogg123 sox
+.PP
+Files, Directories and Playlist\-Files (m3u\-files) given as arguments on the
+commandline will be added to the internal playlist.
+.SH OPTIONS
+.TP
+\fB\-a\fR, \fB\-\-aggressive\fR
+Increase the priority of the players (if possible).
+.TP
+\fB\-c\fR, \fB\-\-color\fR
+Run program in colored mode (if available).
+.TP
+\fB\-l\fR, \fB\-\-logfile\fR
+Log messages to this file. [default: /tmp/mcplay.log]
+.TP
+\fB\-p\fR, \fB\-\-play\fR
+Start playing the playlist.
+.TP
+\fB\-r\fR, \fB\-\-repeat\fR
+Start in repeat playlist mode.
+.TP
+\fB\-R\fR, \fB\-\-random\fR
+Start in random playlist mode.
+.TP
+\fB\-\-version\fR
+Print version information.
+.TP
+\fB\-\-copyright\fR
+Print copyright information.
+.TP
+\fB\-h\fR, \fB\-\-help\fR
+Shows this text.
+.PP
+Press 'h' while mcplay is running for help on keys.
+.SH SEE ALSO
+Website: http://www.yahuxo.de/mcplay/
+.SH AUTHOR
+Tobias Rapp <yahuxo at gmx.de>
+.SH LICENSE
+Copyright (C) 2002 Tobias Rapp.
+
+This program is free software; you can redistribute it and/or modify
+it under the terms of the GNU General Public License as published by
+the Free Software Foundation; either version 2 of the License, or
+(at your option) any later version.
+
+This program is distributed in the hope that it will be useful,
+but WITHOUT ANY WARRANTY; without even the implied warranty of
+MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+GNU General Public License for more details.
+
+You should have received a copy of the GNU General Public License
+along with this program. If not, write to the Free Software
+Foundation, 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+
diff --git a/audio/mcplay/files/patch-Makefile b/audio/mcplay/files/patch-Makefile
new file mode 100644
index 000000000000..953ccfe62e24
--- /dev/null
+++ b/audio/mcplay/files/patch-Makefile
@@ -0,0 +1,20 @@
+--- Makefile.orig 2002-04-28 06:30:35.000000000 -0700
++++ Makefile 2010-03-19 11:07:59.000000000 -0700
+@@ -13,7 +13,7 @@
+ SOX_CFLAGS=-DHAVE_SOX
+
+ #uncomment _one_ of these for midi support
+-MID_CFLAGS=-DHAVE_DRVMIDI
++#MID_CFLAGS=-DHAVE_DRVMIDI
+ #MID_CFLAGS=-DHAVE_PLAYMIDI
+
+ #uncomment these two lines if you have lirc
+@@ -24,7 +24,7 @@
+ #LOG_CFLAGS=-DLOG_DIR_S=\"/tmp\"
+
+ #set install dirs here
+-INSTDIR=/usr/local
++INSTDIR=${PREFIX}
+ BINDIR=$(INSTDIR)/bin
+
+ #####################################################################
diff --git a/audio/mcplay/files/patch-config.h b/audio/mcplay/files/patch-config.h
new file mode 100644
index 000000000000..0998714164a8
--- /dev/null
+++ b/audio/mcplay/files/patch-config.h
@@ -0,0 +1,11 @@
+--- config.h.orig 2010-03-18 18:48:31.000000000 -0700
++++ config.h 2010-03-18 18:50:27.000000000 -0700
+@@ -26,7 +26,7 @@
+ #define LOGFILE_S LOGDIR_S""G_DIR_SEPARATOR_S""PROGNAME_S".log"
+
+ /* if you have linux */
+-#include <linux/limits.h>
++#include <sys/limits.h>
+ /* else */
+ /* #define PATH_MAX 1000 */
+ /* #define NAME_MAX 200 */
diff --git a/audio/mcplay/files/patch-mixer.c b/audio/mcplay/files/patch-mixer.c
new file mode 100644
index 000000000000..11cf95d42422
--- /dev/null
+++ b/audio/mcplay/files/patch-mixer.c
@@ -0,0 +1,11 @@
+--- mixer.c.orig 2010-03-18 18:58:51.000000000 -0700
++++ mixer.c 2010-03-18 18:59:10.000000000 -0700
+@@ -7,7 +7,7 @@
+ #include <fcntl.h>
+ #include <unistd.h>
+ #include <stdlib.h>
+-#include <linux/soundcard.h>
++#include <sys/soundcard.h>
+ #include <errno.h>
+ #include <string.h>
+
diff --git a/audio/mcplay/files/patch-screen.c b/audio/mcplay/files/patch-screen.c
new file mode 100644
index 000000000000..1f2b07a71c6a
--- /dev/null
+++ b/audio/mcplay/files/patch-screen.c
@@ -0,0 +1,17 @@
+--- screen.c.orig 2010-03-18 19:50:01.000000000 -0700
++++ screen.c 2010-03-18 19:54:07.000000000 -0700
+@@ -275,9 +275,13 @@
+ gchar *tmp, *str;
+
+ va_start(az, fmt);
+- str = g_strdup_vprintf(fmt, az);
++ if ( fmt != NULL )
++ str = g_strdup_vprintf(fmt, az);
+ va_end(az);
+
++ if ( fmt == NULL )
++ return;
++
+ if( data->nmsg >= 0 )
+ {
+ tmp = g_strdup_printf("%*.*s", -1*(data->cols-7), data->cols-7, str);
diff --git a/audio/mcplay/pkg-descr b/audio/mcplay/pkg-descr
new file mode 100644
index 000000000000..68669cfe71d2
--- /dev/null
+++ b/audio/mcplay/pkg-descr
@@ -0,0 +1,11 @@
+mcplay is a curses based front-end for various audio players. It
+is a reimplementation in C of the well-known python program 'cplay'.
+
+Supported players currently include:
+- mpg123
+- ogg123
+- sox
+
+Author: Tobias Rapp
+
+WWW: http://www.yahuxo.de/mcplay/