aboutsummaryrefslogtreecommitdiff
path: root/audio/mctoolame-decoder
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-03-13 11:19:28 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-03-13 11:19:28 +0000
commitf237f85dd40292644a02692ec5afd81b23fc25cf (patch)
treef92455157e8b2f1c4372c6c9d999a94a84d041c1 /audio/mctoolame-decoder
parent17e4ba74fffc63fb17832e25f3b212daac51fb96 (diff)
downloadports-f237f85dd40292644a02692ec5afd81b23fc25cf.tar.gz
ports-f237f85dd40292644a02692ec5afd81b23fc25cf.zip
Synchronize mctoolame-decoder and mctoolame-encoder. These ports are pretty
much mimic each other, so it probably makes sense to merge them into one, or turn into master-slave pair. While here, replace unsafe gets() with fgets().
Notes
Notes: svn path=/head/; revision=314072
Diffstat (limited to 'audio/mctoolame-decoder')
-rw-r--r--audio/mctoolame-decoder/Makefile53
-rw-r--r--audio/mctoolame-decoder/pkg-descr34
2 files changed, 29 insertions, 58 deletions
diff --git a/audio/mctoolame-decoder/Makefile b/audio/mctoolame-decoder/Makefile
index e834be8389b6..d6dbb3ca8d2b 100644
--- a/audio/mctoolame-decoder/Makefile
+++ b/audio/mctoolame-decoder/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: mctooLAME decoder
-# Date created: Thu Mar 27 20:32:42 UTC 2003
-# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
-#
+# Created by: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= mctoolame
PORTVERSION= 0.1.a
@@ -15,51 +11,28 @@ DISTNAME= ${PORTNAME}d-${PORTVERSION:C/\.//g}
EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
-COMMENT= A LayerII MPEG Audio decoder which supports multi-channel encoding
+COMMENT= MPEG Layer II audio decoder with multi-channel support
USE_GMAKE= yes
-ALL_TARGET=
+ALL_TARGET= #
+MAKE_ARGS= CC="${CC}" OPTIM="${CFLAGS}"
PLIST_SUB= PKGNAMESUFFIX="${PKGNAMESUFFIX}"
-pre-everything::
-.ifndef(WITH_OPTIMIZED_CFLAGS)
- @${ECHO_MSG} '>>>'
- @${ECHO_MSG} '>>> You can enable extra optimizations by defining WITH_OPTIMIZED_CFLAGS'
- @${ECHO_MSG} ">>> For example, 'make WITH_OPTIMIZED_CFLAGS=yes'"
-.endif
- @${ECHO_MSG} '>>>'
-.ifndef(WITH_PROFILED)
- @${ECHO_MSG} ">>> You can enable profiling by defining WITH_PROFILED"
-.endif
+OPTIONS_DEFINE= DOCS
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
post-patch:
-.ifndef(WITH_OPTIMIZED_CFLAGS)
- @${REINPLACE_CMD} -E \
- -e 's|\$$\(TWEAKS\)||' \
- ${WRKSRC}/Makefile
-.endif
-.ifndef(WITH_PROFILED)
- @${REINPLACE_CMD} -E \
- -e 's|\$$\(PG\)||' \
- ${WRKSRC}/Makefile
-.endif
- @${REINPLACE_CMD} -E \
- -e 's@\$$\((ARCH|OPTIM|WARNINGS)\)@@g' \
- ${WRKSRC}/Makefile
-
-post-configure:
-# C{C,FLAGS} safeness
+ @${REINPLACE_CMD} -e 's|$$(ARCH)||' ${WRKSRC}/Makefile
@${REINPLACE_CMD} -E \
- -e 's|^(CC[[:space:]]*=).+$$|\1${CC} ${CFLAGS}|' \
- ${WRKSRC}/Makefile
+ 's|gets *\(([^,)]+)\)|fgets(\1, sizeof(\1), stdin)|' \
+ ${WRKSRC}/musicout.c
do-install:
-.ifndef(NOPORTDOCS)
+ ${INSTALL_PROGRAM} ${WRKSRC}/mctoolamed ${PREFIX}/bin
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}${PKGNAMESUFFIX}/html
- @${INSTALL_DATA} ${WRKSRC}/html/* ${DOCSDIR}${PKGNAMESUFFIX}/html
+ ${INSTALL_DATA} ${WRKSRC}/html/* ${DOCSDIR}${PKGNAMESUFFIX}/html
.endif
- @${INSTALL_PROGRAM} ${WRKSRC}/mctoolamed ${PREFIX}/bin
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/audio/mctoolame-decoder/pkg-descr b/audio/mctoolame-decoder/pkg-descr
index 20bf70d51e46..539fc0f3f31a 100644
--- a/audio/mctoolame-decoder/pkg-descr
+++ b/audio/mctoolame-decoder/pkg-descr
@@ -1,24 +1,22 @@
-[ excerpt from developer's WWW site ]
+A multi-channel MPEG encoder, using the ISO13818 standard and the dist10
+source code. Multi-channel files may have up to 6 defined channels:
+Left(L), Right(R), Center(C), Left Surround (LS), Right Surround (RS) and
+a Low Frequency Enhancement channel (LFE).
-A multi-channel MPEG encoder, using the ISO13818 standard and the
-dist10 source code. Multi-channel files may have up to 6 defined
-channels: Left(L), Right(R), Center(C), Left Surround (LS), Right
-Surround (RS) and a Low Frequency Enhancement channel (LFE).
+ISO13818 defines 5 multi-channel modes (on top of the normal stereo mode),
+each of these modes may have an optional LFE channel:
-ISO13818 defines 5 multichannel modes (on top of the normal stereo
-mode), each of these modes may have an optional LFE channel:
+ 3/2: L, R, C, LS, RS
+ 3/1: L, R, C, mono surround
+ 2/2: L, R, LS, RS
+ 2/1: L, R, mono surround
+ 3/0: L, R, C
-3/2: L, R, C, LS, RS
-3/1: L, R, C, mono surround
-2/2: L, R, LS, RS
-2/1: L, R, mono surround
-3/0: L, R, C
+The "standard" surround sound encoding of "5.1 channels" is achieved by
+using mode 3/2 plus an LFE channel.
-The "standard" surround sound encoding of "5.1 channels" is achieved
-by using mode 3/2 plus an LFE channel.
-
-A multi-channel MPEG file should decode OK on any MPEG decoder. If
-the decoder doesn't recognize the multi-channel extensions, then
-you'll just get a stereo file containing a down mix of the 5 channels.
+A multi-channel MPEG file should decode OK on any MPEG decoder. If the
+decoder doesn't recognize the multi-channel extensions, then you'll just
+get a stereo file containing a down mix of the 5 channels.
WWW: http://mctoolame.sourceforge.net/