aboutsummaryrefslogtreecommitdiff
path: root/audio/midipp
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
commitb1a1d38bf9ef78334b640d30046388a9c055c3a9 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /audio/midipp
parentbc77780d41178cf3d0327c79ac10737af704f236 (diff)
downloadports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.tar.gz
ports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.zip
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk
From now on, ports that depend on Qt4 will have to set USES= qt:4 USE_QT= foo bar ports depending on Qt5 will use USES= qt:5 USE_QT= foo bar PR: 229225 Exp-run by: antoine Reviewed by: mat Approved by: portmgr (antoine) Differential Revision: →https://reviews.freebsd.org/D15540
Notes
Notes: svn path=/head/; revision=473503
Diffstat (limited to 'audio/midipp')
-rw-r--r--audio/midipp/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/audio/midipp/Makefile b/audio/midipp/Makefile
index 46ecf7d28858..0b24bf05523b 100644
--- a/audio/midipp/Makefile
+++ b/audio/midipp/Makefile
@@ -25,7 +25,9 @@ OPTIONS_SINGLE_TOOLKIT= QT4 QT5
OPTIONS_DEFAULT= QT5
TOOLKIT_DESC= Qt toolkit
-QT4_USE= ${_USE_QT4:S/^/QT4=/}
-QT5_USE= ${_USE_QT5:S/^/QT5=/} GL=gl
+QT4_USES= qt:4
+QT4_USE= ${_USE_QT4:S/^/QT=/}
+QT5_USES= qt:5
+QT5_USE= ${_USE_QT5:S/^/QT=/} GL=gl
.include <bsd.port.mk>