aboutsummaryrefslogtreecommitdiff
path: root/audio/milkytracker
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2018-02-21 14:10:56 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2018-02-21 14:10:56 +0000
commit452e699fcc843cdbde00d24d1b1f7ac51bf34f44 (patch)
treec4703991abb6cf404f48c96a3cdeb77182f8119c /audio/milkytracker
parent1faf852ad2a49746c7e84318621e17a55e68e588 (diff)
downloadports-452e699fcc843cdbde00d24d1b1f7ac51bf34f44.tar.gz
ports-452e699fcc843cdbde00d24d1b1f7ac51bf34f44.zip
Fix build on 12.0-CURRENT after upgrading clang, llvm, lld, lldb, compiler-rt
and libc++ to 6.0.0 by falling back to gcc. Notified by: pkg-fallout
Notes
Notes: svn path=/head/; revision=462524
Diffstat (limited to 'audio/milkytracker')
-rw-r--r--audio/milkytracker/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/audio/milkytracker/Makefile b/audio/milkytracker/Makefile
index 75fc3b44dd95..9b410032f5e1 100644
--- a/audio/milkytracker/Makefile
+++ b/audio/milkytracker/Makefile
@@ -28,6 +28,13 @@ OPTIONS_DEFINE= DOCS
BROKEN_powerpc= Does not build on powerpc
BROKEN_powerpc64= Does not build on powerpc64
+.include <bsd.port.pre.mk>
+
+# does not compile with clang 6.0.0
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1200056
+USE_GCC= yes
+.endif
+
post-install:
.for f in ${ICONS}
${INSTALL_DATA} ${WRKSRC}/resources/pictures/${f} \
@@ -39,4 +46,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/docs/${f} ${STAGEDIR}${DOCSDIR}
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>