aboutsummaryrefslogtreecommitdiff
path: root/audio/mixxx
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2017-09-25 06:34:58 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2017-09-25 06:34:58 +0000
commit654e5822a70ad68b1e729681d245fa0bad2d24c2 (patch)
treedf766918b9d81c5526a778fba08d953395fdb1e3 /audio/mixxx
parentc9314c44534ab10f43f78cbc1909a6044286ff47 (diff)
downloadports-654e5822a70ad68b1e729681d245fa0bad2d24c2.tar.gz
ports-654e5822a70ad68b1e729681d245fa0bad2d24c2.zip
- Add missing dependency
- Take maintainership - Fix libmp3lame detection - Bump PORTREVISION
Notes
Notes: svn path=/head/; revision=450573
Diffstat (limited to 'audio/mixxx')
-rw-r--r--audio/mixxx/Makefile8
-rw-r--r--audio/mixxx/files/patch-src-encoder_encodermp3.cpp11
2 files changed, 15 insertions, 4 deletions
diff --git a/audio/mixxx/Makefile b/audio/mixxx/Makefile
index a7b2a71cd751..7eb443a5fe33 100644
--- a/audio/mixxx/Makefile
+++ b/audio/mixxx/Makefile
@@ -4,11 +4,11 @@
PORTNAME= mixxx
PORTVERSION= 2.0.0
DISTVERSIONSUFFIX= -src
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= audio
MASTER_SITES= http://downloads.mixxx.org/${PORTNAME}-${PORTVERSION}/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= acm@FreeBSD.org
COMMENT= DJ mixing application
LICENSE= GPLv2+
@@ -32,8 +32,8 @@ BROKEN_aarch64= fails to compile: Exception("invalid machine type")
BROKEN_powerpc64= fails to configure: unmet dependencies: Could not find libprotobuf, libchromaprint, libmp4, and libwavpack
USES= scons iconv pkgconfig
-USE_QT4= corelib gui network opengl script scripttools sql svg \
- testlib xml xmlpatterns linguisttools_build moc_build \
+USE_QT4= corelib gui network opengl script scripttools sql sql-sqlite3 \
+ svg testlib xml xmlpatterns linguisttools_build moc_build \
qmake_build rcc_build uic_build
USE_GL= gl glu
MAKE_ARGS= qtdir="${PREFIX}" install_root="${PREFIX}" \
diff --git a/audio/mixxx/files/patch-src-encoder_encodermp3.cpp b/audio/mixxx/files/patch-src-encoder_encodermp3.cpp
new file mode 100644
index 000000000000..67914779e1c1
--- /dev/null
+++ b/audio/mixxx/files/patch-src-encoder_encodermp3.cpp
@@ -0,0 +1,11 @@
+--- src/encoder/encodermp3.cpp 2017-09-24 22:09:28.258505000 -0500
++++ src/encoder/encodermp3.cpp 2017-09-24 22:12:09.197474000 -0500
+@@ -76,7 +76,7 @@
+ */
+ QStringList libnames;
+ QString libname = "";
+-#ifdef __LINUX__
++#if defined(__LINUX__) || defined(__FreeBSD__)
+ libnames << "mp3lame";
+ #elif __WINDOWS__
+ libnames << "lame_enc.dll";