aboutsummaryrefslogtreecommitdiff
path: root/audio/mixxx
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2020-07-02 16:45:34 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2020-07-02 16:45:34 +0000
commitc36e69703f67974e602aec8c79de147c70c0a317 (patch)
tree02c0b332a7482559621501e6c74b0c938372e1e0 /audio/mixxx
parent03d3d2923f4aa1747342e62bce460733c3be0384 (diff)
downloadports-c36e69703f67974e602aec8c79de147c70c0a317.tar.gz
ports-c36e69703f67974e602aec8c79de147c70c0a317.zip
- Update to 2.2.4
- Use python3 scons
Notes
Notes: svn path=/head/; revision=541045
Diffstat (limited to 'audio/mixxx')
-rw-r--r--audio/mixxx/Makefile5
-rw-r--r--audio/mixxx/distinfo6
-rw-r--r--audio/mixxx/files/patch-build_depends.py4
-rw-r--r--audio/mixxx/files/patch-build_features.py4
4 files changed, 9 insertions, 10 deletions
diff --git a/audio/mixxx/Makefile b/audio/mixxx/Makefile
index f0891a71ec05..0f50c46882af 100644
--- a/audio/mixxx/Makefile
+++ b/audio/mixxx/Makefile
@@ -3,8 +3,7 @@
PORTNAME= mixxx
DISTVERSIONPREFIX= release-
-DISTVERSION= 2.2.3
-PORTREVISION= 2
+DISTVERSION= 2.2.4
CATEGORIES= audio
MAINTAINER= acm@FreeBSD.org
@@ -33,7 +32,7 @@ LIB_DEPENDS= libchromaprint.so:audio/chromaprint \
libprotobuf.so:devel/protobuf \
liblilv-0.so:audio/lilv
-USES= compiler:c++11-lang gl iconv qt:5 pkgconfig scons:python2 xorg
+USES= compiler:c++11-lang gl iconv qt:5 pkgconfig scons xorg
USE_XORG= x11
USE_GL= gl glu
USE_GITHUB= yes
diff --git a/audio/mixxx/distinfo b/audio/mixxx/distinfo
index db5222b705d4..749dc9dd281a 100644
--- a/audio/mixxx/distinfo
+++ b/audio/mixxx/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1576007042
-SHA256 (mixxxdj-mixxx-release-2.2.3_GH0.tar.gz) = 69230dca511ba08a284a22a979ff05b62130e97156d39a044bb4045f5f43cd2e
-SIZE (mixxxdj-mixxx-release-2.2.3_GH0.tar.gz) = 35060366
+TIMESTAMP = 1593383731
+SHA256 (mixxxdj-mixxx-release-2.2.4_GH0.tar.gz) = 9372b43d5ec882845b4fe2350ef50dabb3f1e0cc029f182b0ed8aa4f4f3b2afa
+SIZE (mixxxdj-mixxx-release-2.2.4_GH0.tar.gz) = 35480450
diff --git a/audio/mixxx/files/patch-build_depends.py b/audio/mixxx/files/patch-build_depends.py
index f0d8db7aaeae..4d0da8778a3d 100644
--- a/audio/mixxx/files/patch-build_depends.py
+++ b/audio/mixxx/files/patch-build_depends.py
@@ -73,7 +73,7 @@
qtdir = build.env['QTDIR']
framework_path = Qt.find_framework_libdir(qtdir, qt5)
- if os.path.isdir(framework_path):
-+ if framework_path and os.path.isdir(framework_path):
++ if framework_path and os.path.isdir(framework_path):
build.env.Append(LINKFLAGS="-L" + framework_path)
# Mixxx requires C++11 support. Windows enables C++11 features by
@@ -91,7 +91,7 @@
# it, though might cause issues. This is safe to remove once we
# deprecate Karmic support. rryan 2/2011
- build.env.Append(CPPPATH='/usr/include/taglib/')
-+ build.env.Append(CPPPATH='%%LOCALBASE%%/include/taglib/')
++ build.env.Append(CPPPATH='%%LOCALBASE%%/include/taglib/')
if build.platform_is_windows and build.static_dependencies:
build.env.Append(CPPDEFINES='TAGLIB_STATIC')
diff --git a/audio/mixxx/files/patch-build_features.py b/audio/mixxx/files/patch-build_features.py
index f97c69449dfc..9b2c944f5779 100644
--- a/audio/mixxx/files/patch-build_features.py
+++ b/audio/mixxx/files/patch-build_features.py
@@ -4,8 +4,8 @@
# -pthread tells GCC to do the right thing regardless of system
build.env.Append(CCFLAGS='-pthread')
build.env.Append(LINKFLAGS='-pthread')
-+ elif build.platform_is_bsd:
-+ build.env.ParseConfig('pkg-config hidapi --silence-errors --cflags --libs')
++ elif build.platform_is_bsd:
++ build.env.ParseConfig('pkg-config hidapi --silence-errors --cflags --libs')
+ conf.CheckLib(['pthread', 'libpthread'])
+ conf.CheckLib(['rt', 'librt'])