aboutsummaryrefslogtreecommitdiff
path: root/audio/moony-lv2
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-05-24 17:18:59 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-05-24 17:18:59 +0000
commitd5f208d9ae56fb56f42d59b2d2dcc88da045942f (patch)
treeacf7e15695793dac611308541b6d15cdae665833 /audio/moony-lv2
parent248c08be3c9f559038ada13e51482ad70a10d0d6 (diff)
downloadports-d5f208d9ae56fb56f42d59b2d2dcc88da045942f.tar.gz
ports-d5f208d9ae56fb56f42d59b2d2dcc88da045942f.zip
audio/moony-lv2: Fix built on 10
Also change USES=cmake -> USES=cmake:outsource As it turned out, cmake's check_function_exists doesn't find functions in libm.so, so check_library_exists should be used. PR: 228443 Submitted by: tcberner (cmake part)
Notes
Notes: svn path=/head/; revision=470793
Diffstat (limited to 'audio/moony-lv2')
-rw-r--r--audio/moony-lv2/Makefile2
-rw-r--r--audio/moony-lv2/files/patch-CMakeLists.txt6
2 files changed, 4 insertions, 4 deletions
diff --git a/audio/moony-lv2/Makefile b/audio/moony-lv2/Makefile
index 82a20fd17506..ffbb3fb365f3 100644
--- a/audio/moony-lv2/Makefile
+++ b/audio/moony-lv2/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= lv2>0:audio/lv2
-USES= cmake pkgconfig
+USES= cmake:outsource pkgconfig
USE_XORG= x11 xext
USE_GL= gl glu
diff --git a/audio/moony-lv2/files/patch-CMakeLists.txt b/audio/moony-lv2/files/patch-CMakeLists.txt
index 7b5599112432..35a37e70a025 100644
--- a/audio/moony-lv2/files/patch-CMakeLists.txt
+++ b/audio/moony-lv2/files/patch-CMakeLists.txt
@@ -6,9 +6,9 @@
set(CMAKE_MODULE_LINKER_FLAGS "-Wl,-z,nodelete ${CMAKE_MODULE_LINKER_FLAGS}")
+elseif(CMAKE_SYSTEM_NAME STREQUAL "FreeBSD")
+ # see https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=221341
-+ include(CheckFunctionExists)
-+ check_function_exists(clog FreeBSD_CLOG_EXISTS)
-+ check_function_exists(cpow FreeBSD_CPOW_EXISTS)
++ include(CheckLibraryExists)
++ check_library_exists(m clog 'complex.h' FreeBSD_CLOG_EXISTS)
++ check_library_exists(m cpow 'complex.h' FreeBSD_CPOW_EXISTS)
+ if (FreeBSD_CLOG_EXISTS)
+ set(CMAKE_C_FLAGS "-DFreeBSD_CLOG_EXISTS ${CMAKE_C_FLAGS}")
+ endif()