aboutsummaryrefslogtreecommitdiff
path: root/audio/mous
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2012-07-23 18:13:55 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2012-07-23 18:13:55 +0000
commit2794689239461cf027bcfcb38ae6e821e7216418 (patch)
tree294ab4ab204e72e806e1176c69c86b1910c14efe /audio/mous
parent4a9355f439e0aa09ec22be4ce16c8592f8eafb5a (diff)
downloadports-2794689239461cf027bcfcb38ae6e821e7216418.tar.gz
ports-2794689239461cf027bcfcb38ae6e821e7216418.zip
Mous is a simpe yet powerful audio player.
WWW: https://github.com/0x02/mous PR: ports/169095 Submitted by: Yanhui Shen <shen.elf@gmail.com> Approved by: tabthorpe (mentor)
Notes
Notes: svn path=/head/; revision=301404
Diffstat (limited to 'audio/mous')
-rw-r--r--audio/mous/Makefile230
-rw-r--r--audio/mous/distinfo2
-rw-r--r--audio/mous/files/patch-CMakeLists.txt20
-rw-r--r--audio/mous/files/pkg-message.in5
-rw-r--r--audio/mous/pkg-descr3
-rw-r--r--audio/mous/pkg-plist80
6 files changed, 340 insertions, 0 deletions
diff --git a/audio/mous/Makefile b/audio/mous/Makefile
new file mode 100644
index 000000000000..ed962ef06f3a
--- /dev/null
+++ b/audio/mous/Makefile
@@ -0,0 +1,230 @@
+# New ports collection makefile for: mous
+# Date created: 15 Jan 2012
+# Whom: Yanhui Shen <shen.elf@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mous
+PORTVERSION= 1.1a
+CATEGORIES= audio
+MASTER_SITES= http://cloud.github.com/downloads/0x02/mous/
+
+MAINTAINER= shen.elf@gmail.com
+COMMENT= A simple yet powerful audio player
+
+LICENSE= BSD
+LICENSE_FILE= ${WRKSRC}/COPYRIGHT
+
+USE_CMAKE= yes
+MAKE_JOBS_SAFE= yes
+
+OPTIONS_DEFINE= ALSA ASSEMBLY FAAC FAAD FLAC LAME AO CUE MAC4DECODER \
+ MACDECODER MPG123 NCURSES OSS QT4 SDK TAGLIB VORBIS \
+ WAVDECODER WAVENCODER WMA
+OPTIONS_DEFAULT= ASSEMBLY FAAC FAAD FLAC LAME CUE MAC4DECODER \
+ MPG123 NCURSES OSS QT4 TAGLIB VORBIS WAVDECODER \
+ WAVENCODER WMA
+
+ASSEMBLY_DESC= Enable assembly optimize
+MAC4DECODER_DESC= Newest mac4.11 decoder(*.ape)
+MACDECODER_DESC= Old mac3.99 ape decoder(*.ape)
+NCURSES_DESC= Ncurses frontend
+QT4_DESC= QT4 frontend
+SDK_DESC= Install SDK
+TAGLIB_DESC= TagLib plugin(recommended)
+WAVDECODER_DESC= Decode Wav
+WAVENCODER_DESC= Encode Wav
+WMA_DESC= WMA decoder plugin
+
+SUB_FILES= pkg-message
+PKGMESSAGE= ${WRKSRC}/pkg-message
+
+.include <bsd.port.options.mk>
+
+.if ${OSVERSION} < 800067
+BROKEN= Does not compile on 7.x: Requires wcscasecmp(3)
+.endif
+
+.if ${PORT_OPTIONS:MSDK}
+CMAKE_ARGS+= -DWithHeadFiles=1
+PLIST_SUB+= SDK=""
+.else
+CMAKE_ARGS+= -DWithHeadFiles=0
+PLIST_SUB+= SDK="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MASSEMBLY}
+BUILD_DEPENDS+= ${LOCALBASE}/bin/yasm:${PORTSDIR}/devel/yasm
+CMAKE_ARGS+= -DWithAssembly=1
+.else
+CMAKE_ARGS+= -DWithAssembly=0
+.endif
+
+.if ${PORT_OPTIONS:MNCURSES}
+USE_NCURSES= yes
+CMAKE_ARGS+= -DWithFrontendNcurses=1
+PLIST_SUB+= NCURSES=""
+.else
+CMAKE_ARGS+= -DWithFrontendNcurses=0
+PLIST_SUB+= NCURSES="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MQT4}
+USE_QT4= gui linguist moc_build qmake_build rcc_build uic_build
+CMAKE_ARGS+= -DWithFrontendQt=1
+PLIST_SUB+= QT4=""
+.else
+CMAKE_ARGS+= -DWithFrontendQt=0
+PLIST_SUB+= QT4="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MOSS}
+CMAKE_ARGS+= -DWithPluginOssRenderer=1
+PLIST_SUB+= OSS=""
+.else
+CMAKE_ARGS+= -DWithPluginOssRenderer=0
+PLIST_SUB+= OSS="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MALSA}
+LIB_DEPENDS+= asound:${PORTSDIR}/audio/alsa-lib
+CMAKE_ARGS+= -DWithPluginAlsaRenderer=1
+PLIST_SUB+= ALSA=""
+.else
+CMAKE_ARGS+= -DWithPluginAlsaRenderer=0
+PLIST_SUB+= ALSA="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MAO}
+LIB_DEPENDS+= libao:${PORTSDIR}/audio/libao
+CMAKE_ARGS+= -DWithPluginAoRenderer=1
+PLIST_SUB+= AO=""
+.else
+CMAKE_ARGS+= -DWithPluginAoRenderer=0
+PLIST_SUB+= AO="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MTAGLIB}
+LIB_DEPENDS+= tag:${PORTSDIR}/audio/taglib
+CMAKE_ARGS+= -DWithPluginTagLibParser=1
+PLIST_SUB+= TAGLIB=""
+.else
+CMAKE_ARGS+= -DWithPluginTagLibParser=0
+PLIST_SUB+= TAGLIB="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MCUE}
+LIB_DEPENDS+= cue:${PORTSDIR}/textproc/libcue
+CMAKE_ARGS+= -DWithPluginCuePack=1
+PLIST_SUB+= CUE=""
+.else
+CMAKE_ARGS+= -DWithPluginCuePack=0
+PLIST_SUB+= CUE="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MWAVDECODER}
+CMAKE_ARGS+= -DWithPluginWavDecoder=1
+PLIST_SUB+= WAVDECODER=""
+.else
+CMAKE_ARGS+= -DWithPluginWavEncoder=0
+PLIST_SUB+= WAVDECODER="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MWAVDECODER}
+CMAKE_ARGS+= -DWithPluginWavEncoder=1
+PLIST_SUB+= WAVENCODER=""
+.else
+CMAKE_ARGS+= -DWithPluginWavEncoder=0
+PLIST_SUB+= WAVENCODER="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MFAAD}
+LIB_DEPENDS+= faad:${PORTSDIR}/audio/faad
+CMAKE_ARGS+= -DWithPluginFaadDecoder=1
+PLIST_SUB+= FAAD=""
+.else
+CMAKE_ARGS+= -DWithPluginFaadEncoder=0
+PLIST_SUB+= FAAD="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MFAAC}
+LIB_DEPENDS+= faac:${PORTSDIR}/audio/faac
+CMAKE_ARGS+= -DWithPluginFaacEncoder=1
+PLIST_SUB+= FAAC=""
+.else
+CMAKE_ARGS+= -DWithPluginFaacEncoder=0
+PLIST_SUB+= FAAC="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MMPG123}
+LIB_DEPENDS+= mpg123:${PORTSDIR}/audio/mpg123
+CMAKE_ARGS+= -DWithPluginMpg123Decoder=1
+PLIST_SUB+= MPG123=""
+.else
+CMAKE_ARGS+= -DWithPluginMpg123Decoder=0
+PLIST_SUB+= MPG123="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MLAME}
+LIB_DEPENDS+= mp3lame:${PORTSDIR}/audio/lame
+CMAKE_ARGS+= -DWithPluginLameEncoder=1
+PLIST_SUB+= LAME=""
+.else
+CMAKE_ARGS+= -DWithPluginLameEncoder=0
+PLIST_SUB+= LAME="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MWMA}
+CMAKE_ARGS+= -DWithPluginWmaDecoder=1
+PLIST_SUB+= WMA=""
+.else
+CMAKE_ARGS+= -DWithPluginWmaDecoder=0
+PLIST_SUB+= WMA="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MMAC4DECODER}
+CMAKE_ARGS+= -DWithPluginMac4Decoder=1
+PLIST_SUB+= MAC4=""
+.else
+CMAKE_ARGS+= -DWithPluginMac4Decoder=0
+PLIST_SUB+= MAC4="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MMACDECODER}
+LIB_DEPENDS+= mac:${PORTSDIR}/audio/mac
+CMAKE_ARGS+= -DWithPluginMacDecoder=1
+PLIST_SUB+= MAC=""
+.else
+CMAKE_ARGS+= -DWithPluginMacDecoder=0
+PLIST_SUB+= MAC="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MFLAC}
+LIB_DEPENDS+= FLAC:${PORTSDIR}/audio/flac
+CMAKE_ARGS+= -DWithPluginFlacDecoder=1
+PLIST_SUB+= FLAC=""
+.else
+CMAKE_ARGS+= -DWithPluginFlacDecoder=0
+PLIST_SUB+= FLAC="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MVORBIS}
+LIB_DEPENDS+= vorbisfile:${PORTSDIR}/audio/libvorbis
+CMAKE_ARGS+= -DWithPluginOggDecoder=1
+PLIST_SUB+= OGG=""
+.else
+CMAKE_ARGS+= -DWithPluginOggDecoder=0
+PLIST_SUB+= OGG="@comment "
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} 's|%%DATADIR%%|${DATADIR}|' \
+ ${WRKSRC}/CMakeLists.txt
+
+post-install:
+ @${ECHO_MSG}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_MSG}
+
+.include <bsd.port.mk>
diff --git a/audio/mous/distinfo b/audio/mous/distinfo
new file mode 100644
index 000000000000..bc15d401b457
--- /dev/null
+++ b/audio/mous/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mous-1.1a.tar.gz) = 55826f30567a11d1c54af335b4290329b680c9e64ef9f46c0b7e3a4427414b56
+SIZE (mous-1.1a.tar.gz) = 677884
diff --git a/audio/mous/files/patch-CMakeLists.txt b/audio/mous/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..a0aaf22051bc
--- /dev/null
+++ b/audio/mous/files/patch-CMakeLists.txt
@@ -0,0 +1,20 @@
+--- CMakeLists.txt.orig 2012-06-15 04:46:40.000000000 +0200
++++ CMakeLists.txt 2012-07-18 17:04:03.462575000 +0200
+@@ -292,7 +292,7 @@
+ RUNTIME DESTINATION bin)
+ install(
+ CODE "file(GLOB TRANSLATION_FILES \"${PROJECT_BINARY_DIR}/*.qm\")"
+- CODE "file(INSTALL \${TRANSLATION_FILES} DESTINATION ${CMAKE_INSTALL_PREFIX}/share/mous/qt)"
++ CODE "file(INSTALL \${TRANSLATION_FILES} DESTINATION %%DATADIR%%/qt)"
+ )
+ endif()
+
+@@ -307,7 +307,7 @@
+ )
+
+ file(GLOB RESOURCE_FILES "${MOUS_SOURCE_DIR}/resource/*")
+-install(DIRECTORY ${RESOURCE_FILES} DESTINATION share/mous)
++install(DIRECTORY ${RESOURCE_FILES} DESTINATION %%DATADIR%%)
+
+ #==== Messages ====#
+ message("CMake: " ${CMAKE_VERSION})
diff --git a/audio/mous/files/pkg-message.in b/audio/mous/files/pkg-message.in
new file mode 100644
index 000000000000..506cc73a1b3a
--- /dev/null
+++ b/audio/mous/files/pkg-message.in
@@ -0,0 +1,5 @@
+Note:
+For mous-ncurses frontend, you can check its usage
+with 'H' after starting.
+
+Bug report: shen.elf@gmail.com
diff --git a/audio/mous/pkg-descr b/audio/mous/pkg-descr
new file mode 100644
index 000000000000..1c6e49202112
--- /dev/null
+++ b/audio/mous/pkg-descr
@@ -0,0 +1,3 @@
+Mous is a simpe yet powerful audio player.
+
+WWW: https://github.com/0x02/mous
diff --git a/audio/mous/pkg-plist b/audio/mous/pkg-plist
new file mode 100644
index 000000000000..c3dcce6d6ef7
--- /dev/null
+++ b/audio/mous/pkg-plist
@@ -0,0 +1,80 @@
+%%NCURSES%%bin/mous-ncurses
+%%QT4%%bin/mous-qt
+%%SDK%%include/mous/charset/CharsetConvInf.h
+%%SDK%%include/mous/charset/ICharsetConv.h
+%%SDK%%include/mous/core/IConvTask.h
+%%SDK%%include/mous/core/IConvTaskFactory.h
+%%SDK%%include/mous/core/IMediaLoader.h
+%%SDK%%include/mous/core/IPlayer.h
+%%SDK%%include/mous/core/IPluginAgent.h
+%%SDK%%include/mous/core/IPluginManager.h
+%%SDK%%include/mous/core/ITagParserFactory.h
+%%SDK%%include/mous/plugin/IDecoder.h
+%%SDK%%include/mous/plugin/IEncoder.h
+%%SDK%%include/mous/plugin/IEventWatcher.h
+%%SDK%%include/mous/plugin/IFilter.h
+%%SDK%%include/mous/plugin/IMediaPack.h
+%%SDK%%include/mous/plugin/IRenderer.h
+%%SDK%%include/mous/plugin/ITagParser.h
+%%SDK%%include/mous/scx/BufObj.hpp
+%%SDK%%include/mous/scx/CharsetHelper.hpp
+%%SDK%%include/mous/scx/CondVar.hpp
+%%SDK%%include/mous/scx/ConfigFile.hpp
+%%SDK%%include/mous/scx/Conv.hpp
+%%SDK%%include/mous/scx/Dir.hpp
+%%SDK%%include/mous/scx/Env.hpp
+%%SDK%%include/mous/scx/FileHelper.hpp
+%%SDK%%include/mous/scx/FileInfo.hpp
+%%SDK%%include/mous/scx/Function.hpp
+%%SDK%%include/mous/scx/IconvHelper.hpp
+%%SDK%%include/mous/scx/LPVBuffer.hpp
+%%SDK%%include/mous/scx/Mutex.hpp
+%%SDK%%include/mous/scx/PVBuffer.hpp
+%%SDK%%include/mous/scx/RunTimer.hpp
+%%SDK%%include/mous/scx/SemVar.hpp
+%%SDK%%include/mous/scx/Signal.hpp
+%%SDK%%include/mous/scx/Singleton.hpp
+%%SDK%%include/mous/scx/Socket.hpp
+%%SDK%%include/mous/scx/SoftSemVar.hpp
+%%SDK%%include/mous/scx/TaskSchedule.hpp
+%%SDK%%include/mous/scx/Thread.hpp
+%%SDK%%include/mous/scx/UniPinYin.hpp
+%%SDK%%include/mous/util/AudioMode.h
+%%SDK%%include/mous/util/ErrorCode.h
+%%SDK%%include/mous/util/MediaItem.h
+%%SDK%%include/mous/util/MediaTag.h
+%%SDK%%include/mous/util/Option.h
+%%SDK%%include/mous/util/Playlist.h
+%%SDK%%include/mous/util/PlaylistSerializer.h
+%%SDK%%include/mous/util/PluginDef.h
+%%SDK%%include/mous/util/PluginHelper.h
+%%SDK%%include/mous/util/PluginOption.h
+lib/libMousCore.so
+%%ALSA%%lib/mous/libAlsaRenderer.so
+%%AO%%lib/mous/libAoRenderer.so
+%%CUE%%lib/mous/libCuePack.so
+%%FAAC%%lib/mous/libFaacEncoder.so
+%%FAAD%%lib/mous/libFaadDecoder.so
+%%FLAC%%lib/mous/libFlacDecoder.so
+%%LAME%%lib/mous/libLameEncoder.so
+%%MAC4%%lib/mous/libMac4Decoder.so
+%%MAC%%lib/mous/libMacDecoder.so
+%%OGG%%lib/mous/libOggDecoder.so
+%%MPG123%%lib/mous/libMpg123Decoder.so
+%%OSS%%lib/mous/libOssRenderer.so
+%%TAGLIB%%lib/mous/libTagLibParser.so
+%%WAVDECODER%%lib/mous/libWavDecoder.so
+%%WAVENCODER%%lib/mous/libWavEncoder.so
+%%WMA%%lib/mous/libWmaDecoder.so
+%%DATADIR%%/pinyin/unipy.map
+%%QT4%%share/mous/qt/mous-qt_zh_CN.qm
+@dirrm lib/mous
+@dirrm share/mous/pinyin
+%%QT4%%@dirrm share/mous/qt
+@dirrm share/mous/
+%%SDK%%@dirrm include/mous/charset
+%%SDK%%@dirrm include/mous/core
+%%SDK%%@dirrm include/mous/plugin
+%%SDK%%@dirrm include/mous/scx
+%%SDK%%@dirrm include/mous/util
+%%SDK%%@dirrm include/mous