aboutsummaryrefslogtreecommitdiff
path: root/audio/mous
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2016-04-18 17:19:00 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2016-04-18 17:19:00 +0000
commite955bdb14b9cf383e2a5ca32f870a323a284d590 (patch)
tree3d737dfbc9b883a839267ed229cb1e9c7d7ff0b5 /audio/mous
parent92934501d3d4438772918d52fc04b99e0e38dcbb (diff)
downloadports-e955bdb14b9cf383e2a5ca32f870a323a284d590.tar.gz
ports-e955bdb14b9cf383e2a5ca32f870a323a284d590.zip
- Fix build with the new API of libcue, after revision r413589
- Bump PORTREVISION
Notes
Notes: svn path=/head/; revision=413590
Diffstat (limited to 'audio/mous')
-rw-r--r--audio/mous/Makefile2
-rw-r--r--audio/mous/files/patch-plugins_CuePack_CuePack.cpp11
-rw-r--r--audio/mous/files/patch-plugins_CuePack_CuePack.h11
3 files changed, 23 insertions, 1 deletions
diff --git a/audio/mous/Makefile b/audio/mous/Makefile
index aa50cc109e79..de1704fe88e7 100644
--- a/audio/mous/Makefile
+++ b/audio/mous/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mous
PORTVERSION= 1.1a
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= audio
MASTER_SITES= GHC
diff --git a/audio/mous/files/patch-plugins_CuePack_CuePack.cpp b/audio/mous/files/patch-plugins_CuePack_CuePack.cpp
new file mode 100644
index 000000000000..d2ce06fe4ae2
--- /dev/null
+++ b/audio/mous/files/patch-plugins_CuePack_CuePack.cpp
@@ -0,0 +1,11 @@
+--- plugins/CuePack/CuePack.cpp.orig 2012-06-28 14:58:11 UTC
++++ plugins/CuePack/CuePack.cpp
+@@ -55,7 +55,7 @@ void CuePack::DumpCue(const string& dir,
+ string genre;
+ int year = -1;
+
+- char* data = NULL;
++ const char* data = NULL;
+ Cdtext* cdt = cd_get_cdtext(cd);
+ Rem* rem = cd_get_rem(cd);
+
diff --git a/audio/mous/files/patch-plugins_CuePack_CuePack.h b/audio/mous/files/patch-plugins_CuePack_CuePack.h
new file mode 100644
index 000000000000..b14cae07ca47
--- /dev/null
+++ b/audio/mous/files/patch-plugins_CuePack_CuePack.h
@@ -0,0 +1,11 @@
+--- plugins/CuePack/CuePack.h.orig 2012-06-28 14:58:11 UTC
++++ plugins/CuePack/CuePack.h
+@@ -1,7 +1,6 @@
+ #include <plugin/IMediaPack.h>
+ extern "C" {
+-#include <libcue-1.4/libcue/libcue.h>
+-#include <libcue-1.4/libcue/cd.h>
++#include <libcue.h>
+ }
+ using namespace std;
+ using namespace mous;