aboutsummaryrefslogtreecommitdiff
path: root/audio/mp3blaster/Makefile
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2017-06-06 21:20:56 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2017-06-06 21:20:56 +0000
commita41997696e63d47bc260b499c65521c7c94916fd (patch)
treee913554446e08d8bc4f169b003ac72cb2a0315db /audio/mp3blaster/Makefile
parent24ce9f471d3e6c19e47ef99be1f17b3b466cb6e5 (diff)
downloadports-a41997696e63d47bc260b499c65521c7c94916fd.tar.gz
ports-a41997696e63d47bc260b499c65521c7c94916fd.zip
Update to 3.2.6
While here: - Add license - Add the missing SDL option to OPTIONS_DEFINE - Fix ESOUND option - Fix build of NAS option with Clang < 4.0 - The configure script says this configure: WARNING: unrecognized options: --with-cxxflags so remove it from CONFIGURE_ARGS - Regenerate patches Changes: http://www.mp3blaster.org/2017/05/its-only-been-8-years.html PR: 219808 Approved by: lme (mentor), novel (maintainer) Differential Revision: https://reviews.freebsd.org/D11076
Notes
Notes: svn path=/head/; revision=442807
Diffstat (limited to 'audio/mp3blaster/Makefile')
-rw-r--r--audio/mp3blaster/Makefile17
1 files changed, 7 insertions, 10 deletions
diff --git a/audio/mp3blaster/Makefile b/audio/mp3blaster/Makefile
index 9aa02e374e48..61b44c87d27f 100644
--- a/audio/mp3blaster/Makefile
+++ b/audio/mp3blaster/Makefile
@@ -2,23 +2,20 @@
# $FreeBSD$
PORTNAME= mp3blaster
-PORTVERSION= 3.2.5
-PORTREVISION= 6
+PORTVERSION= 3.2.6
CATEGORIES= audio
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= novel@FreeBSD.org
COMMENT= MP3 console ncurses-based player
-USES= gmake ncurses
-GNU_CONFIGURE= yes
-WANT_GNOME= yes
-CONFIGURE_ARGS= --with-cxxflags="${CXXFLAGS}"
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
-CPPFLAGS+= -I${LOCALBASE}/include -DHAVE_DECL_GETOPT
-LDFLAGS+= -lpthread -L${LOCALBASE}/lib
+USES= gmake localbase:ldflags ncurses
+GNU_CONFIGURE= yes
-OPTIONS_DEFINE= LIRC NAS SIDPLAY VORBIS DOCS ESOUND
+OPTIONS_DEFINE= DOCS ESOUND LIRC NAS SDL SIDPLAY VORBIS
OPTIONS_DEFAULT= SIDPLAY VORBIS
SIDPLAY_DESC= Sidplayer support
@@ -41,7 +38,7 @@ NAS_LIB_DEPENDS= libaudio.so:audio/nas
NAS_LDFLAGS= -laudio
ESOUND_CONFIGURE_WITH= esd
-ESOUND_GNOME= esound
+ESOUND_USE= GNOME=esound
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local/share/mp3blaster/win2koi.tbl|${DATADIR}/charmap/win2koi.tbl|' \