aboutsummaryrefslogtreecommitdiff
path: root/audio/mp3c
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-01-19 12:38:55 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-01-19 12:38:55 +0000
commit769fd54d109d60ed57ae699e29457fdf65396733 (patch)
tree9cc36d736f3ffdb83bae832abcc852f67d4ee08b /audio/mp3c
parent55164b213add47a888e1d177eb568fd682b5ba89 (diff)
downloadports-769fd54d109d60ed57ae699e29457fdf65396733.tar.gz
ports-769fd54d109d60ed57ae699e29457fdf65396733.zip
New port MP3c, a cd to mp3 converter with an ASCII frontend:
MP3c is a nice tool for converting cd's to mp3. PR: ports/40461 Submitted by: Joris Vandalon <joris@vandalon.nl>
Notes
Notes: svn path=/head/; revision=73478
Diffstat (limited to 'audio/mp3c')
-rw-r--r--audio/mp3c/Makefile29
-rw-r--r--audio/mp3c/distinfo1
-rw-r--r--audio/mp3c/files/patch-zz51
-rw-r--r--audio/mp3c/pkg-comment1
-rw-r--r--audio/mp3c/pkg-descr1
-rw-r--r--audio/mp3c/pkg-plist7
6 files changed, 90 insertions, 0 deletions
diff --git a/audio/mp3c/Makefile b/audio/mp3c/Makefile
new file mode 100644
index 000000000000..a497fcb39583
--- /dev/null
+++ b/audio/mp3c/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: oneko
+# Date created: 5 December 1994
+# Whom: asami
+#
+# $FreeBSD$
+#
+
+PORTNAME= mp3c
+PORTVERSION= 0.27
+CATEGORIES= audio
+MASTER_SITES= ftp://excelsior.kullen.rwth-aachen.de/pub/linux/wspse/
+
+MAINTAINER= wiebel@FreeBSD.nl
+
+RUN_DEPENDS= dagrab:${PORTSDIR}/audio/dagrab \
+ gogo:${PORTSDIR}/audio/gogo \
+ id3tool:${PORTSDIR}/audio/id3tool
+
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS="--prefix=${PREFIX}"
+
+MAN1= mp3c.1
+MANCOMPRESSED= no
+
+post-install:
+ ${FETCH_CMD} -o ${LOCALBASE}/bin/cdrip.sh http://www.cobweb.nl/wiebel/cdrip.sh
+ ${CHMOD} +x ${LOCALBASE}/bin/cdrip.sh
+
+.include <bsd.port.mk>
diff --git a/audio/mp3c/distinfo b/audio/mp3c/distinfo
new file mode 100644
index 000000000000..774230f00a01
--- /dev/null
+++ b/audio/mp3c/distinfo
@@ -0,0 +1 @@
+MD5 (mp3c-0.27.tar.gz) = 6afabf4c266effa498cd0bd7d25063c9
diff --git a/audio/mp3c/files/patch-zz b/audio/mp3c/files/patch-zz
new file mode 100644
index 000000000000..9643199cf1c9
--- /dev/null
+++ b/audio/mp3c/files/patch-zz
@@ -0,0 +1,51 @@
+--- src/conf.c.orig Wed Jun 27 19:01:29 2001
++++ src/conf.c Thu Jul 11 15:06:19 2002
+@@ -34,12 +34,12 @@
+ #include <sys/param.h>
+ #endif /* HAVE_SYS_PARAM_H */
+
+-#define FN_PATTERN "%7-%8.mp3" /* pattern for filename: %1 = artist,
++#define FN_PATTERN "%7-%2.mp3" /* pattern for filename: %1 = artist,
+ %2 = title, %3 = album, %4 = genre,
+ %5 = year, %6 = track, %7 = track (with leading zeros)
+ %8 = cddb-id
+ */
+-#define FN_PATTERN_MIX "%3/%1-%2.mp3"
++#define FN_PATTERN_MIX "%7-%2.mp3"
+ #define DEF_CDDB_SERVER "freedb.freedb.org:8880"
+
+ #ifdef CONF_CDDB_PATH
+@@ -49,18 +49,18 @@
+ #endif /* CONF_CDDB_PATH */
+
+ #if (defined(BSD) && BSD >= 199306)
+-#define DEF_CDROM_DEV "/dev/rcd0d"
++#define DEF_CDROM_DEV "/dev/acd0c"
+ #else
+-#define DEF_CDROM_DEV "/dev/cdrom"
++#define DEF_CDROM_DEV "/dev/acd0c"
+ #endif /* !(defined(BSD) && BSD >= 199306) */
+ #define DEF_TMP_FILE "/tmp/WSPse-MP3Creat.wav"
+ #define DEF_MP3_DIR "./" /* default dir for mp3s */
+ #define DEF_M3U_DIR "0" /* default dir for m3us */
+ #define DEF_MP3_INFO "id3tool -r \"%1\" -t \"%2\" -a \"%3\" -y \"%5\" -g %4 -n \"%6\" \"%7\""
+-#define DEF_CD_RIP_NF "cdparanoia -d \"%1\" %2 \"%3\""
+-#define DEF_CD_RIP_OF "cdparanoia -d \"%1\" %2 -"
+-#define DEF_MP3_ENC_NF "mp3enc \"%1\" \"%2\""
+-#define DEF_MP3_ENC_OF "mp3enc - \"%1\""
++#define DEF_CD_RIP_NF "dagrab -o 6 -n 32 -d %1 -f %3 %2"
++#define DEF_CD_RIP_OF "cdrip.sh %1 %2"
++#define DEF_MP3_ENC_NF "gogo %1 %2"
++#define DEF_MP3_ENC_OF "gogo /tmp/mp3 \"%1\" -b 160"
+ #define DEF_FRM_MULTI 214
+ #define DEF_M3U_PATTERN "%1-%3.m3u" /* pattern for m3u-playlist: %1 = artist,
+ i %2 = songtitle, %3 = album */
+@@ -165,7 +165,7 @@
+ fn_toupper = TRUE;
+ fn_mode = 1;
+ mp3_frame_mult = DEF_FRM_MULTI;
+- def_on_fly = FALSE;
++ def_on_fly = TRUE;
+ eased_char_hand = FALSE;
+ replace_slash_ch = '-';
+ rip_enc_ordered = FALSE;
diff --git a/audio/mp3c/pkg-comment b/audio/mp3c/pkg-comment
new file mode 100644
index 000000000000..85c09eda1a5d
--- /dev/null
+++ b/audio/mp3c/pkg-comment
@@ -0,0 +1 @@
+Use and enjoy
diff --git a/audio/mp3c/pkg-descr b/audio/mp3c/pkg-descr
new file mode 100644
index 000000000000..3c9238d7a89e
--- /dev/null
+++ b/audio/mp3c/pkg-descr
@@ -0,0 +1 @@
+MP3c is a cd to mp3c converter with a console frontend
diff --git a/audio/mp3c/pkg-plist b/audio/mp3c/pkg-plist
new file mode 100644
index 000000000000..feb6bc7d1566
--- /dev/null
+++ b/audio/mp3c/pkg-plist
@@ -0,0 +1,7 @@
+bin/mp3c
+bin/cdrip.sh
+share/locale/de/LC_MESSAGES/mp3c.mo
+share/locale/es/LC_MESSAGES/mp3c.mo
+share/locale/it/LC_MESSAGES/mp3c.mo
+share/locale/pl/LC_MESSAGES/mp3c.mo
+share/locale/pt/LC_MESSAGES/mp3c.mo