aboutsummaryrefslogtreecommitdiff
path: root/audio/mp3splt
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-02-23 00:35:53 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-02-23 00:35:53 +0000
commitaf4ea50ace9cde6ac63c58be933997f35f73c491 (patch)
treea956ae8bd6af9bb3a5ea58854069bddd808a3522 /audio/mp3splt
parenta7a42e39916a6a9ff27ff12aa9018c3189549989 (diff)
downloadports-af4ea50ace9cde6ac63c58be933997f35f73c491.tar.gz
ports-af4ea50ace9cde6ac63c58be933997f35f73c491.zip
- The author included files/patch-mp3.c to software and
rerolled the tarball - Fix typo in CONFIGURE_TARGET - Bump PORTREVISION PR: ports/63163 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=101783
Diffstat (limited to 'audio/mp3splt')
-rw-r--r--audio/mp3splt/Makefile6
-rw-r--r--audio/mp3splt/distinfo4
-rw-r--r--audio/mp3splt/files/patch-mp3.c14
3 files changed, 4 insertions, 20 deletions
diff --git a/audio/mp3splt/Makefile b/audio/mp3splt/Makefile
index 338ec900de1f..e0a092a7b24e 100644
--- a/audio/mp3splt/Makefile
+++ b/audio/mp3splt/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mp3splt
PORTVERSION= 2.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -16,8 +16,6 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= q@uni.de
COMMENT= Utility to split mp3 and ogg files (via CUE sheets)
-BROKEN= "Does not fetch"
-
LIB_DEPENDS= mad.2:${PORTSDIR}/audio/mad \
vorbis.3:${PORTSDIR}/audio/libvorbis \
ogg.5:${PORTSDIR}/audio/libogg
@@ -25,7 +23,7 @@ LIB_DEPENDS= mad.2:${PORTSDIR}/audio/mad \
GNU_CONFIGURE= yes
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib" \
CFLAGS="${CFLAGS} -I${LOCALBASE}/include"
-CONFIGURE_TARGET:= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/audio/mp3splt/distinfo b/audio/mp3splt/distinfo
index 8efbc7512379..7b6efe87bc01 100644
--- a/audio/mp3splt/distinfo
+++ b/audio/mp3splt/distinfo
@@ -1,2 +1,2 @@
-MD5 (mp3splt-2.0-src.tar.gz) = c092e4f4c1c9f12c83998b39bfe6138a
-SIZE (mp3splt-2.0-src.tar.gz) = 130025
+MD5 (mp3splt-2.0-src.tar.gz) = 2dadcfac92dd776d7bbc3e15e28b21bd
+SIZE (mp3splt-2.0-src.tar.gz) = 130041
diff --git a/audio/mp3splt/files/patch-mp3.c b/audio/mp3splt/files/patch-mp3.c
deleted file mode 100644
index 1fb687739581..000000000000
--- a/audio/mp3splt/files/patch-mp3.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- mp3.c.orig Sun Feb 1 09:28:27 2004
-+++ mp3.c Sun Feb 1 09:29:11 2004
-@@ -529,9 +529,10 @@
- {
- while (state->bytes < begin)
- {
-+ off_t to_read;
- if (feof(state->file_input))
- return -1;
-- off_t to_read = (begin - state->bytes);
-+ to_read = (begin - state->bytes);
- if (to_read > MAD_BSIZE)
- to_read = MAD_BSIZE;
- if ((state->data_len = fread(state->inputBuffer, 1, to_read, state->file_input))<=0)