aboutsummaryrefslogtreecommitdiff
path: root/audio/mp3stat/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-04-26 06:58:41 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-04-26 06:58:41 +0000
commitd678f5a419ef7ad370ed35753b1a41856316c6ac (patch)
tree9f9d4a40057f3ce603eaa031c64cd51d81764bb8 /audio/mp3stat/Makefile
parentff0810582db3c36a3da4661fe14f043b02adf8b2 (diff)
downloadports-d678f5a419ef7ad370ed35753b1a41856316c6ac.tar.gz
ports-d678f5a419ef7ad370ed35753b1a41856316c6ac.zip
- Update MASTER_SITES
- Add LICENSE - Add MAKE_JOBS_SAFE - Support CXX properly PR: 177558 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=316579
Diffstat (limited to 'audio/mp3stat/Makefile')
-rw-r--r--audio/mp3stat/Makefile35
1 files changed, 15 insertions, 20 deletions
diff --git a/audio/mp3stat/Makefile b/audio/mp3stat/Makefile
index e028a7519be1..f3aa1e8ad2dd 100644
--- a/audio/mp3stat/Makefile
+++ b/audio/mp3stat/Makefile
@@ -1,60 +1,55 @@
-# ex:ts=8
-# Ports collection makefile for: mp3stat
-# Date created: Mar 20, 2002
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= mp3stat
PORTVERSION= 2.6.01
PORTREVISION= 11
CATEGORIES= audio
MASTER_SITES= https://signal-lost.homeip.net/files/ \
- http://www.alaskaparadise.com/freebsd/
+ http://www.sourcefiles.org/Multimedia/MP3/Tools/Processing/
DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Read information about mp3s and oggs bitstream
+LICENSE= GPLv2
+
+OPTIONS_DEFINE= VORBIS DOCS
+OPTIONS_DEFAULT= VORBIS
+
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_GNOME= gtk20
USE_GMAKE= yes
-MAKE_ARGS= CXX="${CXX}" CXXFLAGS="${CXXFLAGS}"
+MAKE_JOBS_SAFE= yes
+CXX+= -I${LOCALBASE}/include -L${LOCALBASE}/lib \
+ -Wl,--rpath,${LOCALBASE}/lib
+
+PORTDOCS= README
PLIST_FILES= bin/mp3stat \
lib/mp3stat/input_mp3.so \
lib/mp3stat/ui_gtk2.so \
lib/mp3stat/ui_console.so
PLIST_DIRS= lib/mp3stat
-CXX+= -I${LOCALBASE}/include -L${LOCALBASE}/lib \
- -Wl,--rpath,${LOCALBASE}/lib
-
-OPTIONS_DEFINE= VORBIS DOCS
-OPTIONS_DEFAULT= VORBIS
-
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MVORBIS}
-LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis
+LIB_DEPENDS+= vorbis:${PORTSDIR}/audio/libvorbis
PLIST_FILES+= lib/mp3stat/input_vorb.so
.else
MAKE_ARGS+= VORBIS=""
.endif
-.if ${PORT_OPTIONS:MDOCS}
-PORTDOCS= README
-.endif
-
post-patch:
@${FIND} ${WRKSRC} -name "Makefile*" | ${XARGS} ${REINPLACE_CMD} -e \
's|@$${CXX}|$${CXX}|g ; \
s|-ldl|-lz|g ; \
s|-lc||g ; \
s|-Wl,-soname,.*\.so\.1||g ; \
- s|-fpic|-fPIC|g'
+ s|-fpic|-fPIC|g ; \
+ s|^CXX|#CXX|g'
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/mp3stat ${PREFIX}/bin