aboutsummaryrefslogtreecommitdiff
path: root/audio/mp3stat/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-06-01 09:38:09 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-06-01 09:38:09 +0000
commitf40f4381dbbeca19d5a3802f5f4955d93d768bda (patch)
treedfe994ab68480c0ef60d2f1c390610d92bdf9487 /audio/mp3stat/Makefile
parent170a76404d55c6d2aedb2547ffc29c0cf507899a (diff)
downloadports-f40f4381dbbeca19d5a3802f5f4955d93d768bda.tar.gz
ports-f40f4381dbbeca19d5a3802f5f4955d93d768bda.zip
Convert to new options framework
Notes
Notes: svn path=/head/; revision=297936
Diffstat (limited to 'audio/mp3stat/Makefile')
-rw-r--r--audio/mp3stat/Makefile18
1 files changed, 10 insertions, 8 deletions
diff --git a/audio/mp3stat/Makefile b/audio/mp3stat/Makefile
index e13741d97c1a..10aca00f9120 100644
--- a/audio/mp3stat/Makefile
+++ b/audio/mp3stat/Makefile
@@ -32,18 +32,20 @@ PLIST_DIRS= lib/mp3stat
CXX+= -I${LOCALBASE}/include -L${LOCALBASE}/lib \
-Wl,--rpath,${LOCALBASE}/lib
-OPTIONS= VORBIS "Ogg/Vorbis support" on
+OPTIONS_DEFINE= VORBIS DOCS
+OPTIONS_DEFAULT= VORBIS
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if defined(WITHOUT_VORBIS)
-MAKE_ARGS+= VORBIS=""
-.else
+.if ${PÖRT_OPTIONS:MVORBIS}
LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis
PLIST_FILES+= lib/mp3stat/input_vorb.so
+.else
+MAKE_ARGS+= VORBIS=""
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
PORTDOCS= README
.endif
@@ -61,12 +63,12 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/ui/gtk/ui_gtk2.so ${PREFIX}/lib/mp3stat
${INSTALL_DATA} ${WRKSRC}/ui/console/ui_console.so ${PREFIX}/lib/mp3stat
${INSTALL_DATA} ${WRKSRC}/input/mp3/input_mp3.so ${PREFIX}/lib/mp3stat
-.if !defined(WITHOUT_VORBIS)
+.if ${PORT_OPTIONS:MVORBIS}
${INSTALL_DATA} ${WRKSRC}/input/vorbis/input_vorb.so ${PREFIX}/lib/mp3stat
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>