aboutsummaryrefslogtreecommitdiff
path: root/audio/mp3wrap
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2003-06-14 08:17:35 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2003-06-14 08:17:35 +0000
commit976649a8f53cc215e271b8eff12bd95b8ddb06b2 (patch)
tree466d1604b7f74dbdcc718df0047b8b04c987249e /audio/mp3wrap
parentdd97aea9542b7ae1a80a95a53a503fbd2c06ada0 (diff)
downloadports-976649a8f53cc215e271b8eff12bd95b8ddb06b2.tar.gz
ports-976649a8f53cc215e271b8eff12bd95b8ddb06b2.zip
Add mp3wrap.
With mp3wrap you can easily concatenate multiple mp3 files. You can even add non-mp3 content. PR: ports/52900 Submitted by: Ulrich Spoerlein <q@uni.de>
Notes
Notes: svn path=/head/; revision=82977
Diffstat (limited to 'audio/mp3wrap')
-rw-r--r--audio/mp3wrap/Makefile24
-rw-r--r--audio/mp3wrap/distinfo1
-rw-r--r--audio/mp3wrap/files/patch-aa11
-rw-r--r--audio/mp3wrap/pkg-descr7
-rw-r--r--audio/mp3wrap/pkg-plist1
5 files changed, 44 insertions, 0 deletions
diff --git a/audio/mp3wrap/Makefile b/audio/mp3wrap/Makefile
new file mode 100644
index 000000000000..a88cc56b950a
--- /dev/null
+++ b/audio/mp3wrap/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: audio/mp3wrap
+# Date created: 30.05.2003
+# Whom: Ulrich Spoerlein <q@uni.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mp3wrap
+PORTVERSION= 0.5
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+
+MAINTAINER= q@uni.de
+COMMENT= Utility to merge mp3 files (and other formats)
+
+GNU_CONFIGURE= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+MAN1= mp3wrap.1
+
+.include <bsd.port.mk>
diff --git a/audio/mp3wrap/distinfo b/audio/mp3wrap/distinfo
new file mode 100644
index 000000000000..bb3107879947
--- /dev/null
+++ b/audio/mp3wrap/distinfo
@@ -0,0 +1 @@
+MD5 (mp3wrap-0.5-src.tar.gz) = 096b46295cbe3ee2f02ca7792517dc36
diff --git a/audio/mp3wrap/files/patch-aa b/audio/mp3wrap/files/patch-aa
new file mode 100644
index 000000000000..34a0baca1fe8
--- /dev/null
+++ b/audio/mp3wrap/files/patch-aa
@@ -0,0 +1,11 @@
+--- crc.c.orig Mon Jun 2 20:41:23 2003
++++ crc.c Mon Jun 2 20:43:24 2003
+@@ -25,7 +25,7 @@
+
+ #include <stdio.h>
+ #include <stdlib.h>
+-
++#include <sys/types.h>
+ #include "crc.h"
+
+ static const u_int32_t crctab[256] = {
diff --git a/audio/mp3wrap/pkg-descr b/audio/mp3wrap/pkg-descr
new file mode 100644
index 000000000000..73c6e71b2624
--- /dev/null
+++ b/audio/mp3wrap/pkg-descr
@@ -0,0 +1,7 @@
+Mp3Wrap is a command-line utility that wraps two or more mp3 files in one
+single large playable mp3, without losing filenames and ID3 informations (and
+without need of decoding/encoding). Also with the possibility of including
+other non mp3 files, such as PlayLists, info files, cover images, inside the
+mp3.
+
+WWW: http://mp3wrap.sourceforge.net/
diff --git a/audio/mp3wrap/pkg-plist b/audio/mp3wrap/pkg-plist
new file mode 100644
index 000000000000..c536fb69b52c
--- /dev/null
+++ b/audio/mp3wrap/pkg-plist
@@ -0,0 +1 @@
+bin/mp3wrap