aboutsummaryrefslogtreecommitdiff
path: root/audio/mpdscribble
diff options
context:
space:
mode:
authorLarry Rosenman <ler@FreeBSD.org>2017-05-01 23:49:34 +0000
committerLarry Rosenman <ler@FreeBSD.org>2017-05-01 23:49:34 +0000
commit33bf1a1d429173d1fe63e6da430ea8b3c31209b2 (patch)
treeb7581fcf82e2c2e1ab55206fbd794c6f4a3873f7 /audio/mpdscribble
parent73cea91f9d119b4f323fae2411d6f4b3ca472147 (diff)
downloadports-33bf1a1d429173d1fe63e6da430ea8b3c31209b2.tar.gz
ports-33bf1a1d429173d1fe63e6da430ea8b3c31209b2.zip
[revive] audio/mpdscribble: fix for unfetchable
Revive port, fix ${PORTSDIR} for ftp/curl, give MAINTAINER'ship to submitter. PR: 213160 Submitted by: freebsdbugs@tungol.org Approved by: adamw (mentor, implicit)
Notes
Notes: svn path=/head/; revision=439917
Diffstat (limited to 'audio/mpdscribble')
-rw-r--r--audio/mpdscribble/Makefile40
-rw-r--r--audio/mpdscribble/distinfo2
-rw-r--r--audio/mpdscribble/files/mpdscribble.in26
-rw-r--r--audio/mpdscribble/pkg-descr4
-rw-r--r--audio/mpdscribble/pkg-plist6
5 files changed, 78 insertions, 0 deletions
diff --git a/audio/mpdscribble/Makefile b/audio/mpdscribble/Makefile
new file mode 100644
index 000000000000..b25070c958c3
--- /dev/null
+++ b/audio/mpdscribble/Makefile
@@ -0,0 +1,40 @@
+# Created by: Stepan Zastupov [RedChrom] <redchrom@gmail.com>
+# $FreeBSD$
+
+PORTNAME= mpdscribble
+PORTVERSION= 0.22
+PORTREVISION= 1
+CATEGORIES= audio
+MASTER_SITES= http://www.musicpd.org/download/${PORTNAME}/${PORTVERSION}/
+
+MAINTAINER= freebsdbugs@tungol.org
+COMMENT= Musicpd last.fm client
+
+LICENSE= GPLv2
+
+LIB_DEPENDS+= libmpdclient.so:audio/libmpdclient
+
+USES= pkgconfig tar:bzip2
+USE_GNOME= glib20
+GNU_CONFIGURE= yes
+USE_RC_SUBR= mpdscribble
+
+OPTIONS_DEFINE= SOUP DOCS
+SOUP_DESC= Use libsoup instead of libcurl
+
+SOUP_LIB_DEPENDS= libsoup-2.4.so:${PORTSDIR}/devel/libsoup
+SOUP_CONFIGURE_ON= --with-http-client=soup
+SOUP_LIB_DEPENDS_OFF= libcurl.so:ftp/curl
+SOUP_CONFIGURE_OFF= --with-http-client=curl
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/mpdscribble ${STAGEDIR}${PREFIX}/bin/mpdscribble
+ ${INSTALL_MAN} ${WRKSRC}/doc/mpdscribble.1 ${STAGEDIR}${MANPREFIX}/man/man1/mpdscribble.1
+ ${INSTALL_DATA} ${WRKSRC}/doc/mpdscribble.conf ${STAGEDIR}${PREFIX}/etc/mpdscribble.conf.sample
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for file in AUTHORS NEWS README
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}${DOCSDIR}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/audio/mpdscribble/distinfo b/audio/mpdscribble/distinfo
new file mode 100644
index 000000000000..0ec6694c7f69
--- /dev/null
+++ b/audio/mpdscribble/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mpdscribble-0.22.tar.bz2) = 1cde2b5f8c70f0e3e6f059d01bf0b0f2eac2b29fbcd14b01a8a5103e603feb41
+SIZE (mpdscribble-0.22.tar.bz2) = 116981
diff --git a/audio/mpdscribble/files/mpdscribble.in b/audio/mpdscribble/files/mpdscribble.in
new file mode 100644
index 000000000000..d7e62fb4ed53
--- /dev/null
+++ b/audio/mpdscribble/files/mpdscribble.in
@@ -0,0 +1,26 @@
+#!/bin/sh
+#
+
+# PROVIDE: mpdscribble
+# REQUIRE: LOGIN
+# KEYWORD: shutdown
+
+# Add the following line to /etc/rc.conf to enable mpdscribble:
+#
+#mpdscribble_enable="YES"
+
+. /etc/rc.subr
+
+name=mpdscribble
+rcvar=mpdscribble_enable
+
+command=%%PREFIX%%/bin/mpdscribble
+
+load_rc_config $name
+
+: ${mpdscribble_enable="NO"}
+: ${mpdscribble_user="nobody"}
+
+command_args="--daemon-user ${mpdscribble_user}"
+
+run_rc_command "$1"
diff --git a/audio/mpdscribble/pkg-descr b/audio/mpdscribble/pkg-descr
new file mode 100644
index 000000000000..9bcdc1c6db46
--- /dev/null
+++ b/audio/mpdscribble/pkg-descr
@@ -0,0 +1,4 @@
+mpdscribble is a music player daemon client which submits information about
+tracks being played to Last.fm (formerly audioscrobbler).
+
+WWW: http://mpd.wikia.com/wiki/Client:Mpdscribble
diff --git a/audio/mpdscribble/pkg-plist b/audio/mpdscribble/pkg-plist
new file mode 100644
index 000000000000..85a41e7a16ad
--- /dev/null
+++ b/audio/mpdscribble/pkg-plist
@@ -0,0 +1,6 @@
+bin/mpdscribble
+@sample etc/mpdscribble.conf.sample
+man/man1/mpdscribble.1.gz
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/NEWS