aboutsummaryrefslogtreecommitdiff
path: root/audio/mpdscribble
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-04-30 21:16:53 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-04-30 21:16:53 +0000
commit43e0b7238a9e597ca22856b242e789984371c32a (patch)
tree2a8173832fb8557a29d43a60f5835fcc247a21b0 /audio/mpdscribble
parent8ff604a26b61988a318e4e93f66b7e010ee9ca00 (diff)
downloadports-43e0b7238a9e597ca22856b242e789984371c32a.tar.gz
ports-43e0b7238a9e597ca22856b242e789984371c32a.zip
- Update to 0.17
PR: 133341 Submitted by: Julien Laffaye <kimelto@gmail.com> Approved by: maintainer timeout
Notes
Notes: svn path=/head/; revision=233005
Diffstat (limited to 'audio/mpdscribble')
-rw-r--r--audio/mpdscribble/Makefile29
-rw-r--r--audio/mpdscribble/distinfo6
-rw-r--r--audio/mpdscribble/files/mpdscribble.in26
-rw-r--r--audio/mpdscribble/files/patch-setup.sh43
-rw-r--r--audio/mpdscribble/pkg-descr4
-rw-r--r--audio/mpdscribble/pkg-plist8
6 files changed, 58 insertions, 58 deletions
diff --git a/audio/mpdscribble/Makefile b/audio/mpdscribble/Makefile
index ec65b7336dfa..59cf307b793e 100644
--- a/audio/mpdscribble/Makefile
+++ b/audio/mpdscribble/Makefile
@@ -6,24 +6,33 @@
#
PORTNAME= mpdscribble
-PORTVERSION= 0.2.12
-PORTREVISION= 3
+PORTVERSION= 0.17
CATEGORIES= audio
-MASTER_SITES= http://www.frob.nl/projects/scribble/ \
- http://www.carpetsmoker.net/distfiles/ \
- http://www.xs4all.nl/~tournoij/distfiles/ \
- http://www.rwxrwxrwx.net/distfiles/
+MASTER_SITES= SF/musicpd
MAINTAINER= carpetsmoker@rwxrwxrwx.net
COMMENT= Musicpd last.fm client
-LIB_DEPENDS= soup:${PORTSDIR}/devel/libsoup22
+LIB_DEPENDS= soup:${PORTSDIR}/devel/libsoup
+USE_BZIP2= yes
+USE_GNOME= glib20 pkgconfig
GNU_CONFIGURE= yes
MAN1= mpdscribble.1
-PLIST_FILES= bin/mpdscribble bin/mpdscribble-setup
-post-install:
- @${INSTALL_SCRIPT} ${WRKSRC}/setup.sh ${PREFIX}/bin/mpdscribble-setup
+USE_RC_SUBR= mpdscribble
+
+do-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for i in README AUTHORS NEWS
+ @${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+ @[ -f ${PREFIX}/etc/mpdscribble.conf ] || \
+ ${INSTALL_DATA} ${WRKSRC}/doc/mpdscribble.conf ${PREFIX}/etc/mpdscribble.conf
+ @${INSTALL_DATA} ${WRKSRC}/doc/mpdscribble.conf ${PREFIX}/etc/mpdscribble.conf.sample
+ @${INSTALL_PROGRAM} ${WRKSRC}/src/mpdscribble ${PREFIX}/bin/mpdscribble
+ @${INSTALL_MAN} ${WRKSRC}/doc/mpdscribble.1 ${PREFIX}/man/man1/mpdscribble.1
.include <bsd.port.mk>
diff --git a/audio/mpdscribble/distinfo b/audio/mpdscribble/distinfo
index 51fc957bddc7..5125acb5146f 100644
--- a/audio/mpdscribble/distinfo
+++ b/audio/mpdscribble/distinfo
@@ -1,3 +1,3 @@
-MD5 (mpdscribble-0.2.12.tar.gz) = 7f0e976e7a066df0ddf21f3f4041ef6a
-SHA256 (mpdscribble-0.2.12.tar.gz) = bc15d633abca93d245c013e2f9ce40bc69a01c45da0a63423c437d891f404768
-SIZE (mpdscribble-0.2.12.tar.gz) = 140039
+MD5 (mpdscribble-0.17.tar.bz2) = af8e565c8b5c0e8e5363bca35df0438a
+SHA256 (mpdscribble-0.17.tar.bz2) = 228a66b7544228cabef9df4cbc44f9704c26e1f4a3ed7792f81abbf6366fd416
+SIZE (mpdscribble-0.17.tar.bz2) = 124652
diff --git a/audio/mpdscribble/files/mpdscribble.in b/audio/mpdscribble/files/mpdscribble.in
new file mode 100644
index 000000000000..af7b046bb095
--- /dev/null
+++ b/audio/mpdscribble/files/mpdscribble.in
@@ -0,0 +1,26 @@
+#!/bin/sh
+#
+
+# PROVIDE: mpdscribble
+# REQUIRE: LOGIN
+# KEYWORD: shutdown
+
+# Add the following line to /etc/rc.conf to enable mpdscribble:
+#
+#mpdscribble_enable="YES"
+
+. %%RC_SUBR%%
+
+name=mpdscribble
+rcvar=`set_rcvar`
+
+command=%%PREFIX%%/bin/mpdscribble
+
+load_rc_config $name
+
+: ${mpdscribble_enable="NO"}
+: ${mpdscribble_user="nobody"}
+
+command_args="--daemon-user ${mpdscribble_user}"
+
+run_rc_command "$1"
diff --git a/audio/mpdscribble/files/patch-setup.sh b/audio/mpdscribble/files/patch-setup.sh
deleted file mode 100644
index aaedc2cd6381..000000000000
--- a/audio/mpdscribble/files/patch-setup.sh
+++ /dev/null
@@ -1,43 +0,0 @@
---- setup.sh.orig 2005-04-17 16:53:46.000000000 +0200
-+++ setup.sh 2008-07-22 02:30:33.000000000 +0200
-@@ -1,6 +1,6 @@
- #!/bin/sh
-
--if [ $UID = "0" ]; then
-+if [ $(id -u) -eq 0 ]; then
- echo "user root, system-wide installation assumed."
- echo
- CONF_DIR=/etc
-@@ -25,8 +25,8 @@
- echo "log file: $LOG"
- echo
- echo "press ctrl-c to cancel if this is not intended."
--echo "continue..."
--read -s
-+echo "press enter to continue..."
-+read junk
-
- mkdir -p $CONF_DIR
- mkdir -p $CACHE_DIR
-@@ -35,17 +35,19 @@
- echo -n "Please enter your audioscrobbler username: "
- read -e USERNAME
- echo -n "and password: "
--read -s -e PASSWORD
-+read -e PASSWORD
-
- echo "username = $USERNAME" > $LOGIN
- chmod 600 $LOGIN
--MD5=`echo -n $PASSWORD | md5sum | awk '{print $1}'`
-+MD5=$(echo -n $PASSWORD | md5 -q)
- echo "password = $MD5" >> $LOGIN
-
- echo "cache = $CACHE" >> $LOGIN
- echo "log = $LOG" >> $LOGIN
- echo "verbose = 2" >> $LOGIN
-
-+touch $CACHE
-+
- echo ""
- echo "Thank you."
- echo "You can try running mpdscribble now."
diff --git a/audio/mpdscribble/pkg-descr b/audio/mpdscribble/pkg-descr
index eaf92b86daac..9bcdc1c6db46 100644
--- a/audio/mpdscribble/pkg-descr
+++ b/audio/mpdscribble/pkg-descr
@@ -1,4 +1,4 @@
mpdscribble is a music player daemon client which submits information about
-tracks being played to audioscrobbler.
+tracks being played to Last.fm (formerly audioscrobbler).
-WWW: http://www.frob.nl/scribble.html
+WWW: http://mpd.wikia.com/wiki/Client:Mpdscribble
diff --git a/audio/mpdscribble/pkg-plist b/audio/mpdscribble/pkg-plist
new file mode 100644
index 000000000000..3109cae947b5
--- /dev/null
+++ b/audio/mpdscribble/pkg-plist
@@ -0,0 +1,8 @@
+bin/mpdscribble
+@unexec if cmp -s %D/etc/mpdscribble.conf.sample %D/etc/mpdscribble.conf; then rm -f %D/etc/mpdscribble.conf; fi
+etc/mpdscribble.conf.sample
+@exec [ -f %B/mpdscribble.conf ] || cp -p %B/%f %B/mpdscribble.conf
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%@dirrm %%DOCSDIR%%