aboutsummaryrefslogtreecommitdiff
path: root/audio/mpdscribble
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2008-06-01 12:34:11 +0000
committerRong-En Fan <rafan@FreeBSD.org>2008-06-01 12:34:11 +0000
commit883d02d83433128bbbba49d1610bc7af30d7a5f6 (patch)
tree8a51118c24dd2c279b13f4e3319e0c898f034ce4 /audio/mpdscribble
parent628d5af293ded58a7621f94931f9cae514f4329e (diff)
downloadports-883d02d83433128bbbba49d1610bc7af30d7a5f6.tar.gz
ports-883d02d83433128bbbba49d1610bc7af30d7a5f6.zip
- Do not assume /bin/sh is bash in setup.sh
- Install setup.sh as mpdscribble-setup which is required at runtime - Bump PORTREVISION PR: ports/122993 Submitted by: Sokolov Alexey <sokolov at truebsd.org>
Notes
Notes: svn path=/head/; revision=214120
Diffstat (limited to 'audio/mpdscribble')
-rw-r--r--audio/mpdscribble/Makefile6
-rw-r--r--audio/mpdscribble/files/patch-setup.sh20
2 files changed, 25 insertions, 1 deletions
diff --git a/audio/mpdscribble/Makefile b/audio/mpdscribble/Makefile
index 57b51bc75415..cca9ffd9cb25 100644
--- a/audio/mpdscribble/Makefile
+++ b/audio/mpdscribble/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mpdscribble
PORTVERSION= 0.2.12
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= http://www.frob.nl/projects/scribble/
@@ -18,6 +19,9 @@ LIB_DEPENDS= soup:${PORTSDIR}/devel/libsoup22
GNU_CONFIGURE= yes
MAN1= mpdscribble.1
-PLIST_FILES= bin/mpdscribble
+PLIST_FILES= bin/mpdscribble bin/mpdscribble-setup
+
+post-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/setup.sh ${PREFIX}/bin/mpdscribble-setup
.include <bsd.port.mk>
diff --git a/audio/mpdscribble/files/patch-setup.sh b/audio/mpdscribble/files/patch-setup.sh
new file mode 100644
index 000000000000..10b8d03b3a71
--- /dev/null
+++ b/audio/mpdscribble/files/patch-setup.sh
@@ -0,0 +1,20 @@
+--- setup.sh.orig 2008-06-01 19:53:53.000000000 +0800
++++ setup.sh 2008-06-01 19:54:16.000000000 +0800
+@@ -26,7 +26,7 @@
+ echo
+ echo "press ctrl-c to cancel if this is not intended."
+ echo "continue..."
+-read -s
++read
+
+ mkdir -p $CONF_DIR
+ mkdir -p $CACHE_DIR
+@@ -35,7 +35,7 @@
+ echo -n "Please enter your audioscrobbler username: "
+ read -e USERNAME
+ echo -n "and password: "
+-read -s -e PASSWORD
++read -e PASSWORD
+
+ echo "username = $USERNAME" > $LOGIN
+ chmod 600 $LOGIN