aboutsummaryrefslogtreecommitdiff
path: root/audio/mpg123.el
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2006-04-05 23:58:04 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2006-04-05 23:58:04 +0000
commit14bab967d8616ebed1ad2069661fbf4af20bdc7c (patch)
tree5ff702ea6f2aceb29dece3c6562dc9f5506369b9 /audio/mpg123.el
parent4c348c66bac9a39fbce34465ae8984a637fb4edf (diff)
downloadports-14bab967d8616ebed1ad2069661fbf4af20bdc7c.tar.gz
ports-14bab967d8616ebed1ad2069661fbf4af20bdc7c.zip
audio/mpg123.el: tidy up Makefile
- Tidy up Makefile and pkg-descr - Add pkg-message PR: ports/95382: Submitted by: Lars Engels <lars.engels@0x20.net>
Notes
Notes: svn path=/head/; revision=158909
Diffstat (limited to 'audio/mpg123.el')
-rw-r--r--audio/mpg123.el/Makefile7
-rw-r--r--audio/mpg123.el/pkg-descr6
-rw-r--r--audio/mpg123.el/pkg-message5
3 files changed, 11 insertions, 7 deletions
diff --git a/audio/mpg123.el/Makefile b/audio/mpg123.el/Makefile
index d85616459822..991e21744a9b 100644
--- a/audio/mpg123.el/Makefile
+++ b/audio/mpg123.el/Makefile
@@ -9,7 +9,7 @@ PORTNAME= mpg123.el
PORTVERSION= 1.40
CATEGORIES= audio elisp
MASTER_SITES= http://www.gentei.org/~yuuji/software/mpg123el/
-DISTNAME = ${PORTNAME}-${PORTVERSION}
+DISTNAME= ${PORTNAME}-${PORTVERSION}
EXTRACT_SUFX= # empty
EXTRACT_ONLY= # empty
@@ -25,7 +25,7 @@ NO_BUILD= yes
ELISPDIR= ${PREFIX}/share/emacs/site-lisp
XELISPDIR= ${PREFIX}/lib/xemacs/site-lisp
-myFETCH_CMD= /usr/bin/fetch -AR
+myFETCH_CMD= ${FETCH_CMD} -AR
do-fetch:
${myFETCH_CMD} ${FETCH_BEFORE_ARGS} ${MASTER_SITES}/mpg123el.cgi?${PORTVERSION}
@@ -37,4 +37,7 @@ do-install:
${MKDIR} ${XELISPDIR}
${LN} -sf ${ELISPDIR}/${PORTNAME} ${XELISPDIR}/${PORTNAME}
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
.include <bsd.port.mk>
diff --git a/audio/mpg123.el/pkg-descr b/audio/mpg123.el/pkg-descr
index 5f0cad253106..8da177da61dc 100644
--- a/audio/mpg123.el/pkg-descr
+++ b/audio/mpg123.el/pkg-descr
@@ -1,5 +1,5 @@
The mpg123.el Emacs-Lisp program is a front-end to mpg123/ogg123 audio player.
-You can select and play an mp3 files from the list in your Emacs's buffer with
+You can select and play an mp3 file from the list in your Emacs's buffer with
familiar interface.
Because mpg123.el is an Emacs-Lisp program and is written carefully to
@@ -8,8 +8,4 @@ recent one. Here is the list of environment where mpg123.el is reported to be
available. If you find mpg123 running on other platforms than below, please
tell me your environment.
-Put the expression below into your ~/.emacs.
-
-(autoload 'mpg123 "mpg123" "A Front-end to mpg123" t)
-
WWW: http://www.gentei.org/~yuuji/software/mpg123el/
diff --git a/audio/mpg123.el/pkg-message b/audio/mpg123.el/pkg-message
new file mode 100644
index 000000000000..3f1a2df4a612
--- /dev/null
+++ b/audio/mpg123.el/pkg-message
@@ -0,0 +1,5 @@
+------------------------------------------------------
+Put the expression below into your ~/.emacs.
+
+(autoload 'mpg123 "mpg123" "A Front-end to mpg123" t)
+------------------------------------------------------