aboutsummaryrefslogtreecommitdiff
path: root/audio/mpg123
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2016-09-06 16:28:46 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2016-09-06 16:28:46 +0000
commit8a934ece93cd6f5ff5ce016a149272c16e760c40 (patch)
tree80c15cbbce7d2d5b847ab345f860d21ea9b5f8fc /audio/mpg123
parent25139d644fc339d7b769436bab2c3e05a41126c5 (diff)
downloadports-8a934ece93cd6f5ff5ce016a149272c16e760c40.tar.gz
ports-8a934ece93cd6f5ff5ce016a149272c16e760c40.zip
audio/mpg123: add SNDIO option and cleanups
- add a SNDIO option that enables building of the audio/sndio output module - replace CPPFLAGS/LDFLAGS with USES=localbase - use INSTALL_TARGET=install-strip to strip libraries - bump PORTREVISION due to packaging change PR: 212406 Submitted by: Tobias Kortkamp
Notes
Notes: svn path=/head/; revision=421440
Diffstat (limited to 'audio/mpg123')
-rw-r--r--audio/mpg123/Makefile18
-rw-r--r--audio/mpg123/pkg-plist1
2 files changed, 14 insertions, 5 deletions
diff --git a/audio/mpg123/Makefile b/audio/mpg123/Makefile
index 68b5268ae1db..8bbb49f63c2f 100644
--- a/audio/mpg123/Makefile
+++ b/audio/mpg123/Makefile
@@ -3,6 +3,7 @@
PORTNAME= mpg123
PORTVERSION= 1.23.6
+PORTREVISION= 1
CATEGORIES= audio ipv6
MASTER_SITES= SF \
http://www.mpg123.de/download/
@@ -14,16 +15,23 @@ LICENSE= LGPL21
LIB_DEPENDS= libltdl.so:devel/libltdl
-USES= tar:bzip2 gmake libtool pathfix
+USES= tar:bzip2 gmake libtool localbase pathfix
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-optimization=0 \
- --with-audio=oss \
- --with-default-audio=oss \
--with-module-suffix=.so
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+
+INSTALL_TARGET= install-strip
+
+OPTIONS_DEFINE= SNDIO
+OPTIONS_SUB= yes
+
+SNDIO_CONFIGURE_ON= --with-audio=sndio,oss \
+ --with-default-audio=sndio
+SNDIO_CONFIGURE_OFF= --with-audio=oss \
+ --with-default-audio=oss
+SNDIO_LIB_DEPENDS= libsndio.so:audio/sndio
.include <bsd.port.pre.mk>
diff --git a/audio/mpg123/pkg-plist b/audio/mpg123/pkg-plist
index b7eaa10ba078..967c050d3abb 100644
--- a/audio/mpg123/pkg-plist
+++ b/audio/mpg123/pkg-plist
@@ -13,6 +13,7 @@ lib/libout123.so.0
lib/libout123.so.0.1.4
lib/mpg123/output_dummy.so
lib/mpg123/output_oss.so
+%%SNDIO%%lib/mpg123/output_sndio.so
libdata/pkgconfig/libmpg123.pc
libdata/pkgconfig/libout123.pc
man/man1/out123.1.gz