aboutsummaryrefslogtreecommitdiff
path: root/audio/muine
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-07-24 16:37:31 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-07-24 16:37:31 +0000
commitd8503d22039cb6a21499417db24db620c2af4764 (patch)
tree1646d8c83b99dc390913924ba4c7bca4e68faac8 /audio/muine
parent3f9f552737f513090e61a3293c3b079900fd6000 (diff)
downloadports-d8503d22039cb6a21499417db24db620c2af4764.tar.gz
ports-d8503d22039cb6a21499417db24db620c2af4764.zip
Notes
Diffstat (limited to 'audio/muine')
-rw-r--r--audio/muine/Makefile37
-rw-r--r--audio/muine/distinfo2
-rw-r--r--audio/muine/files/patch-src_muine.exe.config.in11
-rw-r--r--audio/muine/pkg-descr12
-rw-r--r--audio/muine/pkg-plist37
5 files changed, 99 insertions, 0 deletions
diff --git a/audio/muine/Makefile b/audio/muine/Makefile
new file mode 100644
index 000000000000..6e25259aafda
--- /dev/null
+++ b/audio/muine/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: muine
+# Date created: 20040615
+# Whom: Tom McLaughlin <tmclaugh@sdf.lonestar.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= muine
+PORTVERSION= 0.6.3
+CATEGORIES= audio gnome
+MASTER_SITES= http://muine.gooeylinux.org/
+
+MAINTAINER= tmclaugh@sdf.lonestar.org
+COMMENT= Mono based Gnome audio player
+
+LIB_DEPENDS= xine.9:${PORTSDIR}/multimedia/libxine \
+ FLAC.5:${PORTSDIR}/audio/flac \
+ id3tag.2:${PORTSDIR}/audio/libid3tag \
+ gdbm:${PORTSDIR}/databases/gdbm
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/gtk-sharp.pc:${PORTSDIR}/x11-toolkits/gtk-sharp
+RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/gtk-sharp.pc:${PORTSDIR}/x11-toolkits/gtk-sharp
+
+USE_X_PREFIX= yes
+USE_GNOME= gnomeprefix gnomehack intltool libgnomeui
+USE_LIBTOOL_VER=15
+USE_REINPLACE= yes
+
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+GLIB_MIVER= 400
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%GLIB_MIVER%%|${GLIB_MIVER}|g' \
+ ${WRKSRC}/src/muine.exe.config.in
+
+.include <bsd.port.mk>
diff --git a/audio/muine/distinfo b/audio/muine/distinfo
new file mode 100644
index 000000000000..aaa35942c30f
--- /dev/null
+++ b/audio/muine/distinfo
@@ -0,0 +1,2 @@
+MD5 (muine-0.6.3.tar.gz) = dc7923e1e0ba87f0303bc30f14f604e3
+SIZE (muine-0.6.3.tar.gz) = 624566
diff --git a/audio/muine/files/patch-src_muine.exe.config.in b/audio/muine/files/patch-src_muine.exe.config.in
new file mode 100644
index 000000000000..9006c188b055
--- /dev/null
+++ b/audio/muine/files/patch-src_muine.exe.config.in
@@ -0,0 +1,11 @@
+--- src/muine.exe.config.in.orig Sat Jun 5 12:48:33 2004
++++ src/muine.exe.config.in Thu Jul 15 21:59:47 2004
+@@ -1,6 +1,6 @@
+ <configuration>
+- <dllmap dll="libglib-2.0-0.dll" target="libglib-2.0.so.0"/>
+- <dllmap dll="libgobject-2.0-0.dll" target="libgobject-2.0.so.0"/>
++ <dllmap dll="libglib-2.0-0.dll" target="libglib-2.0.so.%%GLIB_MIVER%%"/>
++ <dllmap dll="libgobject-2.0-0.dll" target="libgobject-2.0.so.%%GLIB_MIVER%%"/>
+ <dllmap dll="libgnomevfs-2.dll" target="libgnomevfs-2.so"/>
+ <dllmap dll="libmuine" target="@prefix@/lib/muine/libmuine.so"/>
+ </configuration>
diff --git a/audio/muine/pkg-descr b/audio/muine/pkg-descr
new file mode 100644
index 000000000000..bb5e79c228f6
--- /dev/null
+++ b/audio/muine/pkg-descr
@@ -0,0 +1,12 @@
+Muine is a music player for GNOME using Mono. It features:
+
+* A simple, intuitive user interface
+* Ogg Vorbis, FLAC and MP3 music playback support
+* Automatic album-cover fetching
+* Support for embedded ID3v2 album images
+* ReplayGain support
+* Support for multiple artist and performer tags per song
+* A system tray icon
+* Translations into many languages
+
+WWW: http://muine.gooeylinux.org/
diff --git a/audio/muine/pkg-plist b/audio/muine/pkg-plist
new file mode 100644
index 000000000000..1fffc73720c3
--- /dev/null
+++ b/audio/muine/pkg-plist
@@ -0,0 +1,37 @@
+bin/muine
+@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/muine.schemas > /dev/null || /usr/bin/true
+etc/gconf/schemas/muine.schemas
+@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/muine.schemas > /dev/null || /usr/bin/true
+lib/muine/AmazonSearchService.dll
+lib/muine/libmuine.a
+lib/muine/libmuine.so
+lib/muine/libmuine.so.0
+lib/muine/muine.exe
+lib/muine/muine.exe.config
+share/gnome/application-registry/muine.applications
+share/gnome/applications/muine.desktop
+share/gnome/pixmaps/muine.png
+share/locale/bg/LC_MESSAGES/muine.mo
+share/locale/ca/LC_MESSAGES/muine.mo
+share/locale/cs/LC_MESSAGES/muine.mo
+share/locale/da/LC_MESSAGES/muine.mo
+share/locale/de/LC_MESSAGES/muine.mo
+share/locale/en_CA/LC_MESSAGES/muine.mo
+share/locale/en_GB/LC_MESSAGES/muine.mo
+share/locale/es/LC_MESSAGES/muine.mo
+share/locale/eu/LC_MESSAGES/muine.mo
+share/locale/fr/LC_MESSAGES/muine.mo
+share/locale/hr/LC_MESSAGES/muine.mo
+share/locale/hu/LC_MESSAGES/muine.mo
+share/locale/is/LC_MESSAGES/muine.mo
+share/locale/ja/LC_MESSAGES/muine.mo
+share/locale/ko/LC_MESSAGES/muine.mo
+share/locale/nl/LC_MESSAGES/muine.mo
+share/locale/no/LC_MESSAGES/muine.mo
+share/locale/pl/LC_MESSAGES/muine.mo
+share/locale/pt/LC_MESSAGES/muine.mo
+share/locale/pt_BR/LC_MESSAGES/muine.mo
+share/locale/sr/LC_MESSAGES/muine.mo
+share/locale/sr@Latn/LC_MESSAGES/muine.mo
+share/locale/sv/LC_MESSAGES/muine.mo
+@dirrm lib/muine