aboutsummaryrefslogtreecommitdiff
path: root/audio/musicpc
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2018-11-10 10:42:39 +0000
committerThomas Zander <riggs@FreeBSD.org>2018-11-10 10:42:39 +0000
commit84d189608c65a0fc8330551562f4c4ac6da04bbe (patch)
treef7e8e880d0dcd0a79d85665cf38df992ffbb3185 /audio/musicpc
parent6f65ece3f534a5ae7b4db14040e96e451bcd6658 (diff)
downloadports-84d189608c65a0fc8330551562f4c4ac6da04bbe.tar.gz
ports-84d189608c65a0fc8330551562f4c4ac6da04bbe.zip
Update to upstream version 0.31
Details: - Add commands "queued", "seekthrough", "mount", "unmount" - Support "search" with filter expression (MPD 0.21) - Support "load" with range - Allow only tag names after "list" - Upstream log see https://raw.githubusercontent.com/MusicPlayerDaemon/mpc/v0.31/NEWS PR: 232854 Submitted by: uzsolt@uzsolt.hu (maintainer) MFH: 2018Q4
Notes
Notes: svn path=/head/; revision=484602
Diffstat (limited to 'audio/musicpc')
-rw-r--r--audio/musicpc/Makefile20
-rw-r--r--audio/musicpc/distinfo6
-rw-r--r--audio/musicpc/files/patch-doc_meson.build49
-rw-r--r--audio/musicpc/files/patch-meson.build8
-rw-r--r--audio/musicpc/files/patch-meson__options.txt14
-rw-r--r--audio/musicpc/pkg-plist30
6 files changed, 54 insertions, 73 deletions
diff --git a/audio/musicpc/Makefile b/audio/musicpc/Makefile
index e7a109bcb2f4..83db35fb09af 100644
--- a/audio/musicpc/Makefile
+++ b/audio/musicpc/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= musicpc
-DISTVERSION= 0.30
+DISTVERSION= 0.31
CATEGORIES= audio ipv6
MASTER_SITES= http://www.musicpd.org/download/mpc/0/
DISTNAME= mpc-${PORTVERSION}
@@ -18,21 +18,19 @@ LIB_DEPENDS= libmpdclient.so:audio/libmpdclient
USES= meson pkgconfig tar:xz
MESON_ARGS= --mandir=${MANPREFIX}
-PLIST_FILES= bin/mpc
+OPTIONS_DEFINE= DOCS ICONV
+OPTIONS_DEFAULT= DOCS ICONV
-OPTIONS_DEFINE= DOCS EXAMPLES MANPAGES ICONV
-OPTIONS_DEFAULT= MANPAGES ICONV
-
-MANPAGES_USES= python:env
-MANPAGES_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>0:textproc/py-sphinx@${PY_FLAVOR}
-MANPAGES_MESON_TRUE= use_sphinx
-MANPAGES_PLIST_FILES= man/man1/mpc.1.gz
+DOCS_USES= python:env
+DOCS_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>0:textproc/py-sphinx@${PY_FLAVOR}
+DOCS_MESON_ON= -Ddocumentation=enabled
+DOCS_MESON_OFF= -Ddocumentation=disabled
ICONV_USES= iconv
ICONV_LDFLAGS= -L${ICONV_PREFIX}/lib ${ICONV_LIB}
-ICONV_MESON_TRUE= iconv
+ICONV_MESON_ON= -Diconv=enabled
+ICONV_MESON_OFF= -Diconv=disabled
PORTDOCS= AUTHORS README.rst NEWS
-PORTEXAMPLES= *
.include <bsd.port.mk>
diff --git a/audio/musicpc/distinfo b/audio/musicpc/distinfo
index 3f7a8f185037..1cbfca90cdf3 100644
--- a/audio/musicpc/distinfo
+++ b/audio/musicpc/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1529036000
-SHA256 (mpc-0.30.tar.xz) = 65fc5b0a8430efe9acbe6e261127960682764b20ab994676371bdc797d867fce
-SIZE (mpc-0.30.tar.xz) = 41968
+TIMESTAMP = 1540994707
+SHA256 (mpc-0.31.tar.xz) = 62373e83a8a165b2ed43967975efecd3feee530f4557d6b861dd08aa89d52b2d
+SIZE (mpc-0.31.tar.xz) = 43896
diff --git a/audio/musicpc/files/patch-doc_meson.build b/audio/musicpc/files/patch-doc_meson.build
index ad28aebd1404..aea102d0ef89 100644
--- a/audio/musicpc/files/patch-doc_meson.build
+++ b/audio/musicpc/files/patch-doc_meson.build
@@ -1,42 +1,9 @@
---- doc/meson.build.orig 2018-06-15 04:16:53 UTC
+--- doc/meson.build.orig 2018-10-24 08:31:33 UTC
+++ doc/meson.build
-@@ -1,16 +1,19 @@
--sphinx = find_program('sphinx-build', required:false)
--
--if sphinx.found()
-- custom_target(
-- 'HTML documentation',
-- output: 'html',
-- input: ['index.rst', 'conf.py'],
-- command: [sphinx, '-q', '-b', 'html', '-d', '@OUTDIR@/doctrees', meson.current_source_dir(), '@OUTPUT@'],
-- build_by_default: true,
-- install: true,
-- install_dir: join_paths(get_option('datadir'), 'doc', meson.project_name()),
-- )
-+use_sphinx = get_option('use_sphinx')
-
-+if use_sphinx == 'false'
-+ use_sphinx = false
-+elif use_sphinx == 'true'
-+ sphinx = find_program('sphinx-build', required:false)
-+ if not sphinx.found()
-+ error('can\'t find sphinx')
-+ endif
-+ use_sphinx = true
-+else
-+ sphinx = find_program('sphinx-build', required:false)
-+ use_sphinx = sphinx.found()
-+endif
-+
-+if use_sphinx
- custom_target(
- 'Manpage documentation',
- output: 'man',
-@@ -18,6 +21,6 @@ if sphinx.found()
- command: [sphinx, '-q', '-b', 'man', '-d', '@OUTDIR@/doctrees', meson.current_source_dir(), '@OUTPUT@/man1'],
- build_by_default: true,
- install: true,
-- install_dir: get_option('datadir'),
-+ install_dir: get_option('mandir'),
- )
- endif
+@@ -15,5 +15,5 @@ custom_target(
+ command: [sphinx, '-q', '-b', 'man', '-d', '@OUTDIR@/doctrees', meson.current_source_dir(), '@OUTPUT@/man1'],
+ build_by_default: true,
+ install: true,
+- install_dir: get_option('datadir'),
++ install_dir: get_option('mandir'),
+ )
diff --git a/audio/musicpc/files/patch-meson.build b/audio/musicpc/files/patch-meson.build
index 8cc29e48402e..6abdf9c5e29b 100644
--- a/audio/musicpc/files/patch-meson.build
+++ b/audio/musicpc/files/patch-meson.build
@@ -1,12 +1,12 @@
---- meson.build.orig 2018-05-03 10:27:29 UTC
+--- meson.build.orig 2018-10-24 08:31:33 UTC
+++ meson.build
@@ -1,4 +1,4 @@
-project('mpc', 'c',
+project('musicpc', 'c',
- version: '0.30',
+ version: '0.31',
+ meson_version: '>= 0.47',
default_options: [
- 'c_std=c99',
-@@ -101,13 +101,13 @@ executable('mpc',
+@@ -109,13 +109,13 @@ executable('mpc',
install: true
)
diff --git a/audio/musicpc/files/patch-meson__options.txt b/audio/musicpc/files/patch-meson__options.txt
deleted file mode 100644
index 3c7fa5076539..000000000000
--- a/audio/musicpc/files/patch-meson__options.txt
+++ /dev/null
@@ -1,14 +0,0 @@
---- meson_options.txt.orig 2018-02-27 07:50:47 UTC
-+++ meson_options.txt
-@@ -3,6 +3,11 @@ option('iconv', type: 'combo',
- value: 'auto',
- description: 'Enable iconv() support')
-
-+option('use_sphinx', type: 'combo',
-+ choices: ['true', 'false', 'auto'],
-+ value: 'auto',
-+ description: 'Enable sphinx support for building documentation')
-+
- option('test', type: 'boolean',
- value: false,
- description: 'Enable unit tests')
diff --git a/audio/musicpc/pkg-plist b/audio/musicpc/pkg-plist
new file mode 100644
index 000000000000..19c202a2102e
--- /dev/null
+++ b/audio/musicpc/pkg-plist
@@ -0,0 +1,30 @@
+bin/mpc
+%%PORTDOCS%%%%DOCSDIR%%/html/.buildinfo
+%%PORTDOCS%%%%DOCSDIR%%/html/_sources/index.rst.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/_static/ajax-loader.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/_static/alabaster.css
+%%PORTDOCS%%%%DOCSDIR%%/html/_static/basic.css
+%%PORTDOCS%%%%DOCSDIR%%/html/_static/comment-bright.png
+%%PORTDOCS%%%%DOCSDIR%%/html/_static/comment-close.png
+%%PORTDOCS%%%%DOCSDIR%%/html/_static/comment.png
+%%PORTDOCS%%%%DOCSDIR%%/html/_static/doctools.js
+%%PORTDOCS%%%%DOCSDIR%%/html/_static/down-pressed.png
+%%PORTDOCS%%%%DOCSDIR%%/html/_static/down.png
+%%PORTDOCS%%%%DOCSDIR%%/html/_static/file.png
+%%PORTDOCS%%%%DOCSDIR%%/html/_static/jquery-3.1.0.js
+%%PORTDOCS%%%%DOCSDIR%%/html/_static/jquery.js
+%%PORTDOCS%%%%DOCSDIR%%/html/_static/minus.png
+%%PORTDOCS%%%%DOCSDIR%%/html/_static/plus.png
+%%PORTDOCS%%%%DOCSDIR%%/html/_static/pygments.css
+%%PORTDOCS%%%%DOCSDIR%%/html/_static/searchtools.js
+%%PORTDOCS%%%%DOCSDIR%%/html/_static/underscore-1.3.1.js
+%%PORTDOCS%%%%DOCSDIR%%/html/_static/underscore.js
+%%PORTDOCS%%%%DOCSDIR%%/html/_static/up-pressed.png
+%%PORTDOCS%%%%DOCSDIR%%/html/_static/up.png
+%%PORTDOCS%%%%DOCSDIR%%/html/_static/websupport.js
+%%PORTDOCS%%%%DOCSDIR%%/html/genindex.html
+%%PORTDOCS%%%%DOCSDIR%%/html/index.html
+%%PORTDOCS%%%%DOCSDIR%%/html/objects.inv
+%%PORTDOCS%%%%DOCSDIR%%/html/search.html
+%%PORTDOCS%%%%DOCSDIR%%/html/searchindex.js
+%%PORTDOCS%%man/man1/mpc.1.gz