aboutsummaryrefslogtreecommitdiff
path: root/audio/musicpc
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2013-11-26 14:02:43 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2013-11-26 14:02:43 +0000
commitb4dbc62588c2dd28a0fc058667a593fae4fe5414 (patch)
tree4624ae5c809b1c7ba0656e8ff946442aeb236df0 /audio/musicpc
parentf06302722b7e2e0397b7a6c4d6e497f8bca2d9fc (diff)
downloadports-b4dbc62588c2dd28a0fc058667a593fae4fe5414.tar.gz
ports-b4dbc62588c2dd28a0fc058667a593fae4fe5414.zip
Rename audio/mpc to audio/musicpc to avoid a package name conflict
with math/mpc. [1] Adjust to new LIB_DEPENDS standard. Broker a maintainer handover. [2] Approved by: portmgr (bapt) [1] Mark Reidel <ports@mark.reidel.info> (old maintainer) [2] gblach (new maintainer) [2]
Notes
Notes: svn path=/head/; revision=334933
Diffstat (limited to 'audio/musicpc')
-rw-r--r--audio/musicpc/Makefile61
-rw-r--r--audio/musicpc/distinfo2
-rw-r--r--audio/musicpc/pkg-descr5
3 files changed, 68 insertions, 0 deletions
diff --git a/audio/musicpc/Makefile b/audio/musicpc/Makefile
new file mode 100644
index 000000000000..d124e0770e9f
--- /dev/null
+++ b/audio/musicpc/Makefile
@@ -0,0 +1,61 @@
+# Created by: Mark Reidel <ports@mark.reidle.info>
+# $FreeBSD$
+
+PORTNAME= musicpc
+PORTVERSION= 0.22
+CATEGORIES= audio ipv6
+MASTER_SITES= SF/musicpd/mpc/${PORTVERSION}/
+DISTNAME= mpc-${PORTVERSION}
+
+MAINTAINER= gblach@FreeBSD.org
+COMMENT= Command line client for the musicpd
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libmpdclient.so:${PORTSDIR}/audio/libmpdclient
+
+OPTIONS_DEFINE= EXAMPLES DOCS ICONV
+OPTIONS_DEFAULT= ICONV
+
+USES= pkgconfig
+NO_STAGE= yes
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+LDFLAGS+= -L${LOCALBASE}/lib
+CFLAGS+= -I${LOCALBASE}/include
+
+MAN1= mpc.1
+
+PORTDOCS= AUTHORS README NEWS
+PORTEXAMPLES= *
+
+PLIST_FILES= bin/mpc
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MICONV}
+USES+= iconv
+LDFLAGS+= ${ICONV_LIB}
+.else
+CONFIGURE_ARGS+=--disable-iconv
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lintl|${ICONV_LIB}|g' ${WRKSRC}/configure
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/mpc ${PREFIX}/bin
+
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
+
+.if ${PORT_OPTIONS:MEXAMPLES}
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/mpc-completion.bash ${EXAMPLESDIR}
+.endif
+
+ ${INSTALL_MAN} ${WRKSRC}/doc/${MAN1} ${MAN1PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/audio/musicpc/distinfo b/audio/musicpc/distinfo
new file mode 100644
index 000000000000..6e1053be24ca
--- /dev/null
+++ b/audio/musicpc/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mpc-0.22.tar.bz2) = cc42811d7ed8e65d50a0aaf1edf29597e3e264b06026b40da88a8a763a2dd334
+SIZE (mpc-0.22.tar.bz2) = 102296
diff --git a/audio/musicpc/pkg-descr b/audio/musicpc/pkg-descr
new file mode 100644
index 000000000000..ac2ba1d04a45
--- /dev/null
+++ b/audio/musicpc/pkg-descr
@@ -0,0 +1,5 @@
+A client for MPD, the Music Player Daemon.
+mpc connects to a MPD running on a machine via a network.
+Read more about MPD on http://www.musicpd.org
+
+WWW: http://www.musicpd.org